Ford Mustang Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,192 Posts
Discussion Starter #1
yeah im a dumbass. been having a problem with my car running hot after turbo install. two days ago i switched to a markIII fan and everything was great. drove it today and got hot within a couple of minutes.
"pissed". so after looking everything over i realized i forgot to close the drain on my radiator after fan install and all my coolant leaked out. closed drain all the way, filled rad and like magic it ran cooler. the moral of the story is not to overlook the little things. leason learned, i was lucky.
 

·
Registered
Joined
·
70 Posts
Glad to Hear It's OK

Glad to hear the car is running good and cool.

I really appreciate you calling me back (mid June ish) and giving me your lessons learned on the turbo kit. I'll add the rad drain plug to the list.

Steve
 

·
Registered
Joined
·
705 Posts
Haha you MAY regret posting this thread... Lol....
 

·
Registered
Joined
·
705 Posts
Some Texas tea too...
 

·
Registered
Joined
·
7,597 Posts
Car runs hot with no coolant
For some reason mine likes oil in it too. Go figure??
how does it react to gasoline ;)

don't feel bad about the bs although i hope you didn't let it overheat. we all do dumb ass #### from time to time, example being, back in the day while installing edlebrock performer intake i was clever to stuff a rag inside the upper so that the bolt that mounts inside wouldn't by chance fall inside... well, the car started up and ran great for about a minute and then would run like ####, so i pull the #1 plug and guess what comes out with it...

paul
 

·
Registered
Joined
·
1,192 Posts
Discussion Starter #7
no i shut it down cause the temp came up way too fast. i was watching it cause of the recent fan swap so as soon as i saw something was wrong i was able to shut it down. i just wanted to share my dumb move as a lesson for everyone to pay attention to the small things.
heres a couple of pics.




 

·
Registered
Joined
·
6,671 Posts
Just a friendly ribbing. Anyone who ever works on cars enough has had a moment.
I once forgot to put the bolt back in the pan during an oil change. As I'm refilling the car with fresh oil a huge puddle was forming at my feet.
BTW, great looking car. I bet she's a beast!
 

·
Registered
Joined
·
1,192 Posts
Discussion Starter #10
yeah its a lot of fun to drive. pretty hard to drive slow. that turbo sound and feel is like crack. just cant get enough.
 

·
Registered
Joined
·
1,274 Posts
Make sure your lower rad hose isn't sitting up against the crossover too, mine was. Keyword...was. It ended up in a giant cloud of steam yesterday.

Nice notch!
 

·
Registered
Joined
·
1,192 Posts
Discussion Starter #12
been there done that. you dont realize it til its too late. i cut the new one down and made it quite a bit shorter. live and learn!
 
1 - 15 of 15 Posts
Top