Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
so i got this 95 mustang. turbocharged about 2 weeks ago. car seemed fine except it would start running hot if you drove it too long and i was told it needed a good rsadiator and fan instead of the stock rad and fan. so i put a new aluminum rad and 2800 cfm fans. here is what happens...car won't get hot if i baby it and don't get into boost. it has a t-60 turbo, stock heads, e-cam. so when i changed the radiator and fan i took it for a test drive. getting the turbo spooled up and beating it a bit to see if it could take it. well it got too hot again. the radiator and fan set-up should be able to handle cooling this engine without much problems. it is also putting a significant amount of white smoke out of the tailpipes. i'm thinking it has a blown headgasket. why wouldn't it be overheating until you let it get into boost though? alos i noticed what i think is too much bubbling in the radiator with the cap off. the oil looks good though...not milky at all and very clean. the antifreeze doesn't look like there is any oil in it either. its just weird to me that it runs pretty cool until i tach it out a bit and let the turbo spool up.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
It could be your stock heads lifting when you get into boost, that would create alot of problems.


is that something that happens with stock heads for some reason? its supposedly only running 8psi. i just drove it home which is a 20 minute ride. just babying it and it got pretty hot. which it didn't do before today really. also no heat....even though the heat worked fine this morning. something else i noticed which i found odd.....it has a fluidyne 2 core rad with a 2800cfm be cool dual fan set-up. the left fan (passenger side) was blowing warm air and the right fan (driver side) was blowing cold air. it has a 160 stat in it.
 

·
Registered
Joined
·
444 Posts
what is your afr at are u on pump gas or e85 has it been tuned or are u doing it what is the timing set u may have let a head gasket go check with rad cap off when starting if its spews u blew it
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
what is your afr at are u on pump gas or e85 has it been tuned or are u doing it what is the timing set u may have let a head gasket go check with rad cap off when starting if its spews u blew it

not sure what the afr is at...but i'm pretty sure it is running rich. this is on pump gas......super. it was tuned by radical racing when it was first built. i'm gonna check again in the morning but i think it is starting to spew when it is startd when the radiator cap is off.......which was another reason i thought head gasket......not sure what the timing is at never checked it. i didnt want to #### with it since i assume it was set when it was tuned. never had a turbo car and i didn't want to start messing with the timing.
 
1 - 6 of 6 Posts
Top