Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,096 Posts
Discussion Starter #1
Hey Corral,

So I dropped my 90 LX off at tuner to get tuned and received a call from them saying one of the pins on my A3M1 ECU broke off while disconnecting the harness.

Anyone have experience with this? Is it fixable by soldering a new pin?

I cannot find a replacement ECU for a reasonable price so I’ve been looking for Cardone’s but everywhere is out of stock.

I’ve already called a local place that remanufactures ECU’s and they said they can’t fix broken pins.

Any help would be appreciated. Thanks.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
23,262 Posts
Depending on how it is broken, it can be repaired if you have the tools and patience

Other wise you could add a wire instead to the board with a bullet connector outside the connector
 

·
Registered
Joined
·
1,096 Posts
Discussion Starter #3
Depending on how it is broken, it can be repaired if you have the tools and patience

Other wise you could add a wire instead to the board with a bullet connector outside the connector

Picking it up as we speak. Found a computer repair place that was able to reuse the existing pin and solder it back into place. Took him a couple hours but he was able to fix it. It was the #60 pin so it was in the back 2 rows behind 2 other pins. Definitely tough but it looks like it came out well.

Heading to the tuner right after I leave to see how it works! Thanks for the reply Indy2000. You’re always willing to lend some advice.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,096 Posts
Discussion Starter #4
FWIW ECU is working again!!! Tune still isn’t done though, full throttle anyways, because clutch was slipping at around 400hp/450tq.

Swapping clutch to my Spec stage 2 I had from my previous notch then bringing it back to finish tune.


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top