Ford Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
I had the dealership put 2013 GT500 front brakes on my 2013 GT (because it was free in the deal of buying my car from them) and they squeal from 5mph to zero. It's only when I'm at the end of my braking when coming to a stop. It's not too aggressive but I've noticed it does it always when cold. It's hit or miss when hot.

I've never really ever had to deal with squealing brakes so looking for suggestions.

Surely this isn't the nature of the beast is it?


Sent from my iPhone
 

·
Registered
Joined
·
424 Posts
The brakes on my '13 Shelby has never squealed. I would guess that the dealership left some grime or oil on the rotors/pads when they installed it on your GT (assuming everything is new and bedded correctly).
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
Anyone else have any suggestions?
I pulled the calipers and rotors off the car. They looked fine. I cleaned the heck out of the rotors and pads with brake clean.

Drove it around and the squeal is almost gone. There's a lot less noise but it squealed about 3 times in a 20 mile inner city drive.

It doesn't squeal when cold any more. Now it's only when their warm and only from 10-0mph slowing down on occasion.

It's just really annoying when the car and brakes are brand new.


Sent from my iPhone
 

·
Registered
Joined
·
935 Posts
FWIW, I know they're a little different, but the brakes on my '12 GT500 do the exact same thing. Somewhat annoying, but fairly intermittent so it hasn't been a big enough issue to try and track down. Been thinking of upgrading to Super Snake brakes anyway.

Subscribing to see if there's fix though.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #6
I'd say the same thing about mine. Somewhat intermittent but annoying.


Sent from my iPhone
 

·
Registered
Joined
·
5,686 Posts
Its the Brembos.. they do it on the Brembo Brake GTs as well. Mine do it.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #8
Is this a result of the compound of the pad?

Or improper bedding?

Anyone have any input?


Sent from my iPhone
 
1 - 9 of 9 Posts
Top