Ford Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I have a 92 coupe with a aod with a 2500 stall and 373 gears and a 150 shot. Going down the track just on motor it shifts fine doing the aod shuffle. On spray it doesnt like to shift until about a full second later. For instance, the shift lite comes on at 5200 but it wont shift till around 6000. Is this normal for aods? Just trying to figure the car out. TIA
 

·
Registered
Joined
·
318 Posts
I am running a 150 shot on my 91 GT Auto and I guess mine seems to shift a little bit later it seems on the bottle. But then again it could be me being a bit paranoid since I don't have an "off" pill right now in my window switch. You have a shift kit? If so, which one?
 

·
Registered
Joined
·
64 Posts
Discussion Starter #4
Just a B and M one. Seems like to me on the bottle mine doesnt want to shift. It does but it takes forevor
 

·
Registered
Joined
·
969 Posts
When the motor is on NOS things happen much faster. From your description, it sounds like the AOD isn't up to par. I don't recommend going with a manual VB instead, check out Dan from SilverFoxTransmissions. He can surely help you out.
 

·
Registered
Joined
·
477 Posts
My car seems a little lazy going into drive, the shift is still firm but maybe a 1/4 sec delay whether on motor or N2O. Second gear is always immediate though, doesn't matter. Don't know what shift kit I have, was in the car when I bought it.
I/m thinking about a Silverfox VB for mine, along with an Edge 3000 stall...
 
1 - 9 of 9 Posts
Top