Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7,142 Posts
Discussion Starter #1
OK, gonna try to make this simple as possible. Weather was nearly identical on both days. Last week, the 12.033 @117.16 is the first timeslip. I think my clutch has to be slipping a little, because I am making the power(118.52 mph trap this week), shifting perfect, and cutting a decent 1.70 short time. The car is heavy,but not a total boat anchor either @ 3330lb with me in it. This week I even trapped 94.08 mph in the 1/8th, with an even better short time. I have no idea how long the King cobra clutch has been in the car, but it has slipped here and there before a little. Here's the slips. With those short times,and the car weight, this thing should be running a good 11.8's-11.9's. I do have a new clutch on order also.

Last week.
60' 1.726
330 5.011
1/8 7.725
MPH 91.56
1000 10.069
1/4 12.033
MPH 117.16

This week
60' 1.702
330 5.032
1/8 7.752
MPH 94.08
1000 10.132
1/4 12.101
MPH 118.52
 

·
Registered
Joined
·
4,370 Posts
Yeah I think should be in the 90's anyway.
 

·
Registered
Joined
·
7,030 Posts
That is enough MPH to go 11.40's

I went 11.60 at 114

Tim
 

·
Registered
Joined
·
7,142 Posts
Discussion Starter #5
Definitly 11.40's if not a 30. CHANGE the clutch and also what gear are you running?
John, currently running 3.73 with a 26" ET street (10.5) Going through the traps at 5700. I am doing a 31 spline axle conv., and the new clutch in 2 weeks.
 

·
Registered
Joined
·
4,370 Posts
Clutch slipping more than I thought I guess.
 
1 - 6 of 6 Posts
Top