Ford Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
475 Posts
Discussion Starter #1
I've looked at other airbag threads and tried the reset as linked to a YouTube video. Well that didn't work.

Here are my current problems:

1. Parasitic draw that is draining battery.

2. 5 beeps for three times after starting for the airbag. I tried to reset it with a paperclip after the beeping stops with the key on, and it did not work. I did check the airbag fuse and it was burned, so I did swap it out. Still the reset process did not work.

I did swap the steering wheel with airbag along with passenger airbag from tan to black. I've had this problem ever since. The airbag unit behind the stereo is plugged in and both the steering wheel and passenger airbags are plugged into the factory wiring harness.

3. My Cruise Control no longer works. This happened after the steering column was swapped out too. Is there a testing process for this figuring out what is wrong with the CC circuit and components?

Thanks Corral!
 

·
Registered
Joined
·
1,687 Posts
cruise control problem might be at your brake pedal switch.
No thoughts for the air bags, other than the bag module , that I assume is on the trans hump .
 

·
Registered
Joined
·
23,260 Posts
what clock spring did you use?
 

·
Registered
Joined
·
475 Posts
Discussion Starter #4
The bag module is the same and worked before and bags have never gone off in this vehicle.
 

·
Registered
Joined
·
475 Posts
Discussion Starter #5
The clock spring is a good question. The black steering column was not a cobra and neither is my GT (both have pony emblem on driver airbag cover). I will have to pull the driver air bag off and clock spring off of both the tan one I removed and compare it to the entire steering column that was black that was replaced. I'll have to look at this in about a week. Thanks for the question!
 
1 - 5 of 5 Posts
Top