Ford Mustang Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I'm getting REALLY tired of the neverending problems with the car. Last week I had the MAF go bad - causing me undo problems. Replaced that today and the car is running normally, however the pump for the after-cooler is not working now.
Top this off tonight I went out to move the car into the driveway and low and behold - the damn theft light is on.

Does anyone have any clue how the theft light works and how I can shut it off? The suposedly code locked, micro chipped key is in the damn ignition. Any ideas how to resolve this? Any ideas as to why all this is happening?
 

·
Registered
Joined
·
5,172 Posts
if you want a car with that kind of horsepower, you're gonna have to deal with little things like that. The Z06 is a great car but It has about half the hp your car does...thats a big drop.
 

·
Registered
Joined
·
118 Posts
here is another option. Buy a new or used C5. Then send it to lingenfelter. Have them drop in their 427 TT package. If I remember correctly, that puts out 725 hp. This is just an option.
 

·
Registered
Joined
·
188 Posts
I'll trade you a 400rwhp Naturally aspirated Cobra for your 660rwhp Cobra!!!

Just keep it full of gas and oil that's all it takes :)
 

·
Registered
Joined
·
113 Posts
YOU LEAVING

You going from Ford to Chevy, we will miss ya :)
 

·
Registered
Joined
·
1,098 Posts
I wish I could offer some help, but I can't. All I can say is that I know how discouraging it can get... I am sure we all get down once in a while.

Take for instance my cobra. I took it to get aligned and they can't align it because I don't have enough adjustment in the stock plates. All I changed since the last alignment was the K-Member, Longtubes, sway bar end links, etc. So after having spent $1400 on all those parts, I still can't drive the car until I get my MM C/C plates installed and the car aligned! There goes another $200 that wasn't in my "budget" this season. :(

Your problems are going to be fairly simple to fix. Explain in more detail what the problem with your key is? Maybe take it to Ford and have them reprogram a new key for you. Should cost you $40 tops. Then your pump stopped working for the aftercooler... buy a new one.

If the car causes you too much grief, get rid of it. However, these seem to be fairly simple/cheap fixes right now. I realize it is irritating and that it seems to be a never ending battle, but I doubt you would be happy with a stock Z06.... mods would follow and so would the same annoyances that you are fighting right now.

Best of luck.
 

·
Registered
Joined
·
284 Posts
Supercharging = headaches

I've been N/A for several years now after having three different blowers. They make the power, though!

The draw to the Z06 for me is how easy it is to make power N/A relatively problem free. Yeah, you'll make more power with a blower car, but how much traction are you going to get on the street anyways? I'm not saying you should buy one though. But I will be...

Give me a light car with 350-400 rwhp any day! Just my opinions.

Randy
 

·
Registered
Joined
·
2,852 Posts
Guido in Da Cobra said:
if you want a car with that kind of horsepower, you're gonna have to deal with little things like that. The Z06 is a great car but It has about half the hp your car does...thats a big drop.
I'm with him on this one, I dont even understand how you can even BEGIN to compare a 660RWP car, and the modifications it took to get it there, to the reliability of a stock car....expect the same things when you try to get that z06 to that kind of power...it comes with the territory...once you start changing stuff, things break/malfunction...and in your case, with that kind of power/mods, they break fast.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #12
I don't mind breaking parts - its all part of the game. However when the downtime surpasses the up time you look back at the money you spent and the time you set aside to make those 10 second passes. And you wonder was it worth it.

I have the theft system problem figured out - the switches on my chip toggle has become mis aligned. The car is fine now and I have the after-cooler working again.

I'm back on track for FFW.
 

·
Registered
Joined
·
284 Posts
I agree with you too.

Z06KILLR said:


I'm with him on this one, I dont even understand how you can even BEGIN to compare a 660RWP car, and the modifications it took to get it there, to the reliability of a stock car....expect the same things when you try to get that z06 to that kind of power...it comes with the territory...once you start changing stuff, things break/malfunction...and in your case, with that kind of power/mods, they break fast.
But it's easier when you start with more cubes though. Things don't have to be stressed so much to make the extra power. But like you said, If you want 600 rwhp with any car, you are going to have to accept the problems that come with that.

I just meant that I would rather have a lighter car with a bigger engine, and stay naturally aspirated to avoid too many tuning variables. I'm not putting down Ford either, we work with what we have. I'm keeping my ('98)Cobra regardless if I decide to buy a Z06 or not.

I have been where NO Quarter is now with my former '93 LX coupe, and I'm trying to avoid doing it again with my current car. That's the main reason why I am considering hot-rodding a different car. It's a lot of fun when things aren't breaking though, but I was constantly wondering if it was worth it.

That's one mean car though, sounds like! Good luck at Fun Ford.

Randy
 

·
Registered
Joined
·
238 Posts
there's no doubt the NA possibilities with the LS6 played a large role in my buying decision.

but I'm also highly impressed with the very low weight (3050) while still retaining an IRS, AC, CD/radio, and leather seating.

And the handling is phenomenal

I have no idea how much it would cost a mustang owner to duplicate the complete Z06 package; it certainly isn't cost effective to try.
 

·
Registered
Joined
·
53 Posts
I have both. A 93 vette and a 98 stang. I'd have to say that even though the vette is severely under powered compared to the stang, it is a toss up on which one is more fun to drive. The vette handles so well compared to my stang, and the engine is very strong all the way to red line. It has 140K miles on the odo. and I have had only one down time when the water pump went out. My stang on the other hand just spent 13 months at laRocca's and costed me as much as the vette did when I bought it. Then lasted 500 miles before it went back into the shop. It's fast, but everytime I drive it I wonder if it's going to make it home or not. I like both of them. And most people like the stang more. But it makes me think, If my 10 year old vette is this nice. What are the new ones like? Hmmmmmmmmmmm:rolleyes:
 

·
Registered
Joined
·
2,541 Posts
JB VOBRA said:

I have no idea how much it would cost a mustang owner to duplicate the complete Z06 package; it certainly isn't cost effective to try.
JB, that's easy and I'm sure I'll get flamed, but you can't duplicate the total package for anywhere near the cost of a Z06 off the floor. We are dealing with a 30 year old frame . . . nuff said.
 

·
Registered
Joined
·
89 Posts
NO Quarter said:
I'm getting REALLY tired of the neverending problems with the car. Last week I had the MAF go bad - causing me undo problems. Replaced that today and the car is running normally, however the pump for the after-cooler is not working now.
Top this off tonight I went out to move the car into the driveway and low and behold - the damn theft light is on.

Does anyone have any clue how the theft light works and how I can shut it off? The suposedly code locked, micro chipped key is in the damn ignition. Any ideas how to resolve this? Any ideas as to why all this is happening?
I hear ya man,always something with these highly tuned beasts.My aftercooler pump gave up on me after only 3 weeks,i,ve just installed a Holley Red fuel pump in its place,this works great for one third the price,hope you get every thing else back on track,the Z0-6 is one sweet car though.
 

·
Registered
Joined
·
420 Posts
NO Quarter said:
I'm getting REALLY tired of the neverending problems with the car. Last week I had the MAF go bad - causing me undo problems. Replaced that today and the car is running normally, however the pump for the after-cooler is not working now.
Top this off tonight I went out to move the car into the driveway and low and behold - the damn theft light is on.

Does anyone have any clue how the theft light works and how I can shut it off? The suposedly code locked, micro chipped key is in the damn ignition. Any ideas how to resolve this? Any ideas as to why all this is happening?
I feel the same as you. I did not have over 600hp- but I had problems every time I turned around. So everythings off and 4-sale and I am working on getting a 03 Zo6- Good luck to you!
 
1 - 20 of 23 Posts
Top