Ford Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Having a no start issue with my 88 5.0. I put the key in and I get the normal "door open key in ignition" tone dome light on everything normal. Turn the key to accessory and everything still normal. As soon as I turn past accessory into "run" I loose almost all power. Door tone stops, dome light out, gauges dead. Only a slight noise from the back that sound like my fuel pump but weak. I have clean terminals and a good battery. I have already replaced the ignition switch also. I am not an electrician. This issues happened suddenly and without warning. Been a clean good running car for years.
 

·
Registered
Joined
·
23,216 Posts
why did you replace the switch?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
As I said the car does not start. I have very limited diagnostic ability but I knew the ignition switch is a common problem in these cars and I thought it could have been causing those symptoms therefor replaced.
 

·
Registered
Joined
·
23,216 Posts
cause it doesn't start, does not mean you cannot test the switch

use a test light to batt neg

and probe across the switch in the various positions, the light will come on when the switch is working

you only need to know which pins to test at each position

they sell wiring diagrams, sometimes for free, so that you can id them

infact you don't need them, if you understand the design....regardless, its easy to test

so lets assume your NEW switch is faulty

test it.
 

·
Registered
Joined
·
3,575 Posts
If you replaced the ignition switch, you are an electrician, of sorts.
Your good running car is 30 years old.
Maybe battery terminals are clean, but cable clamps not tight enough.
 
1 - 6 of 6 Posts
Top