Ford Mustang Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,170 Posts
Discussion Starter #1
Took my car to track last night with the mt drag radials. Didnt touch the carb and just messed with the timing very little. Best psi in the radials for me was 15psi and leaving at 4k though I think towards the end of the night I could have left harder. Best 60ft was a whopping 1.64.

First pass spun bad, 3500 launch [email protected] 2.00 60ft 34 degrees timing
Second pass left better 3000k launch [email protected] 1.8460ft 34 degrees
Third pass 3500 launch [email protected] 1.7860ft 34 degrees
Last pass bumped timing to 36 degrees, 4000k launch, 1.64 60ft 6.97 @ 105.6
I think with more tuning and seat time it will go 6.70s on the radials. Heres a video of the best pass but not good quality.

http://s144.photobucket.com/player.swf?file=http://vid144.photobucket.com/albums/r198/rapidgt/100_0350-1.flv&fs=1&os=1&ap=1
 

·
Registered
Joined
·
1,170 Posts
Discussion Starter #3
It's a very simple combo with zero maintenance so far.
69 block with Eagle forged kit
10.4-1
410ci
Afr 205s
supervic
Ots Crane hydraulic roller under .600
AED 850
Tko 600 with 373s
275/60 mt radials
3220lb raceweight
I think with 4.30s and a 5500rpm+ launch it could go high 6.50s. Should 60ft in the low 1.4s I think
 

·
Registered
Joined
·
785 Posts
Nice trap speed... makes me miss my Tremec...
 

·
Registered
Joined
·
1,170 Posts
Discussion Starter #5
Thanks Niterita. I have always admired your car. Hoping to get the et's and 60ft down next time out!
 

·
Registered
Joined
·
785 Posts
Thanks Niterita. I have always admired your car. Hoping to get the et's and 60ft down next time out!
Thanks. I'm also jealous of your induction system. I spent countless hours chasing a performance problem. Turned out my injectors were clogged. I can only assume it's much easier to find a clogged jet than to assume the injectors are clogged.... Got them cleaned/flowed and now I'm good to get back to testing the converter. Luckily hurricane Ike only caused roof damage, downed 2 trees, and knocked down all my fences. We are so lucky compared to people less than 1/2 mile away....

Back to you... Did you dyno tune your car (chassis dyno)? Specifically the air fuel ratio. My car was WAY lean until I had the chip burned for it. After about 10 pulls it was where it needed to be.

Regarding the gears. 4.10's with 28x10.5 slicks was perfect for the 1/4 mile. 4.30's should work better for 1/8, which is what I assume your local track is. If possible, through on a set of slicks and launch it like you hate it...
 

·
Registered
Joined
·
1,170 Posts
Discussion Starter #7
Sorry to hear about your misfortunes man. That was a HUGE hurricane.
I have never dynoed my car but want to soon. I want to see how low I can get on the drag rads before I put slicks on it. I hate the way the tko 600s are geared especially the 2.87 first gear. I think it will go some low 6.80s with them.
 

·
Registered
Joined
·
3,979 Posts
very nice mph there. You've got some .50s or .60s in it for sure once you get it to hook.

I see combos like yours running the mph you're running with a 200 lbs heavier car and wonder what the hell I'm missing on mine. I've got a custom solid roller, ported 192 heads that should outlow your 205s, and a maxed out Vic Jr and 950 ish carb. I should be a couple tenths faster and 3 mph faster than you.
 

·
Registered
Joined
·
1,170 Posts
Discussion Starter #9
I'm not sure but I am happy so far. Your combo runs really good to me. Maybe a super vic would help you out some but I dont think it would much. I am barely shifting into third by the end of the traps. I need a gear bad!
 

·
Registered
Joined
·
4 Posts
Hey Guys..I have been read allot on all the different thing you ass have done with the 408..Just have to say thanks ALLOT for all the help..I my self is running a keith craft 408..with afr 225..and recently just swaped from a tko 600 to a c4..best with the tko was a 6.77 @ 101 and a 10.55 @ 128 all with a 1.42 to 1.45 60ft...Now with the automatic..best 60ft is 1.64 and a 6.97 @99 mph..Have not taken it to the 1/4 mile yet..I swaped from my 4.10.s to 3.73 when i did the c4 swap..D o u thing thats where i lost my 60ft?..Thanks guys
 

·
Registered
Joined
·
5,933 Posts
Nice build bro. im gonna say I think it will or could go 6.50s or 6.40s. I watched you launch the car and it looks like you let off the gas pedal right after you launch then right back in it. Keep us posted.. Nice passes btw. Also do you have slicks on?
 

·
Registered
Joined
·
3,979 Posts
Hey Guys..I have been read allot on all the different thing you ass have done with the 408..Just have to say thanks ALLOT for all the help..I my self is running a keith craft 408..with afr 225..and recently just swaped from a tko 600 to a c4..best with the tko was a 6.77 @ 101 and a 10.55 @ 128 all with a 1.42 to 1.45 60ft...Now with the automatic..best 60ft is 1.64 and a 6.97 @99 mph..Have not taken it to the 1/4 mile yet..I swaped from my 4.10.s to 3.73 when i did the c4 swap..D o u thing thats where i lost my 60ft?..Thanks guys
Holy old post revival batman!


You shouldn't have slowed down that much switching to the C4. Who built/spec'd the converter for it? Do you have a transbrake? Whats it stall to on the transbrake/footbrake? What are the cam specs? Had it on a dyno?

Going from 5 speed to auto doesn't always pick up ET if you are an excellent driver with the 5 speed. But it should never lose ET unless something is mismatched like the converter. The drop from 4.10 to 3.73 shouldn't have hurt it that much.

Also, how was the weather on these two different track days?? Keep in mind, from a best ET in the winter to a best ET in the summer on the same combination could be a difference of .2-.4 in your E.T.
 

·
Registered
Joined
·
4 Posts
Hey man..Can i ask u a question?..How are you getting away in the 1/4 mile with the 4.10.s gears.....I have the same set up almost..but with afr 225 and the cam may be different..My cam is hydraulic also..I lost my cam card:-(.But i know its a 574 lift..and on the dyno it made all the power at 6250 rpm..and with the 4.10.s it felt like it was running out of gear on the big end.So i swaped to 3.73 and now my 60ft is ####..LOL..With theT.K.O it was 1.42..and c4 with 4.10 was 1.50..Now its 1.66 WITH THE 3.73..LOL..i kinda regret listening to all my friends and puting a automatic
 

·
Registered
Joined
·
4 Posts
Holy old post revival batman!


You shouldn't have slowed down that much switching to the C4. Who built/spec'd the converter for it? Do you have a transbrake? Whats it stall to on the transbrake/footbrake? What are the cam specs? Had it on a dyno?

Going from 5 speed to auto doesn't always pick up ET if you are an excellent driver with the 5 speed. But it should never lose ET unless something is mismatched like the converter. The drop from 4.10 to 3.73 shouldn't have hurt it that much.

Also, how was the weather on these two different track days?? Keep in mind, from a best ET in the winter to a best ET in the summer on the same combination could be a difference of .2-.4 in your E.T.
Hey white90gt...I had the trans and the converter built by F.T.I in deland florida..It does have a trans brake.its stalls at 4800..and i have the trans brake set at 4000 its a 8inch..The motor is a 408 hydraulic roller..not sure on the exact cam spec..but its a 576-576 252-252 108ls installed at 103..AFR 225 out of box victor jr instake..holler 750 hp 87-91 jets..i have had it on the dyno with the TKO 600..And it made 467h and 467t..The best et was a 10.55 @ 128 with a 1.44 60ft in 40 degree weather with the TKO..And now with the c4..its been a 10.97 @ 124 with a 1.62 60ft..Had to switch to 3.73 because it felt like it was running out of gear on the big end..But also just founf out that its been running very lean...Thanks for all the help
 

·
Registered
Joined
·
3,979 Posts
The cam sounds small to me, but I haven't messed with hydraulics in a while and never really got big with them. The unported Victor Jr isn't helping the cause, I'd suggest a supervic intake for sure. 4800 on the converter should be OK, just gotta get the motor making the power. Whats the timing set at and is it locked out?

I get away with 4.10 gears in the 1/4 by spinning the motor. Remember, mines a high compression solid roller setup and makes power beyond 7000 rpms. I shift at 7400 rpms and go through the traps at 7400 at 136 mph. I can't spray it in the 1/4 mile as I don't want to push 8k rpms.
 

·
Registered
Joined
·
4 Posts
The cam sounds small to me, but I haven't messed with hydraulics in a while and never really got big with them. The unported Victor Jr isn't helping the cause, I'd suggest a supervic intake for sure. 4800 on the converter should be OK, just gotta get the motor making the power. Whats the timing set at and is it locked out?

I get away with 4.10 gears in the 1/4 by spinning the motor. Remember, mines a high compression solid roller setup and makes power beyond 7000 rpms. I shift at 7400 rpms and go through the traps at 7400 at 136 mph. I can't spray it in the 1/4 mile as I don't want to push 8k rpms.
Cool..Thats understandable..I drive the car almost 3 times a week..so i kinda stayed away from the solid roller..But iam thinking now with this converter and me needing more rpms..if i cant get it from the tune(playing with jets and timing)..i might be better off to switch to solid roller and a better cam to work with the afr 225s to make the power..For damm sure i dont want to try ANOTHER converter again..lol..been thru hell..lol..its locked out at 34 degrees..and its a 10:5:1 comp and pump gas..I have heard if i put the timing to 36 it should pick up the 60ft with the c4..Should have just kept my damm TKO..LOL..Thanks man for all your help
 
1 - 18 of 18 Posts
Top