Ford Mustang Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
370 Posts
Discussion Starter #1
I have Hitech Stage II roots blower cams in my 2v car. Specs are: 234/230 duration, .550/.500 lift, 115LSA. They were in the car when I bought it...it had a little KB 1.9L blower on it. It now has a 76mm On3 setup, running 20-23psi boost. 5-speed, street car.

What are the specs of the turbo cams you are using? I've heard that the cams I have are actually pretty close to what many companies spec for their turbo cams. I have heard from others that the cams I have might be limiting my power and/or slowing spool for me.
 

·
Registered
Joined
·
353 Posts
I have the HP292 stage 2 blower cams. 228/[email protected] 531/531lift 114lsa. They arnt to bad for turbo set up. Your cams dont sound to bad either. For sure a turbo cam would be optimal but for now you shouldnt be to bad.
 

·
Registered
Joined
·
1,361 Posts
I have the HP292 stage 2 blower cams. 228/[email protected] 531/531lift 114lsa. They arnt to bad for turbo set up. Your cams dont sound to bad either. For sure a turbo cam would be optimal but for now you shouldnt be to bad.
Really? Im getting ready to pull those cams out and put stock ones in cause they seem to suck for a turbo setup.

Do you have a dyno graph you can post?
 

·
Registered
Joined
·
353 Posts
ill try and post one tonight. Dont get me wrong I know a turbo cam would be way better but it was what i had becasue i was going blower before i changed my mind and didnt want to change right now. I think ill prob go with the MMR stage 3 turbo cams when i change.
 

·
Registered
Joined
·
1,361 Posts
ill try and post one tonight. Dont get me wrong I know a turbo cam would be way better but it was what i had becasue i was going blower before i changed my mind and didnt want to change right now. I think ill prob go with the MMR stage 3 turbo cams when i change.

yea, of course, Im saying a STOCK PI cam will do a #### ton better than that from what ive seen.

Ive been looking around and see so many guys making way more power than I made on stock cams.

Just looked at a guy over at mod fords with 11 psi that made 530/630 stock PI cams nad intake, slightly cleaned up heads.

Makes no sense that Im making 512 rwhp and 480 tq with heavily ported heads and a eddy victor jr manifold on 12-13 psi with a larger more efficient turbo than him at that.

I looked at your thread and it seemed like your numbers were really low to me....was that dyno with an unlocked converter?

I guess you will have some good results to look at if I do the swap to stockers which im pretty sure I will end up doing based on my dyno sheets.
 

·
Registered
Joined
·
353 Posts
yea, of course, Im saying a STOCK PI cam will do a #### ton better than that from what ive seen.

Ive been looking around and see so many guys making way more power than I made on stock cams.

Just looked at a guy over at mod fords with 11 psi that made 530/630 stock PI cams nad intake, slightly cleaned up heads.

Makes no sense that Im making 512 rwhp and 480 tq with heavily ported heads and a eddy victor jr manifold on 12-13 psi with a larger more efficient turbo than him at that.

I looked at your thread and it seemed like your numbers were really low to me....was that dyno with an unlocked converter?

I guess you will have some good results to look at if I do the swap to stockers which im pretty sure I will end up doing based on my dyno sheets.
yes mine was on an unlocked conv. I made 450hp442tq on 10lbs with i think 13* of timing which i thought wasnt to bad lol. Problem was on the dyno is i was starting to blow through the converter once we turned the boost up. it made 520hp and 48x tq on 15lbs and then the same power on 22lb.s so just stopped. im sure once the conv is fixed it would make a big dif. I have stage 2 ported heads atleast thats what they were supposed to be and a bullit intake and im 8.9-1 comp. alot of ppl are running a little more comp which makes a dif to. ill try and get you a graph tonight.
 

·
Registered
Joined
·
1,361 Posts
Yea, its hard to say what kind of losses you are seeing with the converter unlocked....doesnt seem to be working too bad judging by your 1/4 mile time....lol

For comparison on 9 psi my car made 470 rwhp and 435 tq. I also have ported heads and an edelbrock manifold.

So figure with 10 psi I probably would have made 485 rwhp and 450 tq looking at my numbers...im sure the difference in our power is the converter being unlocked though.

It does seem like your blowing through it if you only went up to 520 on 15 psi...Mine laid down about the same, 512 rwhp and 480 tq on 12 psi.

But again, through a locked converter.

I wish you had locked converter number so I could compare them to mine.

Im baffled, seems like your 1/4 mile times are awesome but maybe thats because your running a locked converter and the rpms stay way up the hole time.

My car makes dog #### power before like 5k compared to other turbo cars.
 

·
Registered
Joined
·
353 Posts
Yea, its hard to say what kind of losses you are seeing with the converter unlocked....doesnt seem to be working too bad judging by your 1/4 mile time....lol

For comparison on 9 psi my car made 470 rwhp and 435 tq. I also have ported heads and an edelbrock manifold.

So figure with 10 psi I probably would have made 485 rwhp and 450 tq looking at my numbers...im sure the difference in our power is the converter being unlocked though.

It does seem like your blowing through it if you only went up to 520 on 15 psi...Mine laid down about the same, 512 rwhp and 480 tq on 12 psi.

But again, through a locked converter.

I wish you had locked converter number so I could compare them to mine.

Im baffled, seems like your 1/4 mile times are awesome but maybe thats because your running a locked converter and the rpms stay way up the hole time.

My car makes dog #### power before like 5k compared to other turbo cars.
its def blowing through when i make the same power on 22lbs as i do on 15-16 there def is an issue. and there is a calc u can use to figure out the slip. running a 10.8 at 121 with a 28inch tire and going through the traps at 6500 there def is a slip issue with the conv. that mph should be high 120s.

id like to get it back on the dyno after my conveter tighten and the exhuats leaks fixed but not sure when that will happen. just gonna have to check at the track.
 

·
Registered
Joined
·
1,361 Posts
Lol yea, I was confused, I saw you went 10.88 @ 121 and 10.85 @ 126?

How the hell did you randomly pick up 5mph.

Either way, it sounds like your converter needs to be tightened up
 

·
Registered
Joined
·
353 Posts
Lol yea, I was confused, I saw you went 10.88 @ 121 and 10.85 @ 126?

How the hell did you randomly pick up 5mph.

Either way, it sounds like your converter needs to be tightened up
i had turned the boost up but when i launched i didnt have enough gas (1/4 tank no baffles though) in the tank and sucked the pumps dry twice and i got out of it twice then got back into it so on the topside it started picking up speed.

I should get the converter back next week and hopefully get it back together soon and get some more times on it.
 
1 - 10 of 10 Posts
Top