Ford Mustang Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #1
I'm having some irregular boost problems with the wastegate opening and closing during full throttle and I'm trying to narrow it down.I've tried different wastegate/vacuum lines/boost controller

Can my turbo outlet only being 2 inch connecting to a 3 inch intercooler pipe cause a pressure drop problem??
 

·
Registered
Joined
·
150 Posts
Discussion Starter #3
From fitting on turbo. I've also tried a port on TB.I've also tries different sized vacuum line. I just can't get this one figured out.

Waste gate will open and close during full throttle all in one gear. Boost spike then gate finally opens then will close again causing up and down boost
 

·
Registered
Joined
·
1,006 Posts
More info on combo please
Have you tested the gate to see if it is sealing ?
Do you hear the BOV going at the same time when this is happening ?
What makes you think it's the WG?
Have you checked to see if the gate valve is sticking ?
 

·
Registered
Joined
·
150 Posts
Discussion Starter #5
I don't think it's the gate anymore no. Like I said I've tried multiple wastegates "tial 46" and all diff reference line options.

It's a stock cube motor
On3 kit / I know :-( /
Precision 67 turbo with .68
Tial F46 waste gate

The I can't hear bov open under boost and it pops opens like it should when I let off gas
 

·
Jersey True Street Guy
Joined
·
3,195 Posts
Very basic suggestion but have you pressurized the vaccum lines while the car is off to listen for leaks?

I had a leak on top of a wastegate causing me havoc.
 

·
Registered
Joined
·
150 Posts
Discussion Starter #7
I haven't tried that it's a good idea.

I've tried different waste gates and have pressure tested them and there fine.

Where was your leak? I've got the fitting on top open but I guess your supposed to leave it not connected to anything
 

·
Jersey True Street Guy
Joined
·
3,195 Posts
I am using an ams-500, it uses a different line routing then how normal instructions without a boost controller would read.

My leak was where the line was connected on top of one of my two gates. It was causing it to not add any boost on top of wg.
 

·
Registered
Joined
·
150 Posts
Discussion Starter #9
Oh ok I don't have an electronic controller
 

·
Jersey True Street Guy
Joined
·
3,195 Posts
...you should still check for leaks, just don't try to compare line routing.
 

·
Registered
Joined
·
150 Posts
Discussion Starter #11
Do I want my top port open or do I want a plug in it capping it off?
 

·
Registered
Joined
·
150 Posts
Discussion Starter #13
Yeah thats how it is. I'm gonna get it on a lift tonight and check for exhaust leaks on the hot parts and vacuum leak
 

·
Jersey True Street Guy
Joined
·
3,195 Posts
Even if you can't hear a leak cleanly look for soot or burning in and around the headers. If it is leaking it won't be clean and pretty
 

·
Registered
Joined
·
150 Posts
Discussion Starter #15 (Edited)
I found a leak u can smell and hear with black soot on a v band connection on hot parts I wonder if that would be enough to cause this.I'll hopeful iget it fixed on the lift and see if there are any other leaks
 
1 - 15 of 15 Posts
Top