Ford Mustang Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,212 Posts
Discussion Starter #1
If it sits more more than a day or two the battery goes stone dead. Odometer has ------- across it when key is off and out of switch and the check engine light is dimly lit. The instrument cluster should not have power when key is off right? Any ideas would be helpful.
 

Attachments

·
Registered
Joined
·
320 Posts
Yes, either you have a bad ignition switch or something has a short around it or the multifunction switch.
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #3
Also when running it has no check engine light and the odometer reads correctly. Starts great no dragging or anything.
 

·
Registered
Joined
·
23,262 Posts
before throwing parts at it

why dont you find the source of the current draw?
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #6
I am going to put my meter on it tomorrow, but I did go ahead and get the switch for 12.00 to have it with me just in case. I was just asking in hopes that someone else might have already fixed a similar problem.
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #7
Ok so #6 maxifuse under the hood is pulling 0.5 volts with key off. Owners manual says instrument cluster and pcm. Pulled fuse and car cranks but check engine light comes on and dome/trunk lights don't work. Also power locks/keyless remote stops working. The ---- on the odometer and dim check engine light went away. I left the fuse out and I'm gonna see if battery is still charged tomorrow. Any ideas?
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #8
I might pull the cluster and reinstall fuse to see if draw is still occurring with it unplugged. Every heard of a cluster being shorted causing this?
 

·
Registered
Joined
·
23,262 Posts
you measred a voltage potential NOT current draw

you need to find the circuits drawing current
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #12
My meter crapped out so I had to borrow a friends. Set on 200ma and probing across the top of the mini fuse in the interior fuse box I got 3.9.
 

·
Registered
Joined
·
23,262 Posts
3.9 milli amps is not a draw to worry about

are you sure its not 3.9 amps??
 

·
Registered
Joined
·
1,000 Posts
He went in parallel of the fuse, reading is useless.
OP, do you need more help with this? In order to read current you have to be in series with the circuit or use a dc clamp on.
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #15
I got a gem on the way. Yes I need all the help I can get but I'm handicapped now because my meter crapped out. I'm just gonna install new gem and wait on my meter to get back from getting repaired. Thanks for all the input so far.
 

·
Registered
Joined
·
23,262 Posts
gem on the way?

how do you know anything is wrong with it?

you pooched your meter's fuse

by not using it correctly??
 

·
Registered
Joined
·
1,212 Posts
Discussion Starter #17
No I checked the fuse and replaced it just to be sure. It was a older Snap on one. I sent it to be repaired. I have a friend with a mustang salvage yard and got one cheap just to see if it fixes my problem. I will know more in a couple of days.
 

·
Registered
Joined
·
23,262 Posts
cheap meter from a friend from a salvage yard?
 
1 - 19 of 19 Posts
Top