Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone I have a built 1995 mustang GT 347/V-1 supercharged, start up and idle no issues. When driving at cruising speed no issues but soon as I step on it, it Boggs out bad as if there is no air or fuel!! What could be the issue? Next month it’s getting a SCT performance tune but before that I need to resolve this issue. Timing is at 10deg and fuel pressure is at 40WOT the following mods is listed if it helps:

Built 347 stroker
custom blower cam
Trick flow heads
Trick flow upper and lower intake
BBK throttle body
80mm maf
60lb injectors
BBK fuel pressure regulator
Msd 6AL
Msd distributor, cap, rotor and wires
Vortech V-1 with 14lbs of boost
Trex fuel system
Full racing suspension too much to list
373 gears
And whole bunch of other stuff non related to engine management
 

·
Registered
Joined
·
371 Posts
Check all of your intake manifold ports if they are opened or capped close?
 

·
Registered
Joined
·
23,260 Posts
what are the 02 voltages when you stab the throttle?

they better be going rich......
 

·
Registered
Joined
·
1,116 Posts
I can promise you that car will run like ass until it’s tuned.
 
  • Like
Reactions: fasterthangas

·
Registered
Joined
·
371 Posts
CEL On? Is it OBd2? on you get a reading on live data logo with a scanner?Can you check your Short and Long fuel trim on the fuel system?
 

·
Registered
Joined
·
41 Posts
Do you have a wideband o2 sensor? It would be very helpful for tuning so you can see what the engine is doing. You said it acts as if there is no air/fuel when you step on it. 40psi at WOT sounds extremely lean.
 

·
Registered
Joined
·
1,580 Posts
So you have all these upgraded performance parts to include a custom cam, blower and injectors but it’s running on the the stock tune until you can get it tuned?

My guess is that the issue will prob be able to be solved when you take it to get the custom tune done.
 
1 - 8 of 8 Posts
Top