Ford Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So I just found this site today, and I figured this would be the best place to find some help.

So my mom has a 1994 manual Mustang GT that's been in the family since it was bought new. We've always had a problem with the vehicle security box that's tucked up behind the clutch, and a while ago my mom took it to a shop to get an alarm problem fixed, and they never put the box back up correctly so it falls down behind the clutch periodically. A few days ago I was driving the car and the box fell behind the clutch so I pulled over to fix it, and I noticed that when it fell the speedometer shut off and went to 0, the radio shut off, the keys don't lock or unlock the car, and worst of all, the car won't start. I'm 99% sure something in the security boxed got tripped and goofed up the car or a wire came lose.

Anyone have any idea what the cause is for this and how I would go about fixing it, aside from taking it to the shop?
Also sorry if this is in a wrong format or I posted this in a wrong part of the forum, I made this account minutes ago to find some help.
 

·
Registered
Joined
·
23,260 Posts
you need and EVTM or equivalent that shows the circuits
 

·
Corral Charter Member
Joined
·
11,254 Posts
@lienonairb

Does the car have the factory alarm?

Have you traced the wires from the box upward into the dash to make sure wires did not break or that another connector did not become disconnected?

This is my thread regarding the factory Ford alarm system on my 94 Cobra. You can read through, maybe something may help:
 
1 - 3 of 3 Posts
Top