Ford Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
Well it's been a long time coming, and I thought I would post this now that the project is almost complete.

I didn't want it to turn into a thread where I would get everyone hyped up to see results, and the project die halfway through. That being said lets get down to business!

I picked up this notch about 2 1/2 years ago from a "kid" that at the time had more money than sense, it was an original 5.0/5 speed car, but it had an issue of constantly blowing the driver side head gasket. Someone mentioned the car to me , and it being for sale, so I went over to look at it, and knew I immediately wanted it. Car was fairly immaculate. 5 lug swap, nice staggered saleens, ok paint, ok interior. I figured it would be a nice cheap project car. So I scooped it up for a $1000.

Well I got to searching on youtube, looking at different swaps and what not. I came across a 351w 4 speed car running low 7s in the 8th and thought "this is what I'm going to do". So BAM! Picked up a 351W, all the swap stuff, got the motor in the car, basically to the point of dropping in the dizzy in and firing it off.... but in my youtube searches I managed to type in "LS Mustang".... and what was the first thing I see: Dave Mizzell going 9.9xs with stock bottom end 6.0 and L92 heads. I GOTTA HAVE IT. It was just damn impressive, plus supposedly it was cheap....

Well long story short, I skipped the 6.0 being stock, decided on a 370, came time to pull the trigger, and went for a 408. So much for going cheap.

2005 LQ9 Block .030 over
Mahle -5cc Pistons
Compstar Rods
Callies Crank
TSP 251/259 .663/.660
.675 lift springs
Worked over L92 Heads
Stock rockers with Comp Trunion Upgrades
L92 Vic Jr
750 Mighty Demon Carb
MSD 6010 ignition
Kooks 1 7/8" LSx Swap LTs

This is all run through a TH350 w/ 3500 stall.

So far everything has been flowing along smoothly, with the exception of a missing balancer bolt, which I don't understand how you miss, thank you machine shop? And the valve covers needing to be notched to fit the rockers, which again I don't know how you miss, especially if you already notched the heads a bit to fit the rockers. Last but not least, a new steering U joint, as the stock joint hits the headers locking up the steering.

All in all it's been a pleasant experience. I took the project myself to a point (motor in the car, ready to put trans in), and decided it was better that I let someone else with more mechanic and wiring knowledge than myself take over, especially after taking some heat from the wife about not spending enough time at home.

The car is almost ready to fire up, just working on getting oil pressure (we think pinched o-ring), and wiring up ignition. Starter spins the motor over nicely, and hope to have the little stuff out of the way this weekend so we can fire her off and get this bad boy rolling!

My goals with the car are hopefully something faster than 10.99 in 1/4 on motor and something faster than 9.99 on gas (when we put it on).

I will add more as I go along, I have some nice shots of the car, and will post videos of the car ASAP.

Any comments or criticism please let me know, as I am open to suggestion on anything.

Thanks,

Brian

PS I would post photos, but I haven't been on the site long enough.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #2
Well we got her drivable last night around 7pm. Ran her on 93 with a fuel additive (nitromethane). Open header btw. Couldn't figure out why it won't go in reverse... duh transbrake needed to be wired up. We had a microswitch, but no button, so we rigged it up on the trunk release button haha!

But as for driving!

All I can say is wow! It idles actually very nicely, does not surge, or stall out at all. It drives like my GTO in regard to how easy it is to keep it running. I drove a H/C/I MS4 GTO that a buddy has and I couldn't get that thing out of the parking lot without stalling, but with this thing no problem.

The car drives great, other than being obnoxiously loud, having no traction (street tires), and having a few little details that need to be finished.

Cooling stayed between 160-180, Oil pressure was solid @ 60lbs. Transmission shifted flawlessly.

I generally putted around with her, keeping it sane, but made a quick stab at the throttle or two taking it to around 5k. I will say that my 3600 rpm stall, is now a 4200ish stall, but it pulled like an absolute raped aped, and to be honest with you, I was a bit afraid lol.
 

·
Registered
Joined
·
1,876 Posts
I want pics and videos... once i split this 5.0 block i have in my car in half a LS motor will end up in mine... awesome to read now i want to see! lol
 

·
Registered
Joined
·
56 Posts
Discussion Starter #4
I want pics and videos... once i split this 5.0 block i have in my car in half a LS motor will end up in mine... awesome to read now i want to see! lol
I have pictures and videos, but the site won't let me link them as I don't have enough posts.

I'll get them up ASAP.
 

·
Registered
Joined
·
452 Posts
nice build. not sure if i missed it but what k member are you using. and steering shaft issues? im starting a ls swap now
 

·
Registered
Joined
·
56 Posts
Discussion Starter #6
nice build. not sure if i missed it but what k member are you using. and steering shaft issues? im starting a ls swap now
AJE K member with LS1 mounts.

The steering shaft:

We used the stock shaft with a U Joint in place of the rag joint. A 3/4" 36 spline x smooth u joint will work if you decide to cut off the factory rag joint. P/n 105-910 southwest speed.
 

·
Registered
Joined
·
452 Posts
thanks illl check out that u joint. i see most people use the aje k-member. im building a budget drag car so im gona try and use the stock K.
 

·
Registered
Joined
·
452 Posts
i set the motor in lat night to mock up a set of mounts. it seems like the motor sits up high cause of the steering rack. is just how it is or is there a way to lower the rack to get an extra 2 inches
 

·
Registered
Joined
·
56 Posts
Discussion Starter #12
No droning issues, but I honestly put the flows on to try to trick people into thinking it was still a 5.0, but oh well.
 
1 - 14 of 14 Posts
Top