Ford Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey I have an 87 gt my hazzard lights nevery worked so I decided to fix the problem and the wires were all mixed up in the connector got it working. Now my dash lights blink with the hazzard flasher. The dash lights were working before. Also my turn signals stopped working after I did the hazard switch. Any ideas would be greatly appreciated
 

·
Registered
Joined
·
23,216 Posts
what did you do, in your attempted fix?

what wiring diagram are you using?
 

·
Registered
Joined
·
23,216 Posts
is that diagram for a '87?

what did you do in trying to fix it?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
It's the only diagram I could find some I don't know if it's specifically for an 87 or not. The flashers have never worked, so when I pulled the switch off there were wires on out of the connector so I wired it per the diagram. now the the hazzard works but the dash lights flash with it and the dash lights dont come on when when I turn the headlights on. The worked before so I don't know what the deal is. Also the headlight hi lo beam works on one side then whining I switch flash to pass the other side turns on. Everything worked they way it should before I wired the hazzard switch.
 

·
Premium Member
Joined
·
1,581 Posts
Make SURE that the Multifunction switch is for your car!
87-89 OR 90-93 YES, the wrong one will cause this problem. been there & done that.
 
1 - 8 of 8 Posts
Top