car feels slow - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-23-2007, 05:27 PM Thread Starter
 
Trader Feedback: (1)
Join Date: Feb 2003
Posts: 45
car feels slow

well im still working out some kinks with my setup
but 1st and 2nd are slow like it takes to long to spool up
but 3td and 4th pull hard could the this be cause of my 373
rear end i just thought i would have more tourqe any ideas
my set up
306
hci
t 70 .68
60 lbs injectors
70mm tb
255 in tank in line fuel

pup50 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-24-2007, 03:56 PM
Registered User
 
slo5.0.'s Avatar
 
Trader Feedback: (14)
Join Date: Feb 2005
Location: Indianapolis, IN
Posts: 1,121
curious to know to.. I wouldnt say the rear end. Or a bad clutch because its find in bigger gears. Kinda weird hopefully we can see what it is.

slo5.0. is offline  
post #3 of 5 Old 06-25-2007, 08:58 AM
Registered User
 
qikazz's Avatar
 
Trader Feedback: (12)
Join Date: Mar 2006
Location: Detroit, Michigan
Posts: 772
Quote:
Originally Posted by pup50 View Post
well im still working out some kinks with my setup
but 1st and 2nd are slow like it takes to long to spool up
but 3td and 4th pull hard could the this be cause of my 373
rear end i just thought i would have more tourqe any ideas
my set up
306
hci
t 70 .68
60 lbs injectors
70mm tb
255 in tank in line fuel
You need to get the car to a tuner, get it on a dyno and see what it is doing in the Air/Fuel and timing areas. You may also have a boost leak somewhere. Do you have a boost gauge on the car? If so, how much is it showing?

I will tell you this, with that 70mm turbo, and especially that .68a/r on the hotside, that thing should spool INSTANTLY and should blaze the tires in at least the first three gears.

qikazz
qikazz is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 06-25-2007, 09:06 AM
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
i agree with qikazz. I had a H/I 302 with a T67 .68 and i had 15 psi by 2400 rpms in fourth LOL. Thing made stupid torque. Get it to a tuner and you should find you're answer.
fastwhite86gt is offline  
post #5 of 5 Old 06-25-2007, 05:00 PM Thread Starter
 
Trader Feedback: (1)
Join Date: Feb 2003
Posts: 45
ill make a app tomorrow for the tune . my boost gauge shows around 12-15 like i said 3 and4 are pretty fast tires want to break loose aroun 3500 to 4000rmp im running mt dr 26 10.5 16
pup50 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome