metal shavings after compressor discharge? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 01-29-2006, 07:31 PM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
metal shavings after compressor discharge?

I found some metal shavings after the compressor discharge. I bought this kit from someone so i dont know if it was from doing any work on the pipes and he didnt just clean it out. Is there any way it could be from the turbo? i cant figure out how the turbo would make small metal shavings like this. The shavings are tiny and look like they were cut of grinded. i didnt notice any in the compressor discharge hole itself. no in and out axial play, minimal side to side. i had a thread about this before, but supposedly the guy had the turbo checked out because there was a small chip in one of the fins and was concerned but had it checked out and said it was ok. He said from the chip, that it just makes a small whistle on idle.


Last edited by fastwhite86gt; 01-29-2006 at 11:19 PM.
fastwhite86gt is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 01-29-2006, 11:22 PM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
ttt

fastwhite86gt is offline  
post #3 of 11 Old 01-30-2006, 09:10 AM
Registered User
 
Erich's Avatar
 
Trader Feedback: (20)
Join Date: Jan 2000
Location: MD
Posts: 5,957
I would be worried that the compressor wheel is hitting the housing and grinding out some metal. Check very carefully if you can move the wheel and get it to hit.
Erich

97 Laser Red GT-248A Wingless model, Built Lincoln Mark VIII motor-Procharger D1SC, 3 core IC
2012 Black GT-Saddle, 3.73s, Brembos, Shaker1000
Erich is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 01-30-2006, 09:42 AM
DNA
 
Trader Feedback: (0)
Join Date: Mar 2001
Posts: 188
Are they magnetic or Aluminum?

Check and see it they are magnetic or not. I had a blower rub on me once and it sent a fai amount of metal down stream. Check you throttle body se if and went that far.
DNA is offline  
post #5 of 11 Old 01-30-2006, 10:07 AM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
double post sorry

Last edited by fastwhite86gt; 01-30-2006 at 10:14 AM.
fastwhite86gt is offline  
post #6 of 11 Old 01-30-2006, 10:09 AM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
triple lol sorry.

Last edited by fastwhite86gt; 01-30-2006 at 10:15 AM.
fastwhite86gt is offline  
post #7 of 11 Old 01-30-2006, 10:09 AM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
Quote:
Originally Posted by DNA
Check and see it they are magnetic or not. I had a blower rub on me once and it sent a fai amount of metal down stream. Check you throttle body se if and went that far.
there was nothing past the elbow of the intake tube. nothing in the IC, nothing anywhere else. i have not run the turbo on my car. but there was only some right after the discharge before the pipe bends. thats it?
fastwhite86gt is offline  
post #8 of 11 Old 01-30-2006, 10:16 AM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
Quote:
Originally Posted by Erich
I would be worried that the compressor wheel is hitting the housing and grinding out some metal. Check very carefully if you can move the wheel and get it to hit.
Erich
there are a couple tiny surface scratches on the housing but not nearly deep enough to cause the shavings. i tried to push the wheel as far to the side as possible and move it and it did not grind against the housing.
fastwhite86gt is offline  
post #9 of 11 Old 01-30-2006, 10:20 AM
DNA
 
Trader Feedback: (0)
Join Date: Mar 2001
Posts: 188
If you have not run the turbo

If you never ran the turbo it might be shavings from something else. If the previous owner was sloppy there could be cut off shavings from a bench or something else. Be very careful cause there might be more in the turbo or tubes.
I would double check all your couplings to make sure there is nothing stuck to them. I would also remove the head unit and lay it on its side and get some real bright lights and look for anything inside. Maybe find a ggod way to flush and clean the inpeller area.

This might sound like a lot but metal in the engine will be even more work.

Good Luck keep us posted.
Now i am going to go wipe out every single tube on my turbo kit before installation.
DNA is offline  
post #10 of 11 Old 01-30-2006, 10:26 AM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
thats exactly what i did. i grabbed a house and washed out all my intake pipes. i will disc. the pipe from the turbo and look inside w/ a flashlight but when i inspected it last i saw no shavings at all in the turbo. just in that one area and no where else. and no, i havent run the engine or the turbo on my setup, yet. he seemed like a really upfront guy when i last talked to him. he said if the chip in the wheel made me nervous i could rebuild it but he said he had it checked and it was OK. so i think once it is running, i'll do a couple WOT pulls, check for shavings. if they're are, i'll have the turbo rebuilt. if no shavings, well then thats good news for me.

fastwhite86gt is offline  
post #11 of 11 Old 01-30-2006, 02:59 PM Thread Starter
 
Trader Feedback: (9)
Join Date: Jun 2005
Posts: 2,006
if the wheel ever hit the housing, would i hear it? could that whistle he spoke of be the wheel scraping?

Last edited by fastwhite86gt; 01-30-2006 at 04:24 PM.
fastwhite86gt is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome