Turbo run - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 19 Old 06-28-2005, 12:13 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 1,088
Turbo run

here is a link to my latest run at bandimere in Denver colo. http://www.zippyvideos.com/15336849512085.html

wyominghotwheels is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 06-28-2005, 12:26 PM
Registered User
 
Erich's Avatar
 
Trader Feedback: (20)
Join Date: Jan 2000
Location: MD
Posts: 5,957
Looks cool but what was the time, 60 ft and mph?
Better to delete the music and hear the turbos
Erich


97 Laser Red GT-248A Wingless model, Built Lincoln Mark VIII motor-Procharger D1SC, 3 core IC
2012 Black GT-Saddle, 3.73s, Brembos, Shaker1000
Erich is offline  
post #3 of 19 Old 06-28-2005, 12:29 PM
Registered User
 
Trader Feedback: (1)
Join Date: Dec 2003
Location: Moore, OK
Posts: 700
twin turbo running 12.9x's? is the motor totally stock? didn't look like you were launching at all?
ViperRed91GT is offline  
Sponsored Links
Advertisement
 
post #4 of 19 Old 06-28-2005, 01:34 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 1,088
yea, the motor is stock......heads, crank, piston's, everything.........and the track condition's really sucked.......tires spent so much time spinning........everyone at the track sunday was having problems, even a 7 sec mustang that was testing his car out........
wyominghotwheels is offline  
post #5 of 19 Old 06-29-2005, 12:28 AM
Registered User
 
Trader Feedback: (1)
Join Date: Dec 2003
Location: Moore, OK
Posts: 700
Ah I see. Well then I'd say that is a pretty respectable run. Nice car!
ViperRed91GT is offline  
post #6 of 19 Old 06-29-2005, 08:25 AM Thread Starter
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 1,088
well thanks man............i really wish the car would have hooked better, i was hoping for low 12's or high 11's and when i got my ticket and it showed 12.90's, i was very disappointed, that's why i cranked up the boost to 15psi.......and that made things worse.......not only did i damage the engine, my time and e.t's got worse.........i ended up with a 13.06..........
hotwheels of insanemustangs.com
wyominghotwheels is offline  
post #7 of 19 Old 06-29-2005, 10:53 AM
Registered User
 
Out50Stang's Avatar
 
Trader Feedback: (4)
Join Date: Jan 2000
Location: Swansea, Mass
Posts: 1,454
Have you figured out what happened to it? Looks like oyu were running it with no oil pressure in your other vid. Does you gauge not work?

Chris
1990 Mustang LX

306 Short Block
T70 DIY turbo, 36# injectors, 80MM Pro-M, Ported Stock Heads, Explorer Intake w/ Ported Lower, TwEECer R/T and PLX-300
Handling
'95 GT Brake Booster, SVO M/C, Willwood adj prop valve, Cadillac Rear Disc conversion w/Mark 7 rotors, 5-lug, 13" Cobra front brakes, '98 Cobras
385rwhp/446rwtq 11psi
Out50Stang is offline  
post #8 of 19 Old 06-29-2005, 12:56 PM
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2001
Location: Maryland
Posts: 1,394
Altitude probably played against your time as well, right?

Matt.
95 Cobra Convertible #298 of 1003.
On jackstands waiting for a Coyote swap and turbo kit...
65 Thunderbird "Millennium Falcon" Running restoration project
MKoebra95 is offline  
post #9 of 19 Old 06-29-2005, 01:17 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 1,088
i truly can't say it's altitude based, since i am adding air with the 2 hair dryers. I was more then likely the problem, looking at my run ticket's, most of my launch time's sucked..........i lost the 4th round do to the light....me and the other guy dialed in, mine was 12.90 and his was 12.95.......his light was like .213 and mine was like .63X.........i bet him to the end of the track, my time was even faster, but i lost do to my launch........still have to work on that part of my hobby.......sucks we don't have a track closer to us here.........

hotwheels of insanemustangs.com
wyominghotwheels is offline  
post #10 of 19 Old 06-29-2005, 02:22 PM
Registered User
 
Erich's Avatar
 
Trader Feedback: (20)
Join Date: Jan 2000
Location: MD
Posts: 5,957
What were your 60 foots and mphs? That will tell alot.
Erich


97 Laser Red GT-248A Wingless model, Built Lincoln Mark VIII motor-Procharger D1SC, 3 core IC
2012 Black GT-Saddle, 3.73s, Brembos, Shaker1000
Erich is offline  
post #11 of 19 Old 06-29-2005, 06:13 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 1,088
1st pass 60' 1.820 mph 111.80
2nd pass 60' 1.943 mph 105.99
3rd pass 60' 1.998 mph 109.36
4th pass 60' 1.853 mph 108.23 and kaput.......hehehehe
wyominghotwheels is offline  
post #12 of 19 Old 06-29-2005, 11:20 PM
Registered User
 
Mustangous's Avatar
 
Trader Feedback: (0)
Join Date: Jun 2002
Location: Old Bridge, NJ
Posts: 124
Quote:
Originally Posted by wyominghotwheels
1st pass 60' 1.820 mph 111.80
2nd pass 60' 1.943 mph 105.99
3rd pass 60' 1.998 mph 109.36
4th pass 60' 1.853 mph 108.23 and kaput.......hehehehe
I would say those 60' arent bad at all. what tires were your running. I see those time with a good set of DR's. With those 60' and mph you should of had a low 12 sec run.

90 GT underconstruction

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mustangous is offline  
post #13 of 19 Old 06-30-2005, 07:47 AM
Registered User
 
Erich's Avatar
 
Trader Feedback: (20)
Join Date: Jan 2000
Location: MD
Posts: 5,957
Yeah, the 60 foots look good enough. I wonder what a 111 mph run would be at sea level. Was the first pass the best? I think my setup is fairly similar to yours. It will be really interesting to see how it runs. Right now I have to paint that new motor. Details like painting stuff I just HATE. But if the motor is out and unpainted now is the time.
How did you break your motor in?
Erich

97 Laser Red GT-248A Wingless model, Built Lincoln Mark VIII motor-Procharger D1SC, 3 core IC
2012 Black GT-Saddle, 3.73s, Brembos, Shaker1000
Erich is offline  
post #14 of 19 Old 06-30-2005, 01:11 PM
Registered User
 
Trader Feedback: (1)
Join Date: Dec 2003
Location: Moore, OK
Posts: 700
111 mph should see mid-low 12's. Spinning can cause a higher mph than usual, however.
ViperRed91GT is offline  
post #15 of 19 Old 07-02-2005, 12:34 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 1,088
yea, the first pass was the best............last year i ran a 12.60 at 115 with a 1.58 60'ft..........the only change i really made to the car was solid motor mount's and solid tranny mount.......people that were watching my car said that my car was now twisting to the right almost touching my bumper cover on the ground.........it is probably more my driving skills though.........hardly ever get to go to the track, just one time a year, most of my racin is done out in the country back roads..........
wyominghotwheels is offline  
post #16 of 19 Old 07-02-2005, 01:41 PM
Registered User
 
Trader Feedback: (1)
Join Date: Dec 2003
Location: Moore, OK
Posts: 700
Do you have subframes or battle boxes? If not..get them asap.
ViperRed91GT is offline  
post #17 of 19 Old 07-02-2005, 07:28 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 1,088
yes, i have subframes, which are full length maximum motorsports, and welded torque boxes........ here is a pic of the launch i had that day, look down at the rear tire towards the bottom of the rim. https://www.corral.net/photopost/show...cat=500&page=1
wyominghotwheels is offline  
post #18 of 19 Old 07-06-2005, 10:42 PM
 
Trader Feedback: (0)
Join Date: Jun 2005
Posts: 35
wyominghotwheels Im from littleton CO and i was at ford fest, i saw your car man It is really a wicked car! I was with my friends dad who has a grey 89 5.0lx with a 418 and the race powerdyne. I just wanted to let you know that. thanx
milehighstang is offline  
post #19 of 19 Old 07-07-2005, 01:38 AM
Registered User
 
Trader Feedback: (1)
Join Date: Dec 2003
Location: Moore, OK
Posts: 700
Do you have upgraded axles or rear end? Looks like you have good traction, just need to up the rpms and pull the wheels off the ground
ViperRed91GT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome