got my car back to the dyno - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 27 Old 09-14-2012, 07:18 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
got my car back to the dyno

It made 407 at 495 best at 12 pounds
Now its smoking at idle unsure what it is but here's a video of the dyno pull. Dynojet https://www.youtube.com/watch?v=9Kw_...e_gdata_player


Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
Sponsored Links
Advertisement
 
post #2 of 27 Old 09-14-2012, 07:26 PM
Registered User
 
Trader Feedback: (5)
Join Date: Jun 2011
Location: United States
Posts: 201
did you ever dyno before the turbo? I would have expected more HP with 12lbs turbo.
I'm running a s trim with 12psi on a gt40 top end also. I made 290 NA, haven't been back since blower. I'm hoping for mid 400's. If not I'm going to need a new pulley

wkornf is offline  
post #3 of 27 Old 09-14-2012, 07:59 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
Never did dyno all motor. I'm happy with that power and torque from a. 62 mm

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
Sponsored Links
Advertisement
 
post #4 of 27 Old 09-14-2012, 10:17 PM
Registered User
 
Trader Feedback: (5)
Join Date: Jun 2011
Location: United States
Posts: 201
done much street driving yet, How is your part throttle acceleration? do you build any boost? I find with my s trim not much going on at part throttle.. When I go WOT I realize I need drag radials.
wkornf is offline  
post #5 of 27 Old 09-15-2012, 11:15 AM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
Drives real smooth with my cutoff closed drives and sounds like a stock mustang. Just cruising no boost but it spools very fast after 3k right around 3 its starting to make a f pound or 2

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #6 of 27 Old 09-15-2012, 02:12 PM
Registered User
 
MY 93 GT's Avatar
 
Trader Feedback: (11)
Join Date: Oct 2008
Location: New Jersey
Posts: 1,977
Really my cars spools very fast...i see boost coming in around 2500 could have as much as 10 psi around 4-4500 then it keeps climbing to 14 psi from there...if im driving say around 25 mph lean in to boost is in fast car just pulls very hard...When i was supercharged seemed like it had to be way up in the upper RPM to start pulling....

Turbo installed!!!!
87 GT Vert.On3 turbo making 14 psi,Trickflow TW 170cc heads,TF street heat intake,70mm TB,stock cam,1.6 roller rockers,Snow performance stage 2 meth kit,42# injectors,340 lph fuel pump,AOD,Lentech VB,electric OD 3000 stall.3.55's
MY 93 GT is offline  
post #7 of 27 Old 09-15-2012, 03:42 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
I have a crappy crossover pipe which I know is killing me. Thinking of starting a new thread. the smoking is bad, when its cold it takes a bit to start smoking. there's no smoking coming out of my dip stick it smokes at idle and when slowing down in gear pcv seems good I'm thinking valve seals or Turbo any input guys?

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi

Last edited by HeiH; 09-15-2012 at 03:45 PM.
HeiH is offline  
post #8 of 27 Old 09-15-2012, 04:53 PM
Registered User
 
93alexcoupe's Avatar
 
Trader Feedback: (0)
Join Date: Sep 2009
Location: Miami,FL
Posts: 653
I didnt really notice any smoke. Are you sure its making 12psi?

Built by Lujan Motorsports
Boss 308ci BullseyePower Turbo, ProEfi.
93alexcoupe is offline  
post #9 of 27 Old 09-15-2012, 05:10 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
Quote:
Originally Posted by 93alexcoupe View Post
I didnt really notice any smoke. Are you sure its making 12psi?
My boost gauge reads 12. It start smoking later after the dyno pulls

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #10 of 27 Old 09-16-2012, 03:38 AM
Registered User
 
Trader Feedback: (6)
Join Date: Mar 2011
Location: minnesota
Posts: 582
after i did 10 dyno pulls last year my car started smoking like crazy... i tore everything apart to figure it out and after weeks and weeks i come to find out i blew the intake gasket out and was sucking oil into the motor burning it.


maybe you might wanna check your intake gasket...

chevyguy15 is offline  
post #11 of 27 Old 09-16-2012, 11:55 AM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
Will do thank you. Maybe ill get on it today

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #12 of 27 Old 09-17-2012, 10:39 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
found this in my d/p having my turbo rebuilt


Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #13 of 27 Old 09-18-2012, 11:31 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
turbo is dead just ordered a 72mm

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #14 of 27 Old 09-19-2012, 09:18 AM
Registered User
 
Trader Feedback: (9)
Join Date: Apr 2003
Location: Windsor, ON Canada
Posts: 2,986
Quote:
Originally Posted by HeiH View Post
turbo is dead just ordered a 72mm
Nice! From where and what make?
FORCED87GT is offline  
post #15 of 27 Old 09-19-2012, 11:43 AM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
Garrett 72 102 locally from a shop called late model oil and water cooled its brand new but there doing some work on it for me

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #16 of 27 Old 09-19-2012, 02:39 PM
Registered User
 
98snakehorse's Avatar
 
Trader Feedback: (16)
Join Date: Oct 2011
Location: Oskaloosa Iowa
Posts: 739
Garage
Wow your hp levels sound similar to mine. What turbo kit are you running? What fuel are you using? My car made 420rwhp and 498ftlbs on 11psi 93 Octane. Im using the boost brothers turbo kit and a t67 turbo. DSS 331 stroker, tirckflow heads and cam, and cobra upper and lower. I believe my car should be putting out alot more but my dyno pulls were made in 105+ degree, high humidity weather.

98 Cobra_stock bs/exhaust [SOLD]
2000 s/c gt, 511rwh 450rwtq [SOLD]
1995 331 Turbo Gt, 420rwhp 498rwtq

1998Gt , Built 2v, Supercharged 518rwhp & 437rwtq
98snakehorse is offline  
post #17 of 27 Old 09-19-2012, 03:54 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
my kit is a diy kit. 93 octane 340 intake and 42 pound injectors. I believe you should be making a lot more as well. I know the heat kills my cars performance luckily we had nice weather here when I had it dynoed I'm thinking if my turbo was running with good efficiency it would have made more the the compressor wheel was touching the housing, the shaft was gone, the backplate was also rubbing pretty badly. What kind of turbo are you running at what timing?

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #18 of 27 Old 09-19-2012, 09:12 PM
Registered User
 
Trader Feedback: (20)
Join Date: Jan 2009
Location: Savannah, GA
Posts: 1,850
I'd put a vband connection on that downpipe if it were me. Just a suggestion. Never messed with a bolt together setup like that befor.

95 GT-306, cnc Victor Jr's,R intake, GT4788,Glide,E85,28's
95 cobra-MM suspension, bolt ons, DD
TRmustangTR is offline  
post #19 of 27 Old 09-19-2012, 09:41 PM
This space for rent
 
99FiveOh's Avatar
 
Trader Feedback: (54)
Join Date: Apr 2006
Location: J-Ville, FL
Posts: 6,727
Quote:
Originally Posted by 98snakehorse View Post
Wow your hp levels sound similar to mine. What turbo kit are you running? What fuel are you using? My car made 420rwhp and 498ftlbs on 11psi 93 Octane. Im using the boost brothers turbo kit and a t67 turbo. DSS 331 stroker, tirckflow heads and cam, and cobra upper and lower. I believe my car should be putting out alot more but my dyno pulls were made in 105+ degree, high humidity weather.
Sounds way underpowered. I thought when you had an intercooler ambient temps didn't matter much. I wonder how much total timing you're running.

2003 Cobra - 2.3 Whipple, Return style fuel system, dual Walbro GSS342 pumps, Aeromotive FPR, SCT BA3000 MAF, Accufab TB, SRA conversion, 604 rwhp, 581 rwtq

1995 GT - H pipe and welded in Flowmasters. Stock otherwise.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GT40 Aluminum heads, F-303 Cam, Holley Systemax intake, Procharger P600B kit 400 rwhp. Sold

Quote:
Originally Posted by kim View Post
There are two problems with the system. 1st is there are more parasites than hosts.... second, the parasites are allowed to vote.
99FiveOh is offline  
post #20 of 27 Old 09-19-2012, 09:46 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
it seals fine but it is a pain I think there throwing a v band in for me with the new but I'm unsure I think my exhaust housing is the same as the broken turbo so if not I'll just switch them

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #21 of 27 Old 09-24-2012, 06:49 PM
Registered User
 
98snakehorse's Avatar
 
Trader Feedback: (16)
Join Date: Oct 2011
Location: Oskaloosa Iowa
Posts: 739
Garage
Quote:
Originally Posted by HeiH View Post
my kit is a diy kit. 93 octane 340 intake and 42 pound injectors. I believe you should be making a lot more as well. I know the heat kills my cars performance luckily we had nice weather here when I had it dynoed I'm thinking if my turbo was running with good efficiency it would have made more the the compressor wheel was touching the housing, the shaft was gone, the backplate was also rubbing pretty badly. What kind of turbo are you running at what timing?
Turbo is a no name, china, journal bearing turbo. Im not sure the timing the tuner set all that up. I'm thinking I need to take it elsewhere to get tuned and on a cooler day. Everyone else thinks I should be well up to 500rwhp

98 Cobra_stock bs/exhaust [SOLD]
2000 s/c gt, 511rwh 450rwtq [SOLD]
1995 331 Turbo Gt, 420rwhp 498rwtq

1998Gt , Built 2v, Supercharged 518rwhp & 437rwtq
98snakehorse is offline  
post #22 of 27 Old 09-27-2012, 07:16 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
Yea I suggest the same 98snake.

Well I got the new Turbo in now the starter doesn't turn over. I pushed started the car and all the gauges went wild the coolant and oil pressure gauges were all the way over to the right amps were low as hell rpm was all over the place. Alternator is band new nit even a month old, battery checked out could the bad starter be causing a short as well? I have the car at 7pounds as of now didn't feel to strong not sure how high ill go or if ill even keep the car as of now thinking about trying to sell it again

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #23 of 27 Old 09-27-2012, 07:26 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268

Pic of new Turbo
Sucker produces some heat!

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #24 of 27 Old 09-27-2012, 11:51 PM
This space for rent
 
99FiveOh's Avatar
 
Trader Feedback: (54)
Join Date: Apr 2006
Location: J-Ville, FL
Posts: 6,727
That alternator sure won't enjoy the heat for too long!

2003 Cobra - 2.3 Whipple, Return style fuel system, dual Walbro GSS342 pumps, Aeromotive FPR, SCT BA3000 MAF, Accufab TB, SRA conversion, 604 rwhp, 581 rwtq

1995 GT - H pipe and welded in Flowmasters. Stock otherwise.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GT40 Aluminum heads, F-303 Cam, Holley Systemax intake, Procharger P600B kit 400 rwhp. Sold

Quote:
Originally Posted by kim View Post
There are two problems with the system. 1st is there are more parasites than hosts.... second, the parasites are allowed to vote.
99FiveOh is offline  
post #25 of 27 Old 09-28-2012, 08:28 PM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
Yea my last one is in heaven now do to the heat

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
post #26 of 27 Old 09-28-2012, 08:38 PM
This space for rent
 
99FiveOh's Avatar
 
Trader Feedback: (54)
Join Date: Apr 2006
Location: J-Ville, FL
Posts: 6,727
Quote:
Originally Posted by HeiH View Post
Yea my last one is in heaven now do to the heat
LMFAO!!!!

2003 Cobra - 2.3 Whipple, Return style fuel system, dual Walbro GSS342 pumps, Aeromotive FPR, SCT BA3000 MAF, Accufab TB, SRA conversion, 604 rwhp, 581 rwtq

1995 GT - H pipe and welded in Flowmasters. Stock otherwise.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GT40 Aluminum heads, F-303 Cam, Holley Systemax intake, Procharger P600B kit 400 rwhp. Sold

Quote:
Originally Posted by kim View Post
There are two problems with the system. 1st is there are more parasites than hosts.... second, the parasites are allowed to vote.
99FiveOh is offline  
post #27 of 27 Old 10-03-2012, 12:16 AM Thread Starter
Registered User
 
HeiH's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2012
Location: fort worth
Posts: 268
finally got it going damn anti theft system did me in. Have it at roughly 8 or 9 pounds goes back and fourth. Seeing boost at 3k about 2 pounds. At wot it feels a bit similar to my old turbos 12 pounds.

Stock block Bcam,gt40p,explorer intake 62mm turbonetics 12psi 42 pound injectors 340 pump all that extra jazz.
366/442 at 9psi
407/495 at 12psi
HeiH is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What Coolant/Antifreeze Do You Use? BTJustice GT & SOHC 13 12-26-2011 06:25 PM
For Sale 2003 Twin Turbo Cobra, Fully Built, Show Car cobramac Mustangs For Sale/Wanted, 1999-2004 4 07-09-2011 06:47 PM
Umass Motorsport Car Show 2011 April 30th Mopman93 Northeast 0 02-16-2011 05:55 PM
Finaly got my car back after a 2 hour stand off!! austinTX GT & SOHC 7 12-23-2001 03:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome