Need Help Air/Fuel running super rich now - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-26-2012, 05:13 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Feb 2012
Location: Maryville, TN
Posts: 49
Need Help Air/Fuel running super rich now

I have had my turbo kit on my 95 cobra for most of the summer and for the most part have had just minor issues. Well last week i blew 3rd out of my t5 so i replaced it with a 3550. Long story short the speedos were slightly different and i ran out of gas ( I trusted the odometer over the fuel gauge stupid mistake) But anyway since i ran out of gas the car has been running stupid rich like 10.0-11.0 at idle and the driveability has went to crap. I pulled the plugs and 3,4,5 and 8 were wet and the rest were clean. I replaced the o2 sensors and the plugs and its still doing the same thing. I also hooked my scanner and some goofy stuff was going on there too. The car stays in open loop and its throwing a trans temp out of range code 636.

Sorry this was so long. Any help is appreciated.

jd23fe is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-21-2012, 09:27 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Feb 2012
Location: Maryville, TN
Posts: 49
Update:
Figured Id answer my own question so maybe it could benefit someone in the future. Bought a set of ford racing 42lb injectors and swapped them for the on3 ones i have had since I put the turbo on. The car now starts, idles, and cruises like a stock machine. Apparently I had some injectors issues from the very beginning and running it out of gas just worsened the problem.

jd23fe is offline  
post #3 of 3 Old 09-22-2012, 05:12 PM
Registered User
 
Trader Feedback: (12)
Join Date: Mar 2004
Location: Terre Haute, IN
Posts: 1,247
Quote:
Originally Posted by jd23fe View Post
Update:
Figured Id answer my own question so maybe it could benefit someone in the future. Bought a set of ford racing 42lb injectors and swapped them for the on3 ones i have had since I put the turbo on. The car now starts, idles, and cruises like a stock machine. Apparently I had some injectors issues from the very beginning and running it out of gas just worsened the problem.
I've heard of a lot of problems from the knock-off injectors, most of their other parts seem decent for the money, though.

Turbocharged 87 GT T Top
XBL Tag: Mikemachine812
MJs89GT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tuned turbo'd 5.0 running rich. HOOKERBEAR Turbochargers 0 06-01-2012 06:50 AM
For Sale Brand New Jet Performance Ford programmer #15043 j.largent87 Electronics and Entertainment 3 06-27-2011 10:59 PM
306 running too rich. sduf344 5.0/5.8 Engine Tech 1 04-12-2011 10:47 PM
Running to rich. hustleman 5.0/5.8 Engine Tech 8 03-18-2002 03:20 PM
Car is running very rich..... Out50Stang 5.0/5.8 Engine Tech 4 12-05-2001 01:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome