on3 crossover problems.... - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 21 Old 07-15-2012, 09:19 PM Thread Starter
Registered User
 
johnny turbo5.0's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2011
Location: Maryland
Posts: 247
on3 crossover problems....

iv tried moving it every way possible... am i going to have to have somthing made it hits every time i tighten the v bands...






95gt stock
johnny turbo5.0 is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 07-15-2012, 09:26 PM
Registered User
 
Trader Feedback: (16)
Join Date: Aug 2011
Location: Indiana
Posts: 372
Had the exact same issue with my kit as well. I had to take it to a local shop where they lengthened the passenger side of the crossover and changed the angle. Also, after they fixed that issue, the wastegate no longer hit the vband on the crossover and could be installed with the dump tube facing out. Trust me, I messed with this forever as well to see if I could get it to fit and no matter what I tried it didnt work.


94 Rio Red Cobra, Trickflow 170s, F cam, T-moss ported lower, Fox intake swap, 3.73s
AJs94cobra is offline  
post #3 of 21 Old 07-15-2012, 09:35 PM Thread Starter
Registered User
 
johnny turbo5.0's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2011
Location: Maryland
Posts: 247
great.... how old is your kit

95gt stock
johnny turbo5.0 is offline  
Sponsored Links
Advertisement
 
post #4 of 21 Old 07-15-2012, 09:44 PM
Registered User
 
MY 93 GT's Avatar
 
Trader Feedback: (11)
Join Date: Oct 2008
Location: New Jersey
Posts: 1,977
Mine fits perfect...What motor mounts do you have?

Turbo installed!!!!
87 GT Vert.On3 turbo making 14 psi,Trickflow TW 170cc heads,TF street heat intake,70mm TB,stock cam,1.6 roller rockers,Snow performance stage 2 meth kit,42# injectors,340 lph fuel pump,AOD,Lentech VB,electric OD 3000 stall.3.55's
MY 93 GT is offline  
post #5 of 21 Old 07-15-2012, 09:50 PM Thread Starter
Registered User
 
johnny turbo5.0's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2011
Location: Maryland
Posts: 247
urethane... also this is on a sn95

95gt stock
johnny turbo5.0 is offline  
post #6 of 21 Old 07-15-2012, 10:04 PM
Registered User
 
Trader Feedback: (16)
Join Date: Aug 2011
Location: Indiana
Posts: 372
Motor mounts shouldn't matter. I got my kit in the fall of last year. Idk how far you have gotten but I ran into several other issues as well. Such as altering the rear flange of the downpipe and had a shop custom make some flow tubes to mate up with the y pipe. It was so far off I thought it was intended for another car.

Sent from my Inspire 4G using Tapatalk 2

94 Rio Red Cobra, Trickflow 170s, F cam, T-moss ported lower, Fox intake swap, 3.73s
AJs94cobra is offline  
post #7 of 21 Old 07-15-2012, 10:08 PM
Registered User
 
MY 93 GT's Avatar
 
Trader Feedback: (11)
Join Date: Oct 2008
Location: New Jersey
Posts: 1,977
Sorry mine is a fox body...mine fit with no issues....

Turbo installed!!!!
87 GT Vert.On3 turbo making 14 psi,Trickflow TW 170cc heads,TF street heat intake,70mm TB,stock cam,1.6 roller rockers,Snow performance stage 2 meth kit,42# injectors,340 lph fuel pump,AOD,Lentech VB,electric OD 3000 stall.3.55's
MY 93 GT is offline  
post #8 of 21 Old 07-15-2012, 10:55 PM
Registered User
 
Trader Feedback: (19)
Join Date: Nov 2002
Location: Youngstown, Ohio
Posts: 842
Quote:
Originally Posted by AJs94cobra View Post
Motor mounts shouldn't matter. I got my kit in the fall of last year. Idk how far you have gotten but I ran into several other issues as well. Such as altering the rear flange of the downpipe and had a shop custom make some flow tubes to mate up with the y pipe. It was so far off I thought it was intended for another car.

Sent from my Inspire 4G using Tapatalk 2
Actually you might want to watch because the aftermarket urethane mounts usually raise your motor some I have energy suspension ones and they raised my motor some and my turbo kit was hitting in places it never did before with the stock ones. This wasnt a on3 kit though by the way it was a old turbo engineering low mount setup. But figured for reference they do raise the motor.

Last edited by gerbenitz; 07-15-2012 at 11:02 PM.
gerbenitz is offline  
post #9 of 21 Old 07-15-2012, 11:05 PM
Registered User
 
Trader Feedback: (16)
Join Date: Aug 2011
Location: Indiana
Posts: 372
Quote:
Originally Posted by gerbenitz View Post
Actually you might want to watch because the aftermarket urethane mounts usually raise your motor some I have energy suspension ones and they raised my motor some and my turbo kit was hitting in places it never did before with the stock ones. This wasnt a on3 kit though by the way it was a old turbo engineering low mount setup. But figured for reference they do raise the motor.
True, you are correct. I should have been more specific. I just meant as far as the crossover issue he is having. Different mounts could cause other fitment issues.

94 Rio Red Cobra, Trickflow 170s, F cam, T-moss ported lower, Fox intake swap, 3.73s
AJs94cobra is offline  
post #10 of 21 Old 07-16-2012, 07:40 AM Thread Starter
Registered User
 
johnny turbo5.0's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2011
Location: Maryland
Posts: 247
I don't thinly its the mounts I am running aftermarket heads tho.. how much did your fix cost you aj. I am not running a y pipe


95gt stock
johnny turbo5.0 is offline  
post #11 of 21 Old 07-16-2012, 09:18 AM
Registered User
 
Trader Feedback: (16)
Join Date: Aug 2011
Location: Indiana
Posts: 372
It wasn't much. Maybe 40-50 bucks or so.

Sent from my Inspire 4G using Tapatalk 2

94 Rio Red Cobra, Trickflow 170s, F cam, T-moss ported lower, Fox intake swap, 3.73s
AJs94cobra is offline  
post #12 of 21 Old 07-16-2012, 09:54 AM
Registered User
 
Trader Feedback: (11)
Join Date: Jun 2001
Location: Meridian, Idaho,U.S.A.
Posts: 994
Since the crossover is mounted to the engine and not to the body, it makes no difference what mounts are in it when it comes to the relationship of the crossover to the balancer. Engine moves up, so does crossover, and visa versa.

1989 5.0 T5 LX Hatch - Explorer Short Block with an FMS F-303 cam, TFS TW170 heads, Tmoss Ported Cobra Intake, an On3 Turbo Kit with a 67mm Ceramic Ball Bearing Turbo, and backed by a T56 Magnum 6spd with 3.55's
MYSTICSVT is offline  
post #13 of 21 Old 07-16-2012, 12:31 PM
Registered User
 
Trader Feedback: (14)
Join Date: Jun 2005
Location: Woodland, CA....Nor Cal
Posts: 2,530
mine had the issue because of the size of my radiator...it would have been fine if stock

'18 Charger Hellcat
95 Cobra - Comp Billet PT8047 DIY Turbo and 340CI A4 Car
Palm Beach Dyno tuned - juuuuuuuust a little over 385RWHP....
RIP - Jerry"BabyLove" Glover ....1952 to 2012...
chinopsu is offline  
post #14 of 21 Old 07-16-2012, 04:27 PM
Registered User
 
mw95gt's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2011
Location: Michigan
Posts: 295
Quote:
Originally Posted by johnny turbo5.0 View Post
I don't thinly its the mounts I am running aftermarket heads tho.. how much did your fix cost you aj. I am not running a y pipe
What heads and are you running?

95gt Dart block 363, TEA 205 Heads. 78MM Turdblower Custom cam, All fab work done by me....Moates tuned by me, AODE done up, yep I got overdrive. Drag radials, 327 rear. Next setup to come over winter...lol
mw95gt is offline  
post #15 of 21 Old 07-16-2012, 04:45 PM
Registered User
 
SMOKEDYA's Avatar
 
Trader Feedback: (9)
Join Date: Dec 2005
Location: worshington
Posts: 939
Quote:
Originally Posted by gerbenitz View Post
Actually you might want to watch because the aftermarket urethane mounts usually raise your motor some I have energy suspension ones and they raised my motor some and my turbo kit was hitting in places it never did before with the stock ones. This wasnt a on3 kit though by the way it was a old turbo engineering low mount setup. But figured for reference they do raise the motor.
I really dont see your point here! You raise or lower the motor by useing diffrent mounts! Well you didnt raise or lower the heads which would cause the problem hes having. Its called a poorly made turbo kit
SMOKEDYA is offline  
post #16 of 21 Old 07-17-2012, 09:25 AM Thread Starter
Registered User
 
johnny turbo5.0's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2011
Location: Maryland
Posts: 247
Lmao chinopsu! And there track heat 170 heads

95gt stock
johnny turbo5.0 is offline  
post #17 of 21 Old 07-17-2012, 12:00 PM
Registered User
 
BobCat's Avatar
 
Trader Feedback: (2)
Join Date: Nov 2000
Location: Farmington, Mo
Posts: 439
We have had to deal with this issue a few times, just cut the V-band at the weld on the passenger side of the crossover and re-position it and it will be good to go.

94 GT 327 S-trim 4r70w yadda yadda

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BobCat is offline  
post #18 of 21 Old 07-17-2012, 12:38 PM
Authorized corral.net Advertiser
 
Trader Feedback: (13)
Join Date: Mar 2001
Location: Columbus
Posts: 2,829
If you wanted to mark that or have me add a section I can do that for you in order to drop that down
On 3 Performance is offline  
post #19 of 21 Old 07-17-2012, 07:10 PM
Registered User
 
Trader Feedback: (16)
Join Date: Aug 2011
Location: Indiana
Posts: 372
Quote:
Originally Posted by On 3 Performance View Post
If you wanted to mark that or have me add a section I can do that for you in order to drop that down
Not trying to get into an argument with you, but its nice to see you say this and be willing to fix it that easy.

94 Rio Red Cobra, Trickflow 170s, F cam, T-moss ported lower, Fox intake swap, 3.73s
AJs94cobra is offline  
post #20 of 21 Old 07-18-2012, 07:08 AM Thread Starter
Registered User
 
johnny turbo5.0's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2011
Location: Maryland
Posts: 247
Quote:
Originally Posted by On 3 Performance View Post
If you wanted to mark that or have me add a section I can do that for you in order to drop that down
That would be great and ill call you today thanks

95gt stock
johnny turbo5.0 is offline  
post #21 of 21 Old 07-18-2012, 03:43 PM Thread Starter
Registered User
 
johnny turbo5.0's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2011
Location: Maryland
Posts: 247
Problem solved thanks chad at on3 for the great customer service

95gt stock
johnny turbo5.0 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale On3 turbo headers and crossover pipe for 302 scs stang Windsor Engine Parts 0 07-10-2012 09:21 PM
on3 oilfilter adaptor problems Buds91LX Turbochargers 3 06-28-2012 05:53 PM
On3 Crossover flex pipe failure mw95gt Turbochargers 45 05-02-2012 10:49 AM
Help major problems after ON3 turbo install mdav Turbochargers 60 04-30-2012 12:31 AM
on3 turbo company...(horrible problems with kit) 99oRallyClipse Turbochargers 83 10-01-2011 11:57 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome