Tuned turbo'd 5.0 running rich. - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-01-2012, 06:50 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2012
Location: Utah
Posts: 17
Tuned turbo'd 5.0 running rich.

My turbo'd 5.0 is running super rich (wideband reads 10) and I can't figure out why. My setup is an On3Performance turbo setup with 42lb injectors(on3), walbro 255 fuel pump, and Pro-M blow-through MAF, and moates QH. Its tuned with BE/EA by Premier Performance in South Jordan, UT. The IAT, ECT, and TPS numbers don't change beyond their base values upon starting the car. You can rev it, let it warm up, and they still don't change. TPS doesn't go beyond .98 and doesn't change if you push the pedal. I replaced the fuel pressure regulator and it has two new HEGO's as well. What I find odd is when you start the car cold, AFRs start at stoich then it leans out a little more and then inches its way to 10:1. I got a 42 and 92 on KOER (big surprise there huh?). I will run another KOEO to see what it spits out and post them when i have more time. I'm getting extremely frustrated with this car so any help would be much appreciated.

HOOKERBEAR is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
running rich, tuned, turbo 5.0

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running to rich. hustleman 5.0/5.8 Engine Tech 8 03-18-2002 03:20 PM
Engine running rich racingisfun 5.0/5.8 Engine Tech 0 12-29-2001 03:19 PM
Running very rich with C&L 80 mm MAF, why? '00Stang GT & SOHC 16 12-26-2001 01:59 PM
New Motor running very rich at idle Todd Edge 5.0/5.8 Engine Tech 4 12-14-2001 03:58 PM
Car is running very rich..... Out50Stang 5.0/5.8 Engine Tech 4 12-05-2001 01:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome