Catch can smoking/vapors at idle - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-23-2012, 10:52 PM Thread Starter
Registered User
 
bwaite's Avatar
 
Trader Feedback: (19)
Join Date: Feb 2009
Location: Gettysburg, Pa
Posts: 1,195
Catch can smoking/vapors at idle

Hey guys. Have a new mmr motor.
I'm having oil vapors coming out of my jazz catch can. Is this normal?

I still have the Pcv on pass. Side. I'm running 5/8in hosses from each valve cover to the catch can.(breather on top) Not sure why it's smoking so much. But it also did this with my old short block.

Any way to fix this? Or is this normal. Motor is fine. No loss in any fluids. Runs great.

Thanks brett


2004 Mustang Sonic Blue - turbo- - MMR 4.75 900
bwaite is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-23-2012, 10:57 PM
Corral Elite Member
 
Trader Feedback: (9)
Join Date: Jul 2007
Location: Hurst, Texas
Posts: 3,565
Put some miles on the motor; break it in and seat the rings. Mine stopped almost overnight. Watch your breather cans for oil in them. I drove mine around with the valves open to see how much oil was coming out when I stopped. The spots got smaller and smaller then there was none.

My motor (see sig) took about 600 miles.


Dart 348ci, Ed Curtis cam/valvetrain, Precision 76mm, Holley Dominator EFI, CNP ignition, tons of Holler EFI small parts, 4"dp, 4R70W w/T-brake, new suspension coming soon.

Little 750rwhp at 6,000rpms and only 10lbs of boost before we just got tired of playing with clutches. New 4R70W and we are turning it up. Expecting 1,000rwhp.
kbscobravert is online now  
post #3 of 7 Old 05-23-2012, 11:26 PM Thread Starter
Registered User
 
bwaite's Avatar
 
Trader Feedback: (19)
Join Date: Feb 2009
Location: Gettysburg, Pa
Posts: 1,195
Quote:
Originally Posted by kbscobravert View Post
Put some miles on the motor; break it in and seat the rings. Mine stopped almost overnight. Watch your breather cans for oil in them. I drove mine around with the valves open to see how much oil was coming out when I stopped. The spots got smaller and smaller then there was none.

My motor (see sig) took about 600 miles.
well i already have 1000 miles on new motor. i dont think im getting any oil. just this orangish nasty smelling stuff. just emptied it tonight. this is what i got after 1000 miles.

im wondering if the vapors are condensation. since i have plastic valve covers and latly weather around here has bin raining humid. and cold nights. idk anything is possible. i just hope its nothing motor related. because i did everything 100% i tripled checked everything i did.

this is the same gunk that was coming out of my stock motor too.

2004 Mustang Sonic Blue - turbo- - MMR 4.75 900

Last edited by bwaite; 05-23-2012 at 11:30 PM.
bwaite is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 05-24-2012, 12:07 AM
Registered User
 
lightblade's Avatar
 
Trader Feedback: (6)
Join Date: Jul 2005
Location: Va Beach
Posts: 753
Condensation mixing with oil vapor, mmmm lol

07 Grabber Orange GT Prem/Vert/6060/3.55
S&H Twin turbo kit, 6262 oil-less Comp turbos
9:1 compression 281, turbo cams, e85
[email protected],[email protected]
lightblade is offline  
post #5 of 7 Old 05-24-2012, 11:13 PM
Jersey True Street Guy
 
mcj50's Avatar
 
Trader Feedback: (84)
Join Date: May 2002
Location: Wall NJ
Posts: 3,195
Small enough quantity that I wouldn't worry.

We drain mine after every few passes and a small amount comes out every time and it never looks like pristine oil out of a bottle.

Trans catch can does the same thing.

Atomized liquid looks funkier then stuff you drain out.

1989 Saleen 89-425 all original + Baer 6P Brakes
1990 Saleen 90-137 heavily modded
1989 Shadow Blue Metallic Hatchback LX
[email protected] -- 94mm T4 True Street Trim
Thanks: Baer, Haltech, UPR, National Parts Depot, Meziere, Weldon, BBRC
mcj50 is offline  
post #6 of 7 Old 05-24-2012, 11:14 PM
Jersey True Street Guy
 
mcj50's Avatar
 
Trader Feedback: (84)
Join Date: May 2002
Location: Wall NJ
Posts: 3,195
Quote:
Originally Posted by lightblade View Post
Condensation mixing with oil vapor, mmmm lol
Yeah, goes good on an overcooked burger.


1989 Saleen 89-425 all original + Baer 6P Brakes
1990 Saleen 90-137 heavily modded
1989 Shadow Blue Metallic Hatchback LX
[email protected] -- 94mm T4 True Street Trim
Thanks: Baer, Haltech, UPR, National Parts Depot, Meziere, Weldon, BBRC
mcj50 is offline  
post #7 of 7 Old 05-25-2012, 10:58 PM
Registered User
 
pkstang's Avatar
 
Trader Feedback: (162)
Join Date: Feb 2000
Location: Marlborough, MA
Posts: 7,504
looks similar to coffe shake aka bad headgasket...

scared the s**t out of me first time i saw it

'90 notch w/an "old school" cartech outlaw kit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


When The Results Disagree With The Theory: Believe The Results And Invent A New Theory
pkstang is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
open loop idle issue, tuned with PMS on dyno Camara77 5.0/5.8 Engine Tech 6 04-20-2012 02:14 PM
MAF C&L, installed, idle issue, backfire during decel, skip at cruise George_ORH 5.0/5.8 Engine Tech 23 04-13-2012 09:25 PM
Base idle reset & tune idle speed.... im4darush General Mustang Tech 6 02-02-2012 08:37 PM
Unhappy UK guy. Advice from tuning experts please brynmaxwell 94/95 Tech 20 01-08-2012 06:04 PM
Engine will not go into fast idle when started cold, causes? FormerlyBlue88Notch 5.0/5.8 Engine Tech 5 03-10-2011 09:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome