Poblem with on3 turbo install - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 35 Old 09-30-2011, 04:22 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
Poblem with on3 turbo install

Hi guys have friend I stall turbo turn on is throwing to much fuel he took out plugs came out white thought he needed tune order a burn chip feo
On 3 got it yesterday put on same problem it's shooting fuel from exhaust co
Compressor any help???

G'z rayo is offline  
Sponsored Links
Advertisement
 
post #2 of 35 Old 09-30-2011, 04:27 PM
Registered User
 
Trader Feedback: (14)
Join Date: Jun 2005
Location: Woodland, CA....Nor Cal
Posts: 2,530
God DAMN!!!!!!

chinopsu is offline  
post #3 of 35 Old 09-30-2011, 06:07 PM
Registered User
 
breakdown's Avatar
 
Trader Feedback: (0)
Join Date: Dec 2007
Location: Wilmington,NC
Posts: 317
ugh...what

2001 Ford Lightning-stock
1992 Ford Mustang-bolt ons+turbo. 11.8 @115. 1.64 60ft
breakdown is offline  
Sponsored Links
Advertisement
 
post #4 of 35 Old 09-30-2011, 06:10 PM
Registered User
 
nmcgrawj's Avatar
 
Trader Feedback: (2)
Join Date: Aug 2004
Location: Ann Arbor, Mi
Posts: 1,536
Quote:
Originally Posted by chinopsu View Post
God DAMN!!!!!!
Great post

Quote:
Originally Posted by G'z rayo View Post
Hi guys have friend I stall turbo turn on is throwing to much fuel he took out plugs came out white thought he needed tune order a burn chip feo
On 3 got it yesterday put on same problem it's shooting fuel from exhaust co
Compressor any help???
Is english not your first language? Posting from your phone? Add some grammar to the mix....will make it much easier to read.



How is the timing? That can cause flames to come out of the exhaust. Get a timing light on it....

-Nate
'95 GT
nmcgrawj is offline  
post #5 of 35 Old 09-30-2011, 06:13 PM
Registered User
 
nmcgrawj's Avatar
 
Trader Feedback: (2)
Join Date: Aug 2004
Location: Ann Arbor, Mi
Posts: 1,536
Quote:
Originally Posted by breakdown View Post
ugh...what
Is it ####ty grammar ?

Yep.


Can you figure out what he is trying to say?

Yep.


So why waste posts to give a guy a hard time with ZERO input to the thread? Wanna give him a hard time, fine. But at least add something positive. Ask a question to clarify....anything.



-Nate
'95 GT
nmcgrawj is offline  
post #6 of 35 Old 09-30-2011, 06:17 PM
Registered User
 
breakdown's Avatar
 
Trader Feedback: (0)
Join Date: Dec 2007
Location: Wilmington,NC
Posts: 317
lol why didnt you just help him out. why waste a post on complaining about me.
good one

2001 Ford Lightning-stock
1992 Ford Mustang-bolt ons+turbo. 11.8 @115. 1.64 60ft
breakdown is offline  
post #7 of 35 Old 09-30-2011, 06:49 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
Sorry guys I was in a rush and I'm using my iPhone lol
G'z rayo is offline  
post #8 of 35 Old 09-30-2011, 06:53 PM
Registered User
 
breakdown's Avatar
 
Trader Feedback: (0)
Join Date: Dec 2007
Location: Wilmington,NC
Posts: 317
haha no prob. what is your set up

2001 Ford Lightning-stock
1992 Ford Mustang-bolt ons+turbo. 11.8 @115. 1.64 60ft
breakdown is offline  
post #9 of 35 Old 09-30-2011, 06:57 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
frend of mine just installed a on3 70mm turbo on his 93 cobra.after he finished it started it up but it was pushing to much fuel. he took out the sparkplugs and they were all white i guess full of fuel. he thought maybe it needed a tune for it to run ok since the upgrade of injectors fuel pump. so he called on3 and they told him he needed a chip burned so he order it, yesterday he put it on and same thing had fuel coming out of the compressor and tailpipes. hes thinking maybe pinch return line on fuel pump??? any advise
G'z rayo is offline  
post #10 of 35 Old 09-30-2011, 07:24 PM
Registered User
 
Trader Feedback: (14)
Join Date: Jun 2005
Location: Woodland, CA....Nor Cal
Posts: 2,530
Quote:
Originally Posted by G'z rayo View Post
frend of mine just installed a on3 70mm turbo on his 93 cobra.after he finished it started it up but it was pushing to much fuel. he took out the sparkplugs and they were all white i guess full of fuel. he thought maybe it needed a tune for it to run ok since the upgrade of injectors fuel pump. so he called on3 and they told him he needed a chip burned so he order it, yesterday he put it on and same thing had fuel coming out of the compressor and tailpipes. hes thinking maybe pinch return line on fuel pump??? any advise
White = lean BTW...

also could be bad FPR and bad tune wouldn't cause the fuel issue....

chinopsu is offline  
post #11 of 35 Old 09-30-2011, 08:39 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
Ok but white not as in just the tip I mean as in the whole spark plug looked like if it had powder
G'z rayo is offline  
post #12 of 35 Old 09-30-2011, 08:43 PM
Registered User
 
Trader Feedback: (14)
Join Date: Jun 2005
Location: Woodland, CA....Nor Cal
Posts: 2,530
Quote:
Originally Posted by G'z rayo View Post
Ok but white not as in just the tip I mean as in the whole spark plug looked like if it had powder

correct...a fouled plug is wet and black..


chinopsu is offline  
post #13 of 35 Old 09-30-2011, 09:07 PM
Registered User
 
Trader Feedback: (22)
Join Date: Jun 2007
Location: Tennessee
Posts: 3,716
setups need too be custom tuned over several hours in the car. you cant just order a random chip and think everything is gonna be all good

03 Mustang GT
Turbo 2v
LS1KILR is offline  
post #14 of 35 Old 09-30-2011, 09:30 PM
Registered User
 
Trader Feedback: (17)
Join Date: Mar 2006
Location: nevada
Posts: 444
still what is the timeing at ? what is your fuel pressure set at ? your custom chip may be for more or less boost than your runing and more or less fuel pressure . as far as i knew on3 has a custom chip to get u to a tuner to burn a proper tune for the car which sounds like u need
allenpeake is offline  
post #15 of 35 Old 10-01-2011, 01:09 AM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
Timing is stock is a 93 cobra everything is originalwad running fine before he started doing everything all he hid was ad a fp regulator and pump injectors and the turbo
G'z rayo is offline  
post #16 of 35 Old 10-01-2011, 05:50 PM
Registered User
 
Trader Feedback: (41)
Join Date: Jun 2004
Location: The Big Apple
Posts: 3,470
When you ordered the chip did you tell him for a 93 Cobra? That setup will use a different chip.

New build in progress: Twin Gen 2 PT6466 352

Old combo:352 single 76mm turbo, 16psi, AOD, 9.41 @ 149mph, E85, 255/50/16 MT DR, 3500lb STREET car driven everywhere.
stangjumper is offline  
post #17 of 35 Old 10-01-2011, 06:45 PM
Registered User
 
Trader Feedback: (17)
Join Date: Mar 2006
Location: nevada
Posts: 444
Quote:
Originally Posted by G'z rayo View Post
Timing is stock is a 93 cobra everything is originalwad running fine before he started doing everything all he hid was ad a fp regulator and pump injectors and the turbo
are u using a 93 cobra computer they r set up for 24#injectors and same as the stock mass air may be the cause of all your problems and unless u have somethen to retard the timing it wont be runing for to long under boost
allenpeake is offline  
post #18 of 35 Old 10-01-2011, 11:40 PM
Registered User
 
nasty92lx's Avatar
 
Trader Feedback: (0)
Join Date: Mar 2011
Location: Kansas City, Missouri
Posts: 448
my question is how did he get fuel coming from the compressor side of the turbo? did i read that right?

I'm not a magazine racer, my car is actually fast.
I also have a Honda civic but, mine has a bigger, uglier driver.
nasty92lx is offline  
post #19 of 35 Old 10-01-2011, 11:56 PM
Registered User
 
nasty92lx's Avatar
 
Trader Feedback: (0)
Join Date: Mar 2011
Location: Kansas City, Missouri
Posts: 448
i did post # 9 op. how is it even possible to get fuel on the compressor side with an injected car? if it's running that rich you may have an injector stuck open, it's not very common but it does happen. and your plugs would be BLACK and shiny not white. If they're that white you are prolly super lean especially if it's all ashy which could mean you have a fpr NOT pinching off the return line which would cause a lean condition. and what's the timing set at. should be at around 10* base, but i'm not sure what kind of advance is dialed into a 93 cobra ecu probably more than what an A9L box has but i have no idea. there's a few things to check really need more info on the setup to give you a better answer.

I'm not a magazine racer, my car is actually fast.
I also have a Honda civic but, mine has a bigger, uglier driver.
nasty92lx is offline  
post #20 of 35 Old 10-03-2011, 10:50 AM
Registered User
 
g3mustang's Avatar
 
Trader Feedback: (18)
Join Date: Apr 2010
Location: Spingfield, mo
Posts: 1,378
what kind of injectors did you put in? when i installed brand new injectors one of them ws bad! it was stuck open all the time. would empty the fuel rail. in seconds. fuel would puddle in the crossover tube.

afr 185 heads, dss 331
Turbo build
g3mustang is offline  
post #21 of 35 Old 10-03-2011, 08:39 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
My bad guys plugs came out black like pic above here at his house now just change o2 sensor passenger sides are full of gas driver side are good yea is socking fuel right away from compressor behind blower and crossover
G'z rayo is offline  
post #22 of 35 Old 10-07-2011, 09:27 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
just wanted to tell you guys that car got fixit was one ofthe new cheap injectors that were soldto my friend. i drove that sucker yesterday all i got to say is im sold on going turbo im just scared lol hes is a 93 all stock even has air conditioner i got heads cam intake cant imagine how fast mine will be lol thanks for all the help guys
G'z rayo is offline  
post #23 of 35 Old 10-09-2011, 12:43 PM
Registered User
 
Trader Feedback: (0)
Join Date: May 2011
Location: frankfort ky
Posts: 49
mine is doing the same thing now, how would i check to see if one is stuck open?
90foxsleepr is offline  
post #24 of 35 Old 10-09-2011, 04:41 PM
Formerly eades5.0
 
4Jenna's Avatar
 
Trader Feedback: (24)
Join Date: Jul 2001
Location: AZ
Posts: 4,716
Quote:
Originally Posted by G'z rayo View Post
just wanted to tell you guys that car got fixit was one ofthe new cheap injectors that were soldto my friend. i drove that sucker yesterday all i got to say is im sold on going turbo im just scared lol hes is a 93 all stock even has air conditioner i got heads cam intake cant imagine how fast mine will be lol thanks for all the help guys
Glad you got it ironed out man!!

-CE

WWW.JENNABEARSFOUNDATION.ORG
4Jenna is offline  
post #25 of 35 Old 10-11-2011, 01:41 AM
Corral Elite Member
 
slosvo's Avatar
 
Trader Feedback: (14)
Join Date: Feb 2001
Location: murrieta ca
Posts: 1,236
Quote:
Originally Posted by 90foxsleepr View Post
mine is doing the same thing now, how would i check to see if one is stuck open?
lift the rail and just turn the key to prime the lines.. do one side at a time and if the injectors don't stay hold them in...

what injectors you using?
slosvo is offline  
post #26 of 35 Old 10-11-2011, 01:42 AM
Corral Elite Member
 
slosvo's Avatar
 
Trader Feedback: (14)
Join Date: Feb 2001
Location: murrieta ca
Posts: 1,236
Quote:
Originally Posted by G'z rayo View Post
just wanted to tell you guys that car got fixit was one ofthe new cheap injectors that were soldto my friend. i drove that sucker yesterday all i got to say is im sold on going turbo im just scared lol hes is a 93 all stock even has air conditioner i got heads cam intake cant imagine how fast mine will be lol thanks for all the help guys
what injectors were you guys using?
slosvo is offline  
post #27 of 35 Old 10-11-2011, 07:40 AM
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2006
Location: Ankara,Turkey
Posts: 148
Quote:
Originally Posted by slosvo View Post
what injectors were you guys using?
Yes what injectors and please edit your dost post stating that the problem is FIXED and was non-turbo related.
Expurple is offline  
post #28 of 35 Old 10-13-2011, 01:36 AM
Registered User
 
Gearhead559's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2006
Location: columbus,ohio
Posts: 873
set base timing at 10* with the timing connector out.

and are you sure its fuel, and not water coming out of the tails?

post a pic of the plugs. if its fuel, they are not going to be white. they will be soaked in fuel.

I am on3 dealer. message me for some killer deals
Gearhead559 is offline  
post #29 of 35 Old 10-18-2011, 09:13 AM
Registered User
 
Trader Feedback: (8)
Join Date: Jan 2003
Location: Wilson, NC
Posts: 189
Quote:
Originally Posted by slosvo View Post
what injectors were you guys using?
x2
lotzatoys is offline  
post #30 of 35 Old 10-24-2011, 04:11 AM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Apr 2011
Location: Pacoima Ca
Posts: 104
Some 42 on3 sold him cheap brand lol he sent them back and still waiting to get his money refunded lol
G'z rayo is offline  
post #31 of 35 Old 10-24-2011, 09:14 AM
Registered User
 
billyNOTnice's Avatar
 
Trader Feedback: (80)
Join Date: Feb 2005
Location: Huntingdon, 16652 Pennsylvania
Posts: 2,048
Quote:
Originally Posted by slosvo View Post
lift the rail and just turn the key to prime the lines.. do one side at a time and if the injectors don't stay hold them in...

what injectors you using?
This is probably not the best advice. Depending on what intake you have, you could probably look down through the lower with the rails attached and see if one is spraying.

As far as this thread goes. If you come on here expecting help, you could at least make sure you are giving us the correct information. Otherwise all you will be getting is random posts, most likely by people who have no idea wtf they are talking about. If you want real help, you need to take the time to clearly state the problems and concerns you are having. I'm not trying to be a jerk, just want you to consider that other people come along reading this mess trying to find the answer when they might have your same problem.

----------Dart 363 Turbo 93 Cobra #3193----------
--------------Magnum T56--------------
billyNOTnice is offline  
post #32 of 35 Old 10-24-2011, 12:51 PM
Corral Elite Member
 
slosvo's Avatar
 
Trader Feedback: (14)
Join Date: Feb 2001
Location: murrieta ca
Posts: 1,236
Quote:
Originally Posted by billyNOTnice View Post
This is probably not the best advice. Depending on what intake you have, you could probably look down through the lower with the rails attached and see if one is spraying.
Never had a problem doing it this way.. I'll guess that your fear is the possibility of fuel being sprayed all over the place?
slosvo is offline  
post #33 of 35 Old 10-24-2011, 01:22 PM
Registered User
 
billyNOTnice's Avatar
 
Trader Feedback: (80)
Join Date: Feb 2005
Location: Huntingdon, 16652 Pennsylvania
Posts: 2,048
not a fear. I've seen people catch their engine bay on fire.. literally lol.

----------Dart 363 Turbo 93 Cobra #3193----------
--------------Magnum T56--------------
billyNOTnice is offline  
post #34 of 35 Old 10-24-2011, 01:30 PM
Corral Elite Member
 
slosvo's Avatar
 
Trader Feedback: (14)
Join Date: Feb 2001
Location: murrieta ca
Posts: 1,236
must be bad luck.. I never have had one single issue.. even when the injectors wont stay.. I had to tie them down with bailing wire...but what ever you feel comfortable.. there was a guy at work that used to change fuel filters while smoking.. I was like WTF!!! car is on the rack, fuel pouring down is arm, cig in mouth with the smoke rolling into his eyes.. old school mechanic... used to change spark plugs with a speed wrench..
slosvo is offline  
post #35 of 35 Old 10-25-2011, 07:05 AM
Registered User
 
Rich G's Avatar
 
Trader Feedback: (35)
Join Date: May 2001
Location: West Palm Beach, Florida
Posts: 7,963
The best part of this post is the title.

Been out of the game since 2011.. looking to get back in in 2019
Rich G is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
On3 Performance Turbo Kit Install ModularSpeed SVT & DOHC 165 04-15-2016 11:05 AM
96 cobra ON3 turbo install whytry50 Turbochargers 22 03-31-2016 04:56 PM
On3 Performance Turbo Kit Install ModularSpeed Turbochargers 176 02-07-2012 11:52 AM
For Sale On3 Performance 2V kit with 66mm bb Turbo **PICS** blk003GT Power Adders 52 12-05-2011 08:24 AM
Turbo kit install document (On3) Larringt Turbochargers 0 08-10-2011 07:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome