Boost Brothers 3v Kit OR Why I need new pistons... - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-14-2011, 09:35 PM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Sep 2003
Location: Toledo, OH
Posts: 89
Boost Brothers 3v Kit OR Why I need new pistons...

After reading post after post about "Chinese" or "off-brand" parts, I wanted to share my actual experiences with a turbo kit from eBay.

Earlier this year, I picked up a "Boost Brothers" turbo kit for my 08 GT. I only gave $1100 for it. The kit arrived, I unpacked it and was extremely impressed with the quality of the welds and the finish of all the parts.

I started to acquire some supporting mods....

60 lb/hr injectors
BBK fuel rails
Diablosport MAFia
Aeromotive Stealth fuel pump
Kenne Bell Boost-A-Pump
Glow Shift Wideband, Fuel Pressure, and Boost Gauges
Turbonetics manual boost control

I began the installation and shortly after became frustrated with the fit of the piping. It is tight to say the least and I was forced to make some minor changes to the y pipe from the exhaust manifolds to make it not hit the pipe that connects to the factory over axle pipes. Some fasteners were missing or the wrong size. Also, the kit requires the use of a factory exhaust hanger on the transmission crossmember that my car did not have, so more fabrication.
After 2 full weekends and 1 week of evenings after work, the kit was on. Keep in mind, I am an ASE certified master tech, and I was working on a lift in my fully stocked home shop. This was not over a week laying on my back on the driveway. I would have lost my mind trying to install this kit without the car on a lift.

I searched for a shop to tune the car and eventually decided to deal with Jeff Chambers at CRT Performance. He sent me an SCT Xcal3 with a start up tune. The car fired right up with the tune and I drove it for a couple of weeks on the start up tune with the boost turned down. I worked out a couple of bugs and then it was off to Norwalk to hit the dyno.

First, let me say that Jeff Chambers was probably the best part of this whole project. He was able to identify a problem with the placement of my MAF, sent me home to fix it, and rescheduled me for a week later instead of wasting my time and money trying to tune the car an underlying problem.

The next week, Jeff hooked me up. 470 hp, 490 ft-lbs, 11 psi on 93 octane and near factory driveablity out of boost. The car HAD amazing power in 3rd and 4th gear but it took a little long to spool for my liking. I am guessing the lag could be attributed to the generic "pt67" unknown specification turbo that came with the kit.

That was Saturday, 6/11/2011.

Yesterday, 6/13/2011, my evening ended with an expressway on-ramp, 11 psi, and a cloud of smoke. I was not far from home, so I limped the car back, positive I blew the oil seal in that cheap turbocharger.

Tonight, I removed the turbo and found some shaft play as well as oil everywhere in the hot and cold side piping.

Unfortunately, my findings didn't end there. I was low on coolant and found it in the crankcase oil. Also, I had codes for cylinder 1 and 3 misfires, so I pulled those plugs. Both plugs were soaked in watery oil.

I'm not sure what broke or how, but lets just say that you can check the oil with the dipstick through the no. 1 spark plug hole.

I'll keep everyone posted as I learn more......

tricolor99 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-14-2011, 10:32 PM
Registered User
 
Blk.Snake's Avatar
 
Trader Feedback: (8)
Join Date: Jan 2009
Location: walled lake MI.
Posts: 1,390
wow.that sucks. How did the impeller look?That is why I will not even consider trying to save a few $ on an off brand or unknown dealer when I do mine. To much at stake. I have Just started to watch this forum and from some researching have read some real screwed up stories.


94 cobra, 393, afr 205s. boxr intake. (SOLD)
New 427 turbo build in progress.
Blk.Snake is offline  
post #3 of 4 Old 06-14-2011, 10:48 PM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Sep 2003
Location: Toledo, OH
Posts: 89
The impeller looked good, no signs that it touched down. It will be a while, but I'm anxious to get the motor torn down to see what actually failed internally. I read on here somewhere about a 3v making 440 hp biting the dust. I wonder if I just ended up with one of the "weak" engines.
tricolor99 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 06-14-2011, 11:00 PM
Registered User
 
longstroke's Avatar
 
Trader Feedback: (7)
Join Date: Mar 2009
Location: baxley, georgia
Posts: 294
FWIW, I've got a buddy that had a 05 3v and it broke a rod at 479rwhp with a saleen supercharger.
longstroke is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale Apexi AVCR boost controller 350$ obo 95stangsvt Electronics and Entertainment 0 05-15-2011 08:16 PM
For Sale Hellion Power Systems 96-04 Mustang Twin Turbo Kit *SALE* PowerAdder Solutions Power Adders 1 05-11-2011 01:32 PM
For Sale Complete Dry Nitrous kit, including WOT box and all wiring LTZ MACH Power Adders 8 02-22-2011 02:06 PM
For Sale Snow Performance Meth Injection Kit denverstang Power Adders 6 01-05-2011 02:06 PM
For Sale 94-95 Boost Brothers turbo Kit with extras 1fstdrp Power Adders 0 12-01-2010 12:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome