rich at idle lean under load - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 06-08-2011, 06:11 PM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Jun 2010
Location: us
Posts: 120
rich at idle lean under load

hey everyone, i have a 95 gt alm heads tfs intake 50# injectors matched to blow through pmas walbro 255 adjustable fpr, stock pcm. it idles at 11.3-11.8 afr on my WB, and driving around it goes way lean like 17.0. if my maf curve was wrong would it do that? should be lean or rich the hole way right? i have tried clocking the maf no change, also had fuel pressure from 30# up to 50# turning it up only helps a little under load brings it down to about 14.4 wot. im fuel pressure is not falling off. any help would be great. thanks.

R.Wireman is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 06-08-2011, 06:42 PM
Registered User
 
Trader Feedback: (8)
Join Date: Jun 2009
Location: Prescott, Ontario
Posts: 193
Do you have a boost reference fuel pressure regulator? Is it working correctly? It sounds like it isn't. It should pull fuel pressure out under vacuum and raise it with boost.

chiaj144 is offline  
post #3 of 8 Old 06-08-2011, 07:00 PM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Jun 2010
Location: us
Posts: 120
no its not boost ref but it is working right i set it at 50# NO vac, and hooked the vac up it pulls it down to like 42 ish, and under load/wot/boost it goes back to 50#
R.Wireman is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 06-08-2011, 07:38 PM
Registered User
 
90fiveoh's Avatar
 
Trader Feedback: (13)
Join Date: Mar 2008
Location: Michigan
Posts: 546
Sounds about right for a car with a big injector and no tune. Get it tuned

90 Turbo GT
90fiveoh is offline  
post #5 of 8 Old 06-08-2011, 09:42 PM
Registered User
 
mw95gt's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2011
Location: Michigan
Posts: 295
If you dont have some form of a chip or stand alone for a tune...I dont think it will ever be correct.

95gt Dart block 363, TEA 205 Heads. 78MM Turdblower Custom cam, All fab work done by me....Moates tuned by me, AODE done up, yep I got overdrive. Drag radials, 327 rear. Next setup to come over winter...lol
mw95gt is offline  
post #6 of 8 Old 06-09-2011, 03:13 PM
Registered User
 
Trader Feedback: (1)
Join Date: Sep 2003
Location: Bluffton, SC
Posts: 216
You should get a boost reference FPR, this will help clear up some of the problem. The other part of you problem is TIMING. How are you controlling the timing? Are you locking it to 18 or are you running a chip, PMS, ect?

93 Cobra # 2588
93 LX Notch
93mustang4me is offline  
post #7 of 8 Old 06-09-2011, 07:48 PM
Registered User
 
Trader Feedback: (8)
Join Date: Jun 2009
Location: Prescott, Ontario
Posts: 193
Quote:
Originally Posted by R.Wireman View Post
no its not boost ref but it is working right i set it at 50# NO vac, and hooked the vac up it pulls it down to like 42 ish, and under load/wot/boost it goes back to 50#
You need a boost referenced regulator. 50 is too high for a base. With a boost referenced reg. you would set it around 42 with the spout out vacuum would pull it down to 36 and 10psi would bring it back up to 52. That should give you a starting point. We have ran several cars like this some with locked timing some with a btm and they all worked well.
chiaj144 is offline  
post #8 of 8 Old 06-10-2011, 07:34 AM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Jun 2010
Location: us
Posts: 120
yes timing is locked at 18-20 also tried low boost like 3-4# with the timing set to 8* then put the sput connector in, also i have had my fuel pressure all over tired it from 30 with vac to 45 with vac and a few places in between. and heres whats got me lost this car ran great for a week or two afr was nice at idle and great in boost pulled like crazy, then one day all this happened.
R.Wireman is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle / Running Rich 85mustang-gt 5.0/5.8 Engine Tech 6 05-01-2011 12:28 AM
96 gt running rich and sputters under load above 2000 rpm blackmustang09 GT & SOHC 1 03-03-2011 08:40 PM
After suffering for 2 1/2 yrs, down to code 91 only! dannyUAL91GT 5.0/5.8 Engine Tech 10 01-27-2011 12:40 PM
New Motor running very rich at idle Todd Edge 5.0/5.8 Engine Tech 4 12-14-2001 03:58 PM
Rich at idle NOSLO50 5.0/5.8 Engine Tech 0 12-06-2001 12:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome