new to turbo need help, spools but no power guage shows boost - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 05-29-2011, 12:17 AM Thread Starter
Registered User
 
ias97's Avatar
 
Trader Feedback: (61)
Join Date: Mar 2007
Location: lititz pa (near lancaster)
Posts: 2,538
new to turbo need help, spools but no power guage shows boost

Okay here is a quick run down, fox body, stock 302 with 60mm turbonetics , had this motor turbo set up in another car and it ran fine until I blew a head gasket. Now thats fixed in a new car timing set at 8 degrees, car runs and drives fine, however when you step on it, I can hear the turbo spool and the mechanical guage shows boost however the car goes nowhere, in 3thrd it feels like it starts to pull a bit, then drops off quick almost like it just falls flat.I am thinking I could have a boost leak?? could it cause this any help would be great I have a msd box with a btm, I dont have the vac line on the btm yet. 42 pound injectors 255 intank pump

ias97 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 05-29-2011, 12:46 AM
Registered User
 
Trader Feedback: (55)
Join Date: Mar 2008
Location: Phoenix
Posts: 2,773
Have you confirmed thatthe vac lines your WG and BOV are connected to the correct ports?


92 Hatch On3 Turbo, T56
92 Vert 349 Lunati Stroker T5
87 Gt Eddy HCI T5
87 Notch in progress
fmyth is offline  
post #3 of 10 Old 05-29-2011, 06:02 AM Thread Starter
Registered User
 
ias97's Avatar
 
Trader Feedback: (61)
Join Date: Mar 2007
Location: lititz pa (near lancaster)
Posts: 2,538
yes, they both should be correct
ias97 is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 05-29-2011, 09:38 AM Thread Starter
Registered User
 
ias97's Avatar
 
Trader Feedback: (61)
Join Date: Mar 2007
Location: lititz pa (near lancaster)
Posts: 2,538
I tried going over some of the hose clamps and tightening stuff down, took it up the road , in third and fourth and it pulled as it was making boost about 5 pounds or so, turned it around and brought it back did the same thing and it fell flat, smells real rich almost raw gas
ias97 is offline  
post #5 of 10 Old 05-29-2011, 09:44 AM
Registered User
 
Rich G's Avatar
 
Trader Feedback: (35)
Join Date: May 2001
Location: West Palm Beach, Florida
Posts: 7,963
Souunds like it needs to be tuned

Been out of the game since 2011.. looking to get back in in 2019
Rich G is offline  
post #6 of 10 Old 05-29-2011, 11:39 AM Thread Starter
Registered User
 
ias97's Avatar
 
Trader Feedback: (61)
Join Date: Mar 2007
Location: lititz pa (near lancaster)
Posts: 2,538
I started thinking that maybe I am running out of fuel?
ias97 is offline  
post #7 of 10 Old 05-29-2011, 12:00 PM
Registered User
 
Trader Feedback: (55)
Join Date: Mar 2008
Location: Phoenix
Posts: 2,773
Quote:
Originally Posted by ias97 View Post
I started thinking that maybe I am running out of fuel?
If the exhaust smells like raw gas and burns your eyes its running too rich. You might want to trailer it to a tuner before you wash down the cylinder walls and end up with a much bigger problem.

92 Hatch On3 Turbo, T56
92 Vert 349 Lunati Stroker T5
87 Gt Eddy HCI T5
87 Notch in progress
fmyth is offline  
post #8 of 10 Old 05-30-2011, 01:11 AM
Registered User
 
red89coupe's Avatar
 
Trader Feedback: (31)
Join Date: Feb 2003
Location: Ohio
Posts: 3,318
boost leak.. NO !! if your gauge is on the intake and reads boost it has boost. a boost leak will cause you to hear the spool and get no readings. like a intercooler hose off will over spin the turbo trying to make boost but you wont see any at the intake. A vac leak will bleed off some boost (metered air) and cause a rich condition.

was the BTM hooked up in the old car?? was the timing at 8* before?
I run 10* with no BTM...

IF it ran good before (like mine did) then I dont see it being the tune all of a sudden it must be something that has changed.



I have pretty much same combo and had issues when I switched cars. I feel your pain !!!!!

NEVER do business with Sam Rivera AKA Sam Wilson.
red89coupe is offline  
post #9 of 10 Old 05-30-2011, 01:34 PM Thread Starter
Registered User
 
ias97's Avatar
 
Trader Feedback: (61)
Join Date: Mar 2007
Location: lititz pa (near lancaster)
Posts: 2,538
the old car ran fine, of course it needed fine tuned but nothing like now. the only difference I can see is, before I had no msd, and I know I had a 255 pump, the guy told me in this car that it had one, but now I am gonna pull the tank since I have a new one sitting here anyway. I just have a feeling nobody changed pump ever in the car, I am sure a stock pump can handle the airflow?? wouldnt that be correct, red89coupe, how much boost with 10 degree timing are you running.
ias97 is offline  
post #10 of 10 Old 05-30-2011, 02:38 PM
Registered User
 
red89coupe's Avatar
 
Trader Feedback: (31)
Join Date: Feb 2003
Location: Ohio
Posts: 3,318
Quote:
Originally Posted by ias97 View Post
the old car ran fine, of course it needed fine tuned but nothing like now. the only difference I can see is, before I had no msd, and I know I had a 255 pump, the guy told me in this car that it had one, but now I am gonna pull the tank since I have a new one sitting here anyway. I just have a feeling nobody changed pump ever in the car, I am sure a stock pump can handle the airflow?? wouldnt that be correct, red89coupe, how much boost with 10 degree timing are you running.

Thats exactly how mine was/is. I knew it needs/needed a good fine tune but it ran great before. everyone told me tune too but it should at least run as well as it did before.


no the stock 88lph pump will not keep up !!!!!! even the reg 255lph is not the best you need the HIGH pressure 255lph. IF you have any doubts about the pump I would not go getting into boost. do not want it going lean !!!!!!!

I run 10 psi.. I do have boost creep in 4th gear, it hits 12psi.. my wastegate is too small and poorly routed.
combo is stock motor,255 high pressure pump, 42s, pmas maf, 10* timing, 10 psi, MSD coil, currently no msd box and runs good.. no tune going on 15k mileage and 40 drag passes. I do have a fuel pressure gauge and a air/fuel. without them I could have easily blown it up trying to figure if i needed a tune or blown it up driving it when it was having issues. be very careful of that!!!!!!!! too lean you will need head gaskets again, too rich and like fmyth said... wash down the cylinder walls and end up with a much bigger problem.


NEVER do business with Sam Rivera AKA Sam Wilson.
red89coupe is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
MMR Forged Shortblock Specials, NOS, S/C or TURBO!! Mod Mustang Racing Modular Engine Parts 946 10-27-2015 05:17 PM
Mod Shootout 4v power adder class rules Dave King GT & SOHC 10 12-20-2001 03:51 PM
TDC DOHC info . . just recieved!!! BlackDemonGT GT & SOHC 36 12-16-2001 10:54 PM
Anybody heard from TDC about 4V turbos? SPI 99 Cobra GT & SOHC 94 12-11-2001 09:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome