car problems...need opinions - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-26-2011, 07:19 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2011
Location: Ocean, NJ
Posts: 48
car problems...need opinions

so i got this 95 mustang. turbocharged about 2 weeks ago. car seemed fine except it would start running hot if you drove it too long and i was told it needed a good rsadiator and fan instead of the stock rad and fan. so i put a new aluminum rad and 2800 cfm fans. here is what happens...car won't get hot if i baby it and don't get into boost. it has a t-60 turbo, stock heads, e-cam. so when i changed the radiator and fan i took it for a test drive. getting the turbo spooled up and beating it a bit to see if it could take it. well it got too hot again. the radiator and fan set-up should be able to handle cooling this engine without much problems. it is also putting a significant amount of white smoke out of the tailpipes. i'm thinking it has a blown headgasket. why wouldn't it be overheating until you let it get into boost though? alos i noticed what i think is too much bubbling in the radiator with the cap off. the oil looks good though...not milky at all and very clean. the antifreeze doesn't look like there is any oil in it either. its just weird to me that it runs pretty cool until i tach it out a bit and let the turbo spool up.

stangly04 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-26-2011, 07:46 PM
Registered User
 
Trader Feedback: (22)
Join Date: Mar 2009
Location: mt.sterling ky
Posts: 375
It could be your stock heads lifting when you get into boost, that would create alot of problems.

phillip_ 347 is offline  
post #3 of 6 Old 03-26-2011, 08:40 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2011
Location: Ocean, NJ
Posts: 48
Quote:
Originally Posted by phillip_ 347 View Post
It could be your stock heads lifting when you get into boost, that would create alot of problems.


is that something that happens with stock heads for some reason? its supposedly only running 8psi. i just drove it home which is a 20 minute ride. just babying it and it got pretty hot. which it didn't do before today really. also no heat....even though the heat worked fine this morning. something else i noticed which i found odd.....it has a fluidyne 2 core rad with a 2800cfm be cool dual fan set-up. the left fan (passenger side) was blowing warm air and the right fan (driver side) was blowing cold air. it has a 160 stat in it.
stangly04 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 03-26-2011, 11:29 PM
Registered User
 
Trader Feedback: (17)
Join Date: Mar 2006
Location: nevada
Posts: 444
what is your afr at are u on pump gas or e85 has it been tuned or are u doing it what is the timing set u may have let a head gasket go check with rad cap off when starting if its spews u blew it
allenpeake is offline  
post #5 of 6 Old 03-27-2011, 02:05 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2011
Location: Ocean, NJ
Posts: 48
Quote:
Originally Posted by allenpeake View Post
what is your afr at are u on pump gas or e85 has it been tuned or are u doing it what is the timing set u may have let a head gasket go check with rad cap off when starting if its spews u blew it

not sure what the afr is at...but i'm pretty sure it is running rich. this is on pump gas......super. it was tuned by radical racing when it was first built. i'm gonna check again in the morning but i think it is starting to spew when it is startd when the radiator cap is off.......which was another reason i thought head gasket......not sure what the timing is at never checked it. i didnt want to #### with it since i assume it was set when it was tuned. never had a turbo car and i didn't want to start messing with the timing.
stangly04 is offline  
post #6 of 6 Old 03-27-2011, 11:53 AM
Registered User
 
Trader Feedback: (17)
Join Date: Mar 2006
Location: nevada
Posts: 444
if it spews with cap off you have blown a gasket atleast
allenpeake is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale 1993 Ford Mustang Cobra Teal/Black - Amazing Car, Check it out. Mustang9 Mustangs For Sale/Wanted, 1987-1993 78 09-26-2011 11:14 AM
For Sale Roushcharged 2v coupe for sale or trade GoneNsixty Mustangs For Sale/Wanted, 1987-1993 135 07-23-2011 07:11 AM
For Sale 2003 Twin Turbo Cobra, Fully Built, Show Car cobramac Mustangs For Sale/Wanted, 1999-2004 4 07-09-2011 06:47 PM
new member..new car...new problems!!!! CobraGreen General Mustang Tech 10 09-22-2004 08:03 PM
Problems getting car in reverse WickedSnake GT & SOHC 4 01-04-2002 09:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome