what wideband to use? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 08-12-2010, 06:35 PM Thread Starter
Registered User
 
Trader Feedback: (6)
Join Date: Sep 2008
Location: north carolina
Posts: 211
what wideband to use?

what wideband is the best to use ?

mikeextrafast is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 08-12-2010, 08:15 PM
Registered User
 
UJUSTLOST's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2009
Location: Pleasant Valley, NY
Posts: 255
Not the Innovate LM-2, I have one and it's JUNK!
I had an Innovate LM-1 and that worked ok but had it's issues too

UJUSTLOST is offline  
post #3 of 12 Old 08-12-2010, 08:23 PM
Banned Alleged Scammer
 
Trader Feedback: (3)
Join Date: Oct 2008
Posts: 168
Quote:
Originally Posted by UJUSTLOST View Post
Not the Innovate LM-2, I have one and it's JUNK!
I had an Innovate LM-1 and that worked ok but had it's issues too
Been using the LM-1 for years and never had a problem with it. Used the LC-1 and G3 gauge on a turbo car and it worked great. Just bought the LM-2 but haven't used it yet. What kind of problems are you having with it?
Sponsored Links
Advertisement
 
post #4 of 12 Old 08-12-2010, 08:52 PM
Registered User
 
Trader Feedback: (0)
Join Date: May 2006
Location: Houston, Tx.
Posts: 4,744
AEM and LM1 usually get the best reviews

Democracy is two wolves and a sheep sitting down and voting on whats for lunch.
r.barn is offline  
post #5 of 12 Old 08-12-2010, 09:34 PM
Registered User
 
bwaite's Avatar
 
Trader Feedback: (19)
Join Date: Feb 2009
Location: Gettysburg, Pa
Posts: 1,195
have have the lc-1 works great
bwaite is offline  
post #6 of 12 Old 08-12-2010, 10:30 PM
Registered User
 
UJUSTLOST's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2009
Location: Pleasant Valley, NY
Posts: 255
[QUOTE=BenLX;9997750]Been using the LM-1 for years and never had a problem with it. Used the LC-1 and G3 gauge on a turbo car and it worked great. Just bought the LM-2 but haven't used it yet. What kind of problems are you having with it? [QUOTE]

Search the LM-2 you will see the problems people are having. I haven't even tried to get the RPM converter working yet, I can't even get it to read AFR consistently. My LM-1 I had to hard wire to get it to work without wacky spikes and stuff. There are much better products out there than the Innovate stuff. This is coming from a former diehard Innovate guy. Their stuff is just too inconsistent.
UJUSTLOST is offline  
post #7 of 12 Old 08-12-2010, 11:03 PM
Registered User
 
pkstang's Avatar
 
Trader Feedback: (162)
Join Date: Feb 2000
Location: Marlborough, MA
Posts: 7,504
LC1 here and love it although you should run a heat sink on the 02 when using on turbo cars.

i posted some info here
https://forums.corral.net/forums/show....php?t=1170069

'90 notch w/an "old school" cartech outlaw kit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


When The Results Disagree With The Theory: Believe The Results And Invent A New Theory
pkstang is offline  
post #8 of 12 Old 08-12-2010, 11:19 PM
Registered User
 
2002mustanggt's Avatar
 
Trader Feedback: (13)
Join Date: Jul 2007
Location: Las Vegas
Posts: 2,012
I have Aem wideband never had any problem.

Voodoo racing innovation built 4v , powerglide, borg warner s475 at 29psi, custome turbo kit , pro efi ecu, Aeromotive fuel pump, aeromotive fuel rails, id 1000 injectors, e85. Best to date 1.36 60'
Best pass to date 8.92 at 156mph. Best 1/8 mile 5.6at 127 mph.
2002mustanggt is offline  
post #9 of 12 Old 08-12-2010, 11:28 PM
Registered User
 
Gearhead559's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2006
Location: columbus,ohio
Posts: 873
Innovate ...i'll never use another aem again.

I am on3 dealer. message me for some killer deals
Gearhead559 is offline  
post #10 of 12 Old 08-12-2010, 11:46 PM
Registered User
 
Trader Feedback: (0)
Join Date: Jul 2004
Location: San Diego
Posts: 1,006
LM-1 here with no problems.

10secgoal is offline  
post #11 of 12 Old 08-13-2010, 01:10 AM
Registered User
 
Trader Feedback: (2)
Join Date: Feb 2010
Location: jax, fl.
Posts: 426
innovate all the way.
jaxboostedGT is offline  
post #12 of 12 Old 08-13-2010, 02:16 AM
Registered User
 
331D1SCGT's Avatar
 
Trader Feedback: (9)
Join Date: Dec 2001
Location: albany, ny
Posts: 1,047
aem datalogging into my quarterhorse, works awsome, and was dead on with what dyno's wideband read.

95GT: 302, TEA TFS heads, systemax, jay allen cam, t-70, 60lb inj, moates quarterhorse, dynamic c4, and so on...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


best so far (only pass on the car) 10.72 @ 123 (needs 3.27's)
331D1SCGT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
AEM Wideband svostang86 Electronics and Entertainment 3 09-21-2009 12:07 PM
AEM wideband Gauge-Type Wideband UEGO Controller Blown302stng Electronics and Entertainment 6 04-25-2008 10:38 PM
Guys with TwEECer RT and PLX Wideband I need help with installation PLX wideband Ernie302 94/95 Tech 11 08-27-2005 09:17 PM
2 MAF's, WideBand, PMS TurboNotchBack Electronics and Entertainment 24 11-02-2004 10:10 AM
Bung mounted wideband O2, verses tailpipe wideband O2, measuring A/F ratio? TxSnakeCharmer GT & SOHC 8 06-11-2002 04:47 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome