on3 first startup question - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-29-2010, 12:37 PM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Mar 2010
Location: Minnesota
Posts: 132
on3 first startup question

Just got my on3 kit running with a base tune and am using a pte 6765 turbo. Question I have is should the turbo be spinning even when the car idles down to like below 1000 rpm? It spins when I first start it and when it is idling higher but slows and stops when it idles down really low. Is the oil feed too small or what? Any help greatly appreciated thanks

01GTurbo is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-29-2010, 01:56 PM
Registered User
 
Blk4V00GT's Avatar
 
Trader Feedback: (10)
Join Date: May 2008
Location: Chattanooga TN
Posts: 416
Yes the turbo should be spinning while at idle, I would make sure the feed line is directly in the top of the turbo and that the feed line isn't kinked anywhere


1994 Mustang GT Coupe....
Blk4V00GT is offline  
post #3 of 4 Old 07-29-2010, 03:23 PM
Registered User
 
conbread's Avatar
 
Trader Feedback: (60)
Join Date: Jun 2005
Location: kannapolis NC
Posts: 1,942
make sure it doesnt have any exhaust leeks..
conbread is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 07-31-2010, 12:36 PM
Registered User
 
vorga's Avatar
 
Trader Feedback: (0)
Join Date: Mar 2010
Location: Houston TX
Posts: 201
Mine did the same thing . the bearings are packed with a thick grease when new. once the car worms up and pushes the clean oil from your motor into the turbo .It then should spin freely at idel. As long as everything else is set up correctly.
Here are 2 vids of my first start up and one after about a hr of ideling.
My car idels at around 800rpm 2nd vid i never touched the gas

http://s867.photobucket.com/albums/a...t=P6270072.mp4
http://s867.photobucket.com/albums/a...t=P6270073.mp4

2002 MustangGT,FRPP 70mm TB,TF plenum,1/2" Intake/plenum spacer,Qa1K member A arms,UPR Coilover,UPR 4Bolt CC,Tokico HP's,FL subframe connectors,UPR torque boxs,SVT Focus Fuel Pump,BAP,42lb injectors,Magnapacks,SCT X3,Pro-5.0 Shifter,3:55 Gears,On3 MP Turbo T70,EboostStreet,446whp/511wtq

Last edited by vorga; 07-31-2010 at 12:41 PM.
vorga is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New 347 startup Have a quick question. 94gt_vert_procharged 5.0/5.8 Engine Tech 6 04-28-2009 10:10 PM
First Startup (HELP) bigger_is_better 5.0/5.8 Engine Tech 28 02-25-2007 09:14 AM
lc-1 and xd-16 startup question DavidNC Engine Management Systems 0 02-14-2007 12:38 PM
New 5.0 startup beaglesfalcon 5.0/5.8 Engine Tech 5 05-21-2005 11:35 PM
Startup Idle question Ed McAndrew 5.0/5.8 Engine Tech 0 01-03-2002 08:33 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome