any one having a problem with hp performance - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-27-2010, 07:17 PM Thread Starter
eco
Registered User
 
Trader Feedback: (2)
Join Date: Feb 2010
Location: queens ny
Posts: 146
any one having a problem with hp performance

anyone having a problem with hpperformace i ordered to pipes from them and its ben 3 months and they giving me the run around same thing happened to my friend

eco is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-27-2010, 07:27 PM
Registered User
 
Radrick50's Avatar
 
Trader Feedback: (60)
Join Date: Aug 2000
Location: Altoona, PA, USA
Posts: 1,768
Oh man! You should have done some searching on this site and Turbomustangs.com before you decided to deal with them! Although their kit is a decent piece, they're customer service is the worst I've ever seen. It took my buddy 14 months to get his "complete" foxbody 302 turbo kit from them.

Good luck...I'd call the Better Business Bureau and see if they can help you out. Also, if you used a credit card, file a complaint with them.

Radrick50 is offline  
post #3 of 5 Old 04-27-2010, 10:17 PM
Registered User
 
y2k02's Avatar
 
Trader Feedback: (12)
Join Date: Jan 2003
Location: OHIO
Posts: 1,335
http://www.modularfords.com/forums/s...d.php?t=141618

2002 2V TF heads Custom Edelbrock NA SVT Cams
Twin 6466 TH400 Dominator EFI TH400 UCC
y2k02 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 04-28-2010, 02:06 AM
Registered User
 
Trader Feedback: (0)
Join Date: May 2006
Location: Houston, Tx.
Posts: 4,744
Quote:
Originally Posted by eco View Post
anyone having a problem with hpperformace i ordered to pipes from them and its ben 3 months and they giving me the run around same thing happened to my friend
normal. you only have another 3-6 months to wait now ..............


thought they had finally worked past this b.s. ................. guess not.

Democracy is two wolves and a sheep sitting down and voting on whats for lunch.
r.barn is offline  
post #5 of 5 Old 04-28-2010, 06:13 PM Thread Starter
eco
Registered User
 
Trader Feedback: (2)
Join Date: Feb 2010
Location: queens ny
Posts: 146
hp

thanks for the info crazy dont no how people do business like that
eco is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Performance Automatics tranny problem Dragonis GT & SOHC 4 05-03-2009 06:58 PM
Problem with my performance on 1/4 PoNyCaR50L Drag Racing 2 08-06-2003 03:48 PM
Performance problem update boo SVT & DOHC 4 06-08-2003 12:11 AM
Need help diagnosing 94 performance problem (Long) thecheat 94/95 Tech 3 06-05-2003 10:34 AM
C&C 76mm performance problem..input please rconnjr 5.0/5.8 Engine Tech 3 06-20-2002 12:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome