turbo headache, fixed! - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 07-04-2009, 12:53 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2004
Location: vancouver
Posts: 174
turbo headache, fixed!

well thought i would update everyone on my car for those who recall, went through 6 months to get my turbo kit from qt, with 500 buck of parts missing. got it all together and installed, and my motor went south,it was mostly because all the blasting media stuck inside the piping and it all went into the engine. i guess i should have checked but never thought about it. put a new motor in it and it ran awesome for the first 5 mins of warmup, then pouring out smoke. shut it down and pulled the downpipe and intake pipe off and its filled with oil. sent the turbo out, and the guy calls me and says its a non BB turbo, i paid QT for a BB precision. and he says someone put it together wrong. i dont know much about turbos but he said it had a spacer that only BB turbo use and snap rings were in which should be, or something like that.he changed the bushings and seals and rebalanced it for 300. put it back on and with the new Kurgan SCT tune so far it sounds and feels pretty good. going to put 300 or so street miles on it before i start to hammer on it.all in all the problems were a blessing,new dart iron block, i spent time to hide the wires in the engine bay, redo alot of old wiring and put my new jme gauge cluster in and wideband. i will post pics tommorow. just wanted to let you guys know i lurked alot to get some good info as i never have gone turbo before, just superchargers . thanks.

http://i40.tinypic.com/96w4g4.jpg
http://i39.tinypic.com/2ez4p79.jpg
http://i41.tinypic.com/2j2hxs8.jpg


Last edited by DR.GRIP; 07-04-2009 at 08:27 PM.
DR.GRIP is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-04-2009, 01:38 AM
Registered User
 
staticstang's Avatar
 
Trader Feedback: (4)
Join Date: Jun 2006
Location: Syracuse, IN
Posts: 352
Good Luck. Glad that you are getting everything dialed in.


93' SSP Notch 579hp/556tq - SOLD
00' GT 641hp/536tq - Novi 2K(17psi)
staticstang is offline  
post #3 of 9 Old 07-04-2009, 07:48 AM
Authorized corral.net Advertiser
 
Trader Feedback: (10)
Join Date: Oct 2003
Location: Braselton, GA
Posts: 3,684
glad that chip finally showed up! Im sure we will need to do some tweaking.. email me when you are ready to send it back for me to tweak it!

thanks bob

PLEASE EMAIL --->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<--- DO NOT PM for prices or tuning!

815-669-RACE (7223) <--- Sales

Please visit our e-store --->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<---

Chicagolands largest Vortech dealer since 2006!

We stock many parts! If you dont see it, just ask!

Before you buy ANY mustang part, give us a chance. We accept mastercard and visa.
Authorized SCT, AEM, Diablosport, Vortech, Paxton, BS3, FAST, UPR, PA Racing, Harland Sharp, Team Z, GMS, Trickflow, Kooks, and MANY MORE!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
flyin_hawaiin is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 07-04-2009, 12:46 PM
Registered User
 
Purple Haze's Avatar
 
Trader Feedback: (0)
Join Date: Nov 1999
Location: Texas
Posts: 2,092
So did you get your money back from QT for the non ball-bearing turbo?

How did the blasting media get left in the piping?
Purple Haze is offline  
post #5 of 9 Old 07-04-2009, 01:28 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2004
Location: vancouver
Posts: 174
bernards customer service is less than stellar, ie never answering calls. not sure how it got left in there, when i looked inside it was stuck to the inside walls of the pipe, i took laquer thinner and an engine cylinder bore brush and ran it through all the pipes, from what was still stuck inside the walls would probably fill half a shot glass with blasting media. i only checked because the engine builder who looked at my old motor said something was going through my motor , it only had 400 miles maybe and always ran a filter . when i took the piping apart to pull the motor i saw blasting media falling out of the pipes, i guess it got loose from the boost pressure and oil from the turbo.
DR.GRIP is offline  
post #6 of 9 Old 07-04-2009, 02:37 PM
Registered User
 
Trader Feedback: (12)
Join Date: Dec 2002
Location: la grange, kentucky
Posts: 2,428
ridiculous

2000 gt bright atlantic blue, 5 speed, procharger, built motor, cms stage 2 cams, lee blankenship tune, 430/405.
mustanginky is offline  
post #7 of 9 Old 07-12-2009, 10:06 PM
Registered User
 
Trader Feedback: (0)
Join Date: Jun 2006
Location: canada
Posts: 119
Hey Grip,what ever happened with your engine from "high performance engines"
in Van.?I was thinking about having one built by them.
edwardo is offline  
post #8 of 9 Old 07-12-2009, 11:17 PM
Registered User
 
92stanggt5.0's Avatar
 
Trader Feedback: (2)
Join Date: Feb 2005
Location: Minnesnowta
Posts: 393
That looks great in there. Glad everything is working out for ya.

1995 Cobra white/tan and a T64
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
92stanggt5.0 is offline  
post #9 of 9 Old 07-13-2009, 10:26 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2004
Location: vancouver
Posts: 174
Quote:
Originally Posted by edwardo View Post
Hey Grip,what ever happened with your engine from "high performance engines"
in Van.?I was thinking about having one built by them.
i went to them because of their reputation. the guy who built my new engine found that the orings in the block were all too high. but the biggest issue was that the oil pick up was resting on the bottom of the pan. he didnt find any problems with the rest of their work. during the build they did pay attention to small details so im not sure how they missed the oil pan pick up issue.
DR.GRIP is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
turbo compressiors map headache 5.0mustang5speed Turbochargers 4 04-29-2007 10:24 PM
baffleing headache XR7 5.0/5.8 Engine Tech 6 02-18-2007 12:19 PM
so i have a headache sprayed_pony SVT & DOHC 4 03-06-2006 09:23 PM
What a Headache MustangStrip 5.0/5.8 Engine Tech 1 03-24-2004 06:04 PM
those of you who have fixed your driveline vibration...what fixed it? neckdemon General Mustang Tech 4 02-24-2004 05:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome