Still running super rich - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-13-2009, 12:50 AM Thread Starter
Registered User
 
94saleengtvert's Avatar
 
Trader Feedback: (4)
Join Date: Nov 2006
Location: Scranton Pa
Posts: 468
Still running super rich

i made a thread about this around a month ago, but i havent really had time to work on it lately with my job keeping me busy.
Basically its so bad that i dont feel comfortable running it to try and diagnose the issue. I changed the plugs, they were just about dripping with fuel, my oil was getting contaminated with gas it was so bad, so i changed that(hopefully before any damage has taken place) so now i dont know where to go from here.
its running this bad even shortly after startup, so i dont think its my o2's. Maybe my MAF? i have not checked to see where the voltage is at during idle.
any single sensor that if bad, could throw it off that much dumping huge amounts of fuel? I'm going out of my mind here and almost no time to work on it so i have to have some sort of a game plan together before i start pulling things apart


96 Cobra: 5.0 swap, T5, On3 67mm BB turbo, Megasquirt, EDIS,
94saleengtvert is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-13-2009, 03:29 PM
Registered User
 
Trader Feedback: (7)
Join Date: Feb 2005
Location: Ohio
Posts: 465
Have you checked to make sure your fuel pressure regulator diaphragm isn't torn letting fuel get sucked into the intake?

Checked for fuel injectors leaking down/stuck open?

The coolant temp sensor can cause extra fuel to be added, but it shouldn't add THAT much fuel if it was faulty.

What maf is on the car?

Will

Teal94GT50 is offline  
post #3 of 5 Old 06-13-2009, 03:47 PM
Registered User
 
Trader Feedback: (2)
Join Date: Feb 2008
Location: ohio
Posts: 192
Are you actually tuning the car or are you band-aiding it with "calibrated MAF's"???

Nothing but slow chebby's right now.....
OrangeSVT03 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 06-14-2009, 12:51 PM Thread Starter
Registered User
 
94saleengtvert's Avatar
 
Trader Feedback: (4)
Join Date: Nov 2006
Location: Scranton Pa
Posts: 468
I'm running a 3" protube and 42's that are being tuned using a EECtuner. i dont think its the injectors sticking because when i changed the plugs they were all fouled with gas.
i was thinkng maybe the ECT as well, but i agree i dont think it would dump that much extra fuel. the FPR is something i havent checked yet but will do so today.

thanks for the advice so far, any other ideas?

96 Cobra: 5.0 swap, T5, On3 67mm BB turbo, Megasquirt, EDIS,
94saleengtvert is offline  
post #5 of 5 Old 06-15-2009, 10:23 PM
Registered User
 
Trader Feedback: (2)
Join Date: Feb 2008
Location: ohio
Posts: 192
Its more than likely in your MAF transfer function (in the tune)

Nothing but slow chebby's right now.....
OrangeSVT03 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1989 GT runs SUPER SUPER rich.... any ideas/help? ksstang 5.0/5.8 Engine Tech 14 01-28-2008 12:06 PM
help with running super rich nstycpe93 5.0/5.8 Engine Tech 1 04-18-2003 08:48 AM
heads + intake=super rich condition 2esoteric 5.0/5.8 Engine Tech 6 09-22-2002 08:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome