MAF help! - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 06-03-2009, 11:56 PM Thread Starter
Registered User
 
jasonlx's Avatar
 
Trader Feedback: (1)
Join Date: May 2008
Location: cape breton N.S.
Posts: 94
MAF help!

hey guy's, i'm lookin for some help with tuning my car. its a 93 lx with windsor jr's, track heat intake, custom cam, all supporting mod's and a hellion turbo kit (62-1).

i bought an abaco 85mm maf and am trying to tune the car myself. i tuned it for the 42# injectors i have and went for a drive, my wide band is pegged lean at idle but the car will water your eye's it smells so rich and while crusing its back firing through the intake the odd time or when i try to open the throttle much more then 1/4.

what i dont understand is while it smell's really rich at idle the wide band is dead lean. mabey its so rich its just dumping raw air and fuel out the exhaust? and also why would it be running lean at cruse if ts so rich at idle?

just lookin for some helpfull idea's guys, also if someone could post up a common maf transfer curve for 42#'s that would be a huge help. thanks for any reply's

jasonlx is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 06-04-2009, 01:10 PM
Registered User
 
jturmanator's Avatar
 
Trader Feedback: (7)
Join Date: Jul 2007
Location: MS
Posts: 2,069
Make sure your MAF is plugged in all the way. Mine did the same, the culpret was the MAF harness not plugged in completely. I'm running 60lb inj.


Stock block, GT40 heads, Explorer intake, 67mm, 10lbs, 431HP 497TQ on 110 octane. 12.01 @ 123
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jturmanator is offline  
post #3 of 9 Old 06-05-2009, 07:51 AM
Registered User
 
Trader Feedback: (12)
Join Date: Dec 2004
Location: Charles Town WV.
Posts: 433
lean will burn up your eyes and smell worse then rich does. I would trust the wide band over the nose any day if you are unsure maybe test it on another car or maybe find another one to try

Turbo 306,How fast will it go that depends on who is around.. Local parts pimp.. Things for sale most stuff is OBO https://docs.google.com/document/d/1hvqaA8aKICIw6BBj3IU2KCwiv86TtWXmxmvrsd8lw1A/edit?hl=en_US&pli=1#
wvstangdriver is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 06-05-2009, 02:26 PM Thread Starter
Registered User
 
jasonlx's Avatar
 
Trader Feedback: (1)
Join Date: May 2008
Location: cape breton N.S.
Posts: 94
thanks for the reply's


Quote:
lean will burn up your eyes and smell worse then rich does. I would trust the wide band over the nose any day if you are unsure maybe test it on another car or maybe find another one to try
now this i didn't know, i recalibrated the wideband to be sure it was accurate and it still did the same thing. now that i know this i just may have it solved
jasonlx is offline  
post #5 of 9 Old 06-05-2009, 06:57 PM
Registered User
 
Trader Feedback: (12)
Join Date: Dec 2004
Location: Charles Town WV.
Posts: 433
let us know how it works out

Turbo 306,How fast will it go that depends on who is around.. Local parts pimp.. Things for sale most stuff is OBO https://docs.google.com/document/d/1hvqaA8aKICIw6BBj3IU2KCwiv86TtWXmxmvrsd8lw1A/edit?hl=en_US&pli=1#
wvstangdriver is offline  
post #6 of 9 Old 06-05-2009, 11:11 PM Thread Starter
Registered User
 
jasonlx's Avatar
 
Trader Feedback: (1)
Join Date: May 2008
Location: cape breton N.S.
Posts: 94
so far i've gotten the car to work a little better, not as much fumes and eye burning lol. i have an innovate lc-1 wide band and no matter what i do at idle its pegged lean (22.4) has anyone ever had a problem like this? as soon as i touch the throttle its acts fairly normal. the cam shaft in the car is pretty lumpy sounding too, would this cause it to read really lean at only idle? it will sit there and idle all day long not a problem except that the wide band show's so lean. no matter what i do i cant get it to richen up the idle but everywhere else seems ok or close too it. thanks for the help so far guys, hopefully i can figure this out before i burn it
jasonlx is offline  
post #7 of 9 Old 06-06-2009, 06:28 AM
Registered User
 
Trader Feedback: (12)
Join Date: Dec 2004
Location: Charles Town WV.
Posts: 433
what are you tuning with ? can you open the injector dwell at idle? they use to have mass air transfers on Pro-ms site I don't know if they do now or not. I think all I have is big injector stuff. I will look for you today.

Turbo 306,How fast will it go that depends on who is around.. Local parts pimp.. Things for sale most stuff is OBO https://docs.google.com/document/d/1hvqaA8aKICIw6BBj3IU2KCwiv86TtWXmxmvrsd8lw1A/edit?hl=en_US&pli=1#
wvstangdriver is offline  
post #8 of 9 Old 06-06-2009, 07:56 AM
 
Trader Feedback: (0)
Join Date: Feb 2008
Posts: 44
Quote:
Originally Posted by jasonlx View Post
so far i've gotten the car to work a little better, not as much fumes and eye burning lol. i have an innovate lc-1 wide band and no matter what i do at idle its pegged lean (22.4) has anyone ever had a problem like this? as soon as i touch the throttle its acts fairly normal. the cam shaft in the car is pretty lumpy sounding too, would this cause it to read really lean at only idle? it will sit there and idle all day long not a problem except that the wide band show's so lean. no matter what i do i cant get it to richen up the idle but everywhere else seems ok or close too it. thanks for the help so far guys, hopefully i can figure this out before i burn it
mine does the same thing-but i had my car tuned-i think thats just what the lc1 does-when im driving it works like its supposed to and my tuner says as long as its workingexcept idle im fine
turbod89 is offline  
post #9 of 9 Old 06-06-2009, 10:27 PM Thread Starter
Registered User
 
jasonlx's Avatar
 
Trader Feedback: (1)
Join Date: May 2008
Location: cape breton N.S.
Posts: 94
Quote:
Originally Posted by turbod89 View Post
mine does the same thing-but i had my car tuned-i think thats just what the lc1 does-when im driving it works like its supposed to and my tuner says as long as its workingexcept idle im fine
this seems to be exactly what mine is doing, no matter what i change the lc-1 shows the same at idle. mabey thats just how it works and im focused to much on that. the car seems to idle great (way better then with the c&l meter) i'll mess with it some more soon and let everyone know. thanks for the heads up turbod89.
jasonlx is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale- 90mm ford lightning maf & maf extender Black 4.6 Beast Modular Engine Parts 3 11-13-2008 12:23 PM
FS: Stock MAF, Rubber Inlet Elbow & MAF Bracket - $75 EvinH Fuel System & Related 2 11-06-2007 08:50 PM
FS: Edelbrock Performer RPM, Pro-M Optimizer MAF, C&L MAF Andres2882 Windsor Engine Parts 2 06-01-2006 07:27 PM
What will happen if you swap a mass air sensor from a smaller maf into a larger maf? FHATTCATT EEC Tech 2 04-17-2005 04:51 AM
?'s about FMS Cobra Conversion 70MM MAF using stock MAF electronics... 91ConvLX 5.0/5.8 Engine Tech 2 12-12-2003 10:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome