do you think this is a bad - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-28-2009, 11:18 AM Thread Starter
Registered User
 
blown91stang's Avatar
 
Trader Feedback: (112)
Join Date: Aug 2001
Location: st louis mo
Posts: 2,775
do you think this is a bad

putting my mass air over the turbo...i will be getting a blanket btw..



blown91stang is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-28-2009, 11:54 AM
Registered User
 
Trader Feedback: (0)
Join Date: May 2006
Location: Houston, Tx.
Posts: 4,744
Put a good blanket on the turbo
and then I'd put a heat shield wrap around the MAF too

That bend before the MAF is not the greatest either.
The straighter the pipe before the MAF the better.

If you could move MAF where NX lable is would mo betta


Thermo-Tec makes all kinds of blankets and tapes for the MAF
http://store.summitracing.com/egnsearch.asp?N=400356


Democracy is two wolves and a sheep sitting down and voting on whats for lunch.
r.barn is offline  
post #3 of 3 Old 03-28-2009, 06:27 PM
Registered User
 
WHITEMACH's Avatar
 
Trader Feedback: (23)
Join Date: Feb 2008
Location: jensen beach FL
Posts: 1,235
if you get a GOOD blanky it will be fine!!
WHITEMACH is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 mustang BAD PI motor 2v 4.6l motor with block heads californiabratt Modular Engine Parts 1 04-06-2009 01:51 PM
91 notch 306 with bad vibrations bustah49 5.0/5.8 Engine Tech 13 03-20-2009 11:29 AM
HELP....engine revs but no power...bad tranny (AOD)? vegas93gt General Mustang Tech 3 03-19-2009 12:34 PM
Amps drop bad dont know why, Please Help! jermdawg General Mustang Tech 5 03-19-2009 11:17 AM
bad heater core? slo89stang General Mustang Tech 9 03-15-2009 08:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome