What if I pulled my Superchip? 1994 GT - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 01-09-2003, 05:18 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jul 2001
Location: Clemson, South Carolina
Posts: 241
What if I pulled my Superchip? 1994 GT

When i bought my 94 GT a few months back it already had trickflow heads, a comp cam camshaft, trickflow roller rockers, edelbrock upper and lower, and all the bolt ons (TB, MAF, cold air etc.). It also has a dual mode Superchip. I personally dont believe in superchips product, i feel that you have to be on a chasis dyno to really make a good chip. My question is, if i pulled the superchip, would I run into a big problem with the comp cam camshaft and the trickflow heads? Its an AOD-E car, but it just doesnt seem to have the power i would expect, my 99Gt runs with this thing, and that car only goes 13.8's. Thanks everyone.

Michael Reger


99 GT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reger99GT is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-09-2003, 05:53 PM
Registered User
 
Guarddog II's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2001
Location: Northern Virginia
Posts: 2,105
Do you know if it was tuned?

Does your car run fine now? Do you know if its a custom tune or mail order chip?

You can always pull it and try it, but go real easy.

You might be able to adjust for it with a fuel pressure regulator.

These are all options.

If the car is running fine, I'd leave it alone.

I'm in Alexandria, by the way....


95GT Vert; Do you want a list of whats in my garage or whats actually on my car?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Guarddog II is offline  
post #3 of 8 Old 01-10-2003, 01:18 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jul 2001
Location: Clemson, South Carolina
Posts: 241
thanks...

The car does run ok, but theres just a lot of power missing, I would think with all the parts on it, that it should be faster then 13.8's....its extremely choppy on start, (i think i might need a new IAC) it always wants to cut out when I start it, i have to play with the gas for 15-20 seconds. the cam is real choppy which doesnt help either. I dont think it was a custom burn, but am positive......I dont really think those things can do a lot though without the car being present when the chip is burned.

Michael

99 GT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reger99GT is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 01-10-2003, 09:30 AM
Registered User
 
Guarddog II's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2001
Location: Northern Virginia
Posts: 2,105
Hmmm...

I would do some searches on this site and others to see what kind of ET's are being run with your car. With your mods' I would guess 13.5 with a decent driver. Have you dyno'd it yet?

I have 95GT vert AOD-E (now a TKO after a conversion). and the thing is just slow. The car weighs 3800lbs and the AOD-E is sloppy. I'm assuming the chip firmed up your shifts because that is a basic thing that they do for AOD-E's....does make a difference.

You actually might be slower if you did gain more horsepower but lost the firm shifts.

Have you run this thing on a Dyno yet?

The slow starting/ stalling could be a number of things; bad 02 sensors, tune/chip, vacuum leak in the system, and a host of other items.

Again, you can always pull the chip and see what happens...takes about 15 minutes to do....

95GT Vert; Do you want a list of whats in my garage or whats actually on my car?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Guarddog II is offline  
post #5 of 8 Old 01-10-2003, 09:36 AM
Registered User
 
Guarddog II's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2001
Location: Northern Virginia
Posts: 2,105
another thing...

With the choppy starting, I'd pull the codes and see if there are any.

Go to AutoZone or wherever and get a code reader for $30 (might be cheaper). It comes with a book. Its like plugging in a socket into the reader. The "socket" is behind the passenger side strut tower brace--I think its attached to the wheel well. It literally looks like a big socket that you plug into the code reader (has a plastic cover over it--remove the cover and there is the plug-in).

Follow the directions and go from there...you might find some interesting and useful stuff in the codes. After that, clear the codes and see what happens.

If there are codes thrown, the car will revert to a "safe" mode and pull timing.

Oh, yeah...what is your timing set at? Should be 10 degrees with the spout pulled.

Keep me informed...sounds interesting.

95GT Vert; Do you want a list of whats in my garage or whats actually on my car?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Guarddog II; 01-10-2003 at 09:39 AM.
Guarddog II is offline  
post #6 of 8 Old 01-10-2003, 06:42 PM
Registered User
 
Trader Feedback: (2)
Join Date: Aug 2002
Location: dublin, oh
Posts: 307
you can pull the chip and it should still run fine. I was having a few problems and pulled my chip to try and isolate them but our computers are a little sluggish(especially a slushbox) w/o a little kick in the a$$. The chip will cause you to get a lot of codes if it is in. You don't necessarily have to buy a scanner, there are 2 plugs on the back side of the passenger strut tower and big one and a small one w/ one wire. Ground the one w/ one wire and then turn on the switch and the check engine light will flash your codes. You will just have to ask someone what they are since you won't have a book to tell you.
laidback is offline  
post #7 of 8 Old 01-10-2003, 09:26 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jul 2001
Location: Clemson, South Carolina
Posts: 241
I'm not actually getting codes....

The car runs alright, i get no codes when I drive it. I am just thinking that the chip is messing up my air fuel curves, and everything else. There is a lot of power missing in the car. I'll pull the chip this weekend and see what happens.

99 GT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reger99GT is offline  
post #8 of 8 Old 01-12-2003, 01:07 AM
Registered User
 
Guarddog II's Avatar
 
Trader Feedback: (8)
Join Date: Nov 2001
Location: Northern Virginia
Posts: 2,105
Cool...

Just remember that your car won't necessarily throw a "check engine" light if it has a code in memory...

95GT Vert; Do you want a list of whats in my garage or whats actually on my car?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Guarddog II is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale 1994 mustang gt pedal assembly Phoenix AZ OCHOHILL Interior Parts 0 03-31-2014 02:23 PM
For Sale Parting out 2002 Mustang GT bmwm3 Interior Parts 12 03-03-2014 08:07 PM
Behind the Smoke with Dai Yoshihara - The Series Discount Tire Discount Tire 24 11-03-2011 04:50 PM
For Sale 1994 Ford Mustang GT 5.0 H.O satyr36 Mustangs For Sale/Wanted, 1994-1998 2 08-20-2011 11:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome