rear defroster not working? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-13-2007, 10:28 PM Thread Starter
Registered User
 
Trader Feedback: (19)
Join Date: Feb 2001
Location: Tulsa,OK
Posts: 1,461
rear defroster not working?

the light on the switch comes on but nothing happens in the back window.....it satrting to get cold and i cant see out the freakin windows in the morning.......does anyone know which fuse or anything else to check? I lost my user manual....

thanks


1994 Cobra,stock motor,Tremec 3550,McLoed dual disc clutch,Billet steel flywheel,SFI bellhousing. Fox length Aluminum driveshaft with 5/8" spacer,Lowering springs,adjustable upper control arms,non adjustable lowers,FRPP Diff,31 spline Strange axles.17X9 10th anniversary wheels, 245/45/17,275/40.
bdhollie is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-14-2007, 05:42 AM
Registered User
 
homank76's Avatar
 
Trader Feedback: (8)
Join Date: Aug 2003
Location: South Korea, USAF
Posts: 804
Make sure that the electrical connections are still plugged in at the window.

If the light comes on, its not a fuse.


Typical 97 vert with 8-point roll bar.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
homank76 is offline  
post #3 of 5 Old 10-14-2007, 10:21 PM
Registered User
 
svpstang's Avatar
 
Trader Feedback: (0)
Join Date: Oct 2007
Location: Winnipeg, Manitoba
Posts: 46
I have a 95 as well & the Solder broke on my connector that right on the glass. To see if this is the problem, try "Bridging" the connection with some needlenose pliers, hold one to the metal part of the connector & one to the metal filament on the glass. You'll need to see a glass shop to repair the connection.

Last edited by svpstang; 10-28-2007 at 08:19 PM.
svpstang is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 10-17-2007, 07:13 PM
Registered User
 
j87gtmd's Avatar
 
Trader Feedback: (35)
Join Date: Jan 2007
Location: Taneytown MD
Posts: 333
You can also use a test light...even right on the grid for the defr.
mine got messed up when the glass guy was putting in the new window after paint job.
I used solder to fix it.

87 GT
j87gtmd is offline  
post #5 of 5 Old 10-28-2007, 08:20 PM
Registered User
 
svpstang's Avatar
 
Trader Feedback: (0)
Join Date: Oct 2007
Location: Winnipeg, Manitoba
Posts: 46
Quote:
Originally Posted by j87gtmd View Post
You can also use a test light...even right on the grid for the defr.
mine got messed up when the glass guy was putting in the new window after paint job.
I used solder to fix it.
Mine actually still dosen't work, I tried to solder myself & couldn't get it to hold on (since I was actually working upside down.) How'd you do it??
svpstang is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome