94 V6 electrical issues - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-12-2007, 10:54 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Dec 1999
Posts: 330
94 V6 electrical issues

My CD player was stolen a few months ago and I finally decided to replace it with another Kenwood. After I took the stock tape player out, I lost my interior lights, door locks, and power to the stereo. I don't think it's related, but my speedometer is no longer working either.

I'm thinking that all this is too much of a coincidence and that I had to have done something when I was taking the stock player out. I have checked the fuses under the hood and all of them are fine. I've also switched (but not replaced) both relays and that hasn't helped either. There are two empty relay slots and a couple of empty fuse slots, but everything was functioning fine before I did this so I don't think extra slots are the problem.

Can anyone give me any ideas?

92GreenMonster is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-05-2009, 05:07 PM
Registered User
 
Weaponrider87's Avatar
 
Trader Feedback: (6)
Join Date: Oct 2006
Location: circleville, ohio
Posts: 277
I heard of something like this before. check to make sure that the illumination wire for the stero isnt bare and shorting out somewhere.


2002 Mustang GT N/A 3.73 Richmond Gears, Auburn Pro Series Diff, Moser 31 Spline Axles, TKO 600, On3Performance 67mm Ball Bearing Turbo Kit.
Weaponrider87 is offline  
post #3 of 4 Old 05-05-2009, 05:39 PM
Registered User
 
Trader Feedback: (8)
Join Date: Jul 2003
Location: Charleston, SC
Posts: 547
Have you checked the fuses under the dash?

http://z.about.com/d/autorepair/1/0/Q/K/41874387.gif

Specifically, number 8?

No.. I'm not "Fast."
Quote:
Originally Posted by fkurls1 View Post
Simply awesome! Its like you came down from forum mountain with two stone tablets...
Fast94CobraSVT is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 05-11-2009, 12:26 PM
Registered User
 
Trader Feedback: (59)
Join Date: Feb 2009
Location: virginia
Posts: 2,964
its a fuse under your dash, a fuse under the dash gives power to everything that youve lost. check it
prddad1 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome