Pinging - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-26-2006, 09:23 PM Thread Starter
TTU
 
Trader Feedback: (0)
Join Date: Aug 2002
Posts: 10
Pinging

I have a 2000 v6 with approximately 80,000 miles on it. The car will not stop pinging. I replaced the fuel filter, cleaned the injectors (and throttle body) put a K & N air filter it it, and even took it to Firestone for one of thier "stop pinging treatments--I believe this is to clean out any backed up carbons in the cats"--none of this has worked.

Is there anything else I can do? replace MAF? I also strated using higher octane gas--same result. Thanks in advance.

TTU is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-26-2006, 11:46 PM
 
Trader Feedback: (0)
Join Date: Sep 2006
Posts: 24
I always put Premium in mine and never have a problem.. Give it a little bit after using the higher premium gas maybe put an octane booster in it, just incase u mixed the old gas new gas and the octane still isnt high enough..

ragedlonewolf is offline  
post #3 of 6 Old 09-27-2006, 08:49 PM
Registered User
 
Trader Feedback: (0)
Join Date: Sep 2006
Location: ludlow mass
Posts: 165
Quote:
Originally Posted by ragedlonewolf View Post
I always put Premium in mine and never have a problem.. Give it a little bit after using the higher premium gas maybe put an octane booster in it, just incase u mixed the old gas new gas and the octane still isnt high enough..
premium is useless unless you have a tune, you might of just gotten cheap gas thought

99 mustang gt 35th vert - bolt ons
09 f-350 lariat CCSB 5.4 - DD
04 f-350 RCLB 6.0 - sold
---8100 lbs 13.9 @ 96 tune/deleted, stock heads
mustangman022232 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 09-27-2006, 11:44 PM
 
Trader Feedback: (0)
Join Date: Sep 2006
Posts: 24
my car runs different if i dont put in premium..
ragedlonewolf is offline  
post #5 of 6 Old 10-13-2006, 11:18 PM
Registered User
 
h82lose's Avatar
 
Trader Feedback: (1)
Join Date: Feb 2005
Location: Ohio
Posts: 18
Quote:
Originally Posted by TTU View Post
I have a 2000 v6 with approximately 80,000 miles on it. The car will not stop pinging.

Is there anything else I can do?
Sure there's plenty you can do. I would start with spark plugs and wires. If that doesn't help, check the coil pack with a multimeter. That should get you on the right track. There isn't a check engine light is there?
h82lose is offline  
post #6 of 6 Old 10-15-2006, 07:20 PM
Registered User
 
Trader Feedback: (0)
Join Date: Sep 2006
Location: ludlow mass
Posts: 165
Quote:
Originally Posted by ragedlonewolf View Post
my car runs different if i dont put in premium..
then its either in your head or your getting cheap gas, if your car isnt tuned for premium, or running F/I (which requires a tune anyways) then you have no reason to run premium

99 mustang gt 35th vert - bolt ons
09 f-350 lariat CCSB 5.4 - DD
04 f-350 RCLB 6.0 - sold
---8100 lbs 13.9 @ 96 tune/deleted, stock heads
mustangman022232 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome