V6 EFI vs Carb - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-13-2006, 04:51 PM Thread Starter
Registered User
 
quikstang2's Avatar
 
Trader Feedback: (0)
Join Date: Jul 2006
Location: South Florida
Posts: 93
V6 EFI vs Carb

I took the 3.8L out of my '84 'vert and put it in another '84 coupe with a blown motor to try and resell it and make a little money. Between what's left of both the EFI systems the thing won't run right...or just won't run. I know the 'vert had a Cougar computer in it, so that may have caused some issues.
I saw an '83 3.8L at a local junk yard and ripped off all the parts that I thought I needed to carb it.
For some reason the distrubutor shaft is shorter than my EFI one and won't reach. Is there something else I need to get ahold of to make this work?
Also, is there an aftermarket carb intake manifold I can get or am I going to end up filling in a bunch of holes left by the sensors and smog crap that I don't need?

thanks,
mike

quikstang2 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-16-2006, 01:11 PM
Registered User
 
88CougarCoupe's Avatar
 
Trader Feedback: (0)
Join Date: Apr 2003
Location: north brunswick, nj
Posts: 598
somewhere i know their is a 4brl. carb intake someplace. i'll have to search the net. but i was gonna do it with my 3.8


Performance Automatic C4, TFS steet heat intake with 1inch spacer, GT-40's long tube headers, 24lbs. injectors, 65mm tb 3g alt Jegs Aluminum radiator., taurus fan (DCC)... and some Maximum Motorsports stuff, 5 lug w/ Bullets..... no numbers yet
88CougarCoupe is offline  
post #3 of 3 Old 08-16-2006, 09:42 PM Thread Starter
Registered User
 
quikstang2's Avatar
 
Trader Feedback: (0)
Join Date: Jul 2006
Location: South Florida
Posts: 93
Yes there is a 4brl carb conversion: http://www.moranav6racing.com/
They have everything.

Another bit of info I found is that there were two distributors for the '83 Stangs and the part number for CA and FL is #E3ZE12127.

Couldn't find anything about oil pumps being different which is what my dad thinks may be the problem.
quikstang2 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome