installed injectors and got rich codes - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 12-14-2005, 09:11 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
installed injectors and got rich codes

code 175 and the other side also what ever it is. in 2002 What I did was pull the 17# injectors and put in some 19# injectors. Then cranked the car. CEL came on at that time car would run but could not dog it. Then I sent my MAF to have it flowed for the 19's put it back in and the light stayed on, still could not dog it. Then I went and had Jerry dyno tune it. The car runs great but the light is still on. The car is not running rich. Why would the car run great and the rich codes still show up. Can the injectors I put in throw a code but still perform. I have changed the O2 sensors still have a light. HAS THIS EVER HAPPENED TO ANYBODY. I can reset the computer and the light will stay off no matter how far its drove, until I start it up the nest time. Then the moment the fan comes on the cel will come back on. I have replaced the etc sensor also. I ahve also replaced the dpfe sensor. thanks for any help


02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 12-15-2005, 04:26 AM
Registered User
 
homank76's Avatar
 
Trader Feedback: (8)
Join Date: Aug 2003
Location: South Korea, USAF
Posts: 804
Need to talk to your tuner then about the problem. Another problem might be the FMU, or least I hope you have an FMU if your pushing 14lbs of boost.

What kind of numbers you seeing any way? Before and after the Meth if you don't mind.


Typical 97 vert with 8-point roll bar.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
homank76 is offline  
post #3 of 17 Old 12-15-2005, 10:01 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
Yes, I have an FMU, the fuel system goes to 80 psi under boost. Jerry W. (sct)tuned my car back in 2002. We got 188rwhp with the 19's. He knew the light was on and tuning it did not remove the CEL. I am having a new v6 being built with all the go fast stuff. I will be running 17#'s boost so I needed cooling and went with the Snowperformance water injection. I got it instaled and running like it should. It was better judging by the sop. Since I was preparing my car for the new engine but running the stock engine I threw on a 2.62 pulley just to see how bad it would detonate. Well, it just barly did detonate. I pulled the timing plug and it did not detonate until I get to around 5 grand. I shift at 4700. There is alot of difference in the power output. This car is not my daily driver so it has been getting the crap drove out it. Ya know people come by and I say check this out and we go run it through the gears about four times. I show them after that how you can touch the TB and it will be cool to the touch but the discharge at the Vortech you can barley touch it. The upper intake is just barley warm. I am getting a Excalibrator II with that I will be able to give it more fuel and timing. The codes show rich condition but there is no damn way it's running rich.

02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
Sponsored Links
Advertisement
 
post #4 of 17 Old 12-15-2005, 02:01 PM
Registered User
 
Linc's 93 Splash's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2002
Location: Elm Mott, TEXAS
Posts: 2,805
hey Danny,

The mixture ratio can be just a ~tiny~ bit richer than the computer wants to see, and it will throw the C.E. light.

Now that you are getting the SCT that ~should~ hopefully fix your problems.

Dou you still run 4 O2's?
4 cat pipe too?

'93 Splash 5.0 - needs more traction

1997 GT 5-speed with 97 Mark VIII engine swap
Linc's 93 Splash is offline  
post #5 of 17 Old 12-15-2005, 02:16 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
I had it tuned (by the best) after the 19's were put in. I have magnaflow cats(2). I have traded the downstream O2's with a guy I know at Baylor. He did not get a cel. I put new o2's in the front and I think they did was hurt my gas milage some. I just think the injectors are doing something wrong. Tail pipes burn white and rusty colored. I had to flat black the id of the tail pipes so they would look better. Lincoln, if you are ever going through Bynum stop by the big grain tanks and check out my set up. Mustangs are in the garage. I was mainly asking if anybody has ever had injectors cause a cel but still run good. kinds sounds like a joke---looks bad but feels good----lol

02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
post #6 of 17 Old 12-15-2005, 02:26 PM
Registered User
 
Linc's 93 Splash's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2002
Location: Elm Mott, TEXAS
Posts: 2,805
I haven't seen white tailpipe insides since the days of leaded gas!!

You have one other option - pull the injectors and have them flow tested AND impedance tested.
Linc's 93 Splash is offline  
post #7 of 17 Old 12-15-2005, 06:50 PM
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 21
Where you getting the engine stuff from?
DAPACK69 is offline  
post #8 of 17 Old 12-17-2005, 12:41 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
Lincoln, I know little more rusty than white, not black like it should be, Ya know since it was the thing I did9change injectors) to get the CEL I should have just went back to the 17's, the car runs fine I just hate the light. Hell the gas milage stayed the same after the swap. I'll bet it's the inpedance like you said, if that would throw a CEL.

DAPACK69 I traded some 24#'ers I got off of Stece C. for the 19's. That someone I traded with is over at another forum. He said they had not been run much. I e-mailed him several times about the CEL and if the injectors could have caused it. He will not reply. I should have put in the 24's

02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
post #9 of 17 Old 12-17-2005, 12:49 AM
Registered User
 
homank76's Avatar
 
Trader Feedback: (8)
Join Date: Aug 2003
Location: South Korea, USAF
Posts: 804
You should just sell the injectors along with the FMU and pick up some 60 lb injectors and be done with it.

Typical 97 vert with 8-point roll bar.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by homank76; 12-17-2005 at 12:57 AM.
homank76 is offline  
post #10 of 17 Old 12-17-2005, 01:09 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
Now Homan, you know I going to put those in my new engine. 196,000 on this engine, I just don't think it is worth a 400 dollar dyno tune to go bigger injectors, plus the price of the injectors. What if I did the new injectors and the light still stayed on. I could just have them checked like Lincoln mentioned. Go ahead and say it,, just drive the damn thang,,,, to hell with the light. That's what they make black tape for. That CEL keeps me from modding up my GT. thanks guys


02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
post #11 of 17 Old 12-17-2005, 01:21 AM
Registered User
 
homank76's Avatar
 
Trader Feedback: (8)
Join Date: Aug 2003
Location: South Korea, USAF
Posts: 804
Who's building your new engine or at least where you getting parts from? I'm having Tom do mine.

Typical 97 vert with 8-point roll bar.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
homank76 is offline  
post #12 of 17 Old 12-17-2005, 02:14 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
A guy over by Waxahachie named Charlie Richardson. He's 70 years young. Been building race motors a long time and rear ends. Big Daddy Garlitis however ya spell it(ya know the guy that first started using the hemi in the rail jobs) signed his race license. He has one head done just need to copy it. I can say 280/165 cfm. He welds inside the head and grinds out like he wants it. uses some kind of clay mold to make ports the same. He's building a friend of his Grand National motor right now. He likes the v6 like we do for some reason. Hell he had an engine in a car at the SEMA show last year. a 440 Roadrunner with a Comp roller cam. That was for an old friend also. i watched him build it.

He is using the Supercoupe engine. He likes the type of iron it was cast with, more nickle or something.

Charlie is a Comp cam dealer, so cam will be custom ground

JE pistons


Tom is the real deal. You don't know how close I came to driving my car there for a new engine.

02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
post #13 of 17 Old 10-09-2006, 12:42 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
DAPACK69 I got the injectors from Gaston

02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
post #14 of 17 Old 10-09-2006, 06:45 PM
 
Trader Feedback: (0)
Join Date: Mar 2003
Posts: 21
Cool.

How did the engine rebuild go?
DAPACK69 is offline  
post #15 of 17 Old 10-09-2006, 08:11 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
It is still a work in progress. I'm floggin the hell out of this stock motor in the mean time.

02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
post #16 of 17 Old 10-10-2006, 02:50 AM
Registered User
 
Linc's 93 Splash's Avatar
 
Trader Feedback: (1)
Join Date: Mar 2002
Location: Elm Mott, TEXAS
Posts: 2,805
Quote:
Originally Posted by ginner View Post
It is still a work in progress. I'm floggin the hell out of this stock motor in the mean time.
Glad to hear its still holding up!

'93 Splash 5.0 - needs more traction

1997 GT 5-speed with 97 Mark VIII engine swap
Linc's 93 Splash is offline  
post #17 of 17 Old 10-10-2006, 08:34 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Oct 2005
Location: central Texas
Posts: 34
Linc, glad to hear from ya. Remeber if your ever in my area, come by the house. I need ya to take a ride in my 6banger. At the moment the passive anti theft system is acting up. It will crank but if I go somewhere it may strand me for a while. It does end up cranking after it sits a while. I am either taking it to Sycora Ford for repair or buy an excal 2. I plan on the later.

02 Mustang GT,5 spd, magnaflow cat back,excalibrator I, march ram air
97 v6 Mustang,5 spd,v1 Vortech 14#'s boost,Jerry tune,Snow Water /Meth injection
ginner is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome