2000 mustang V6 Missing Bad - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-14-2014, 02:39 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2009
Location: Reno, NV
Posts: 26
2000 mustang V6 Missing Bad

Here's one for the mustang tech gurus. I have a 2000 Mustang V6 I have tried everything I took it to my mechanic he misdiagnosed it needed a new engine because one of the cylinders had lowered compression we put a new engine in it from a similar model from 2001 V6 and we replace the engine because it had a miss. The car looks like it may have been a flood victim at one point in time. We have put new wires new Coil new spark plugs, tried numerous different firing orders including the ones from similar model years. It has a miss it runs okay but it's not quite right. This instance we have literally tried everything I replace the exhaust I have on many GT Mustangs but I just don't know that much about the v6. Help me out guys give me some ideas you always do!

91Saleen is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
4.6 DOHC question. Rfreeman37 SVT & DOHC 313 01-07-2014 10:35 PM
EXHAUSTED: One man's 4 month journey through the land of Mustang Exhaust...with video MikeLTDLX S-197 Mustang GT (2011-2014) 53 09-30-2013 08:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome