3.8L misfire - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 08-29-2013, 09:24 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Jul 2003
Location: Qtown PA
Posts: 115
3.8L misfire

I am at my end. I have a 1994 Mustang 3.8L Automatic.
Got a P30x code, which is cyl 2 misfire. I have done the following:
Replaced the coilpack, plugs and wires. Replace the #2 plug again just to be sure. Replaced the intake manifold gasket. Replaced the injector (with a used injector).

Compression test was good on #2. Spark good to the plug.
I would like to be able to test the injector and injector wiring to ensure that is not the problem.

(Also made a trip to the junk yard and got MAF, IAC, IAT and a couple other used parts, none made a difference)

PLEASE Help!!!



----------
94 3.8 Vert AOD
95 3.8 Vert AOD
98 3.8 Vert AOD
qtownhb is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 08-29-2013, 09:53 PM
Registered User
 
swetrid's Avatar
 
Trader Feedback: (16)
Join Date: Jul 2011
Location: Reading Pa
Posts: 789
Does is miss? Head gaskets were a major problem and a recall on 3.8L engine back in the day.


Ex Ford tech for last 17 years! 2016 Triple Yellow California Special
swetrid is offline  
post #3 of 10 Old 08-29-2013, 10:11 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Jul 2003
Location: Qtown PA
Posts: 115
Yes, it has a miss.
I did the compression test and it was ok. Thought that would rule out the head gasket

----------
94 3.8 Vert AOD
95 3.8 Vert AOD
98 3.8 Vert AOD
qtownhb is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 08-29-2013, 10:24 PM
Registered User
 
swetrid's Avatar
 
Trader Feedback: (16)
Join Date: Jul 2011
Location: Reading Pa
Posts: 789
Dead cylinder or intermittent miss?

Ex Ford tech for last 17 years! 2016 Triple Yellow California Special
swetrid is offline  
post #5 of 10 Old 08-29-2013, 11:54 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Jul 2003
Location: Qtown PA
Posts: 115
#2 is dead. Nothing seems to be able to bring this one back from the dead

----------
94 3.8 Vert AOD
95 3.8 Vert AOD
98 3.8 Vert AOD
qtownhb is offline  
post #6 of 10 Old 08-29-2013, 11:57 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Jul 2003
Location: Qtown PA
Posts: 115
is there a way to test the injector and the wiring to it? Did the ohms test and it passed. Would like to see that the injector is good before tackling a head gasket

----------
94 3.8 Vert AOD
95 3.8 Vert AOD
98 3.8 Vert AOD
qtownhb is offline  
post #7 of 10 Old 08-30-2013, 10:41 AM
Registered User
 
swetrid's Avatar
 
Trader Feedback: (16)
Join Date: Jul 2011
Location: Reading Pa
Posts: 789
It could be valve train problem. I would remove the valve cover and inspect rocker arms and pushrods and valve springs .

Ex Ford tech for last 17 years! 2016 Triple Yellow California Special
swetrid is offline  
post #8 of 10 Old 08-30-2013, 02:05 PM
Registered User
 
Trader Feedback: (0)
Join Date: Nov 2011
Location: Hawaii
Posts: 151
Try doing a block check and a leak down test too, as far as the injector, they have a tool that checks pulsing while the engine is running just by placing the probe on the injector body, try even doing a cooling system pressure test

Last edited by redkoa5; 08-30-2013 at 02:07 PM.
redkoa5 is offline  
post #9 of 10 Old 08-31-2013, 12:13 PM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Jul 2003
Location: Qtown PA
Posts: 115
Problem Solved

I was able to measure the resistance in each of the injector circuits. The dead cyl had a resisitance on the positive side, which should not have been there. I replaced the PCM, problem solved.

Thanks to everyone for your suggestions and tips.

----------
94 3.8 Vert AOD
95 3.8 Vert AOD
98 3.8 Vert AOD
qtownhb is offline  
post #10 of 10 Old 09-03-2013, 03:41 PM
Registered User
 
StalkerStang's Avatar
 
Trader Feedback: (13)
Join Date: Oct 2008
Location: Phoenix, AZ
Posts: 813
Garage
My old 94 V6 had an injector stick open. It was also the PCM. Seemed to be a common issue for that year.


90' LX________________2011 GT Premium, DD, manual
Previous 4 cyl.__________Brembo Package, Borla ATAK system
427W, in the works______JLT Intake, Tuned
StalkerStang is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Misfire at low RPM and when engine is under load sterry 5.0/5.8 Engine Tech 13 02-01-2016 08:53 AM
Carb 3.8L to EFI 3.8L swap 86caprirs Six Shooter 4 11-23-2015 08:44 PM
Junkyard Horsepower SUMMARY! slo5oh 5.0/5.8 Engine Tech 231 01-30-2015 11:35 PM
Small misfire question. bigcarfan GT & SOHC 2 11-05-2012 04:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome