3.8 problems - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-24-2013, 03:40 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jun 2013
Location: United States
Posts: 1
3.8 problems

So I bought my wife a 2001 ford mustang v6 auto. Shortly afterwards I ran a can of seafoam through it and the fuel pump and filter messed up. We had a mechanic repace it and then had to fix the clip that connects the fuel pressure sensor in. Well it has run bad ever since.

At first start it misses bad for a few sec then lines out. when you throttle on it it stumbles then goes. Its had codes ever since we had to replace the fuel pump. One of the codes is p0420 the other is a bad speed sensor on the right wheel. It also is throwing the evap code and the check gas cap. I replaced the gas cap. I hate to just throw money at this thing.


Last edited by dunning3075; 06-24-2013 at 03:43 PM.
dunning3075 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-26-2013, 07:58 PM
Registered User
 
Trader Feedback: (13)
Join Date: Jan 2013
Location: michigan
Posts: 269
With the p0420 check the code but i think thats an O2 sensor..have code read and see which one. Also look at the wires on the O2 sensors...loose or melted wires as well.
With the evap code is the vent properly on the gas tank?

warthogdriver is offline  
post #3 of 3 Old 09-20-2013, 11:06 PM
Registered User
 
badbrad's Avatar
 
Trader Feedback: (36)
Join Date: May 2009
Location: hueytown, alabama
Posts: 1,154
My 2001 is throwing a code po420 too...gonna gut the cats..

New project: 86 Coupe
9 previous Mustangs--all gone
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
badbrad is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
3.8 bell, 5.0 engine, and one unhappy starter... help please! ced715 94/95 Tech 8 05-21-2016 01:52 PM
Off road h-pipe from 94-98 3.8 on an 86 with 3.8 mleega1 General Mustang Tech 0 08-22-2012 05:36 PM
3.8 Question. What years are a direct bolt in for a '98 Stang? 90PandE General Mustang Tech 9 01-19-2012 03:31 PM
3.8 to 4.6 swap ???? 95stalker GT & SOHC 6 05-17-2010 12:17 PM
Problems w/ 1994 3.8 V6 Talisian General Mustang Tech 4 11-14-2002 12:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome