sluggish no low range power ???help!!! - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-23-2010, 08:46 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Dec 2005
Location: ashland,ky
Posts: 108
sluggish no low range power ???help!!!

alright guys i have had nothing but trouble of this thing its a 99 v6 5 speed car long story short just put another motor in and only problem i know is that i have an exhaust leak and code scanner said some emmisions but that was it i have replaced everything coil wires plugs mass air cleaned and iac cleaned looks good all vaccums are hooked up idle isnt up and down or anything lil rough but not on the tach just shakes the car anyways its is a turd taking off i mean it falls flat on it face any advice will be greatly appreciated....

8388stang is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'90 gt sluggish,no power? Marty White 5.0/5.8 Engine Tech 2 08-04-2008 12:30 PM
Sluggish to build RPMS; Part throttle bucking/loss of power... nidyanazo 5.0/5.8 Engine Tech 20 05-30-2007 04:37 AM
Help? Mid-range power gone xxx00SilverGTxxx GT & SOHC 1 08-04-2006 08:50 PM
66 coupe 289 V8 sluggish power CrazyStangdriver Classic Mustangs & Fords 3 09-02-2005 12:25 PM
Please Help!! Sluggish top end power 70+ mph Quick306 5.0/5.8 Engine Tech 5 05-31-2003 09:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome