Loud popping from rear? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-17-2005, 01:14 AM Thread Starter
Registered User
 
JJxUSAF's Avatar
 
Trader Feedback: (1)
Join Date: May 2003
Location: Rahway, NJ
Posts: 992
Loud popping from rear?

I have Bilstein rear shocks with H&R springs, HPM Megabyte Jr. lower control arms, Steeda upper control arms, and a MM Panhard Bar. I'm extremely happy with the setup, but...

ever since I put the car back together I have been getting this loud popping from the rear whenever I'm turning into a driveway and going over bumps. It's not all the time, just like I have to hit it the right way. Any ideas what it could be?


1995 Bright Sapphire GT

Killed the bugs...running like a raped ape.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JJxUSAF is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-17-2005, 12:19 PM
Registered User
 
Glenn's Avatar
 
Trader Feedback: (4)
Join Date: Jan 2000
Location: Cocoa, Florida
Posts: 3,627
It's probably the HPM LCA's. Correct me if I am wrong, but don't they use either a solid bushing or extremely rigid urethane at the ends? If so this induces bind when your car goes into roll. Something has to give and it is usually the torque boxes, not a good thing. Sell the HPM's and get some MM or Pro-3i arms with sphericals and 3 piece poly bushings.

Glenn is offline  
post #3 of 3 Old 10-17-2005, 01:51 PM
Registered User
 
Trader Feedback: (9)
Join Date: Apr 2003
Location: Windsor, ON Canada
Posts: 2,986
Quote:
Originally Posted by Glenn
It's probably the HPM LCA's. Correct me if I am wrong, but don't they use either a solid bushing or extremely rigid urethane at the ends? If so this induces bind when your car goes into roll. Something has to give and it is usually the torque boxes, not a good thing. Sell the HPM's and get some MM or Pro-3i arms with sphericals and 3 piece poly bushings.
I agree with Glenn. I had those LCA's and they did the same thing.
When I changed everything over to MM stuff. The popping was gone, and it never came back.
FORCED87GT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome