el-cheapo clutch working good for me - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-15-2005, 01:54 PM Thread Starter
Registered User
 
Han Solo's Avatar
 
Trader Feedback: (2)
Join Date: Apr 2004
Location: Miccosukee, FL
Posts: 1,417
el-cheapo clutch working good for me

Bought a clutch set from gripforce-clutches off ebay for $84 + $20 shipping. It included a disk and pressure plate made by Seco and also came with a pilot bearing, throw out bearing, and alignment tool. All of it looks like decent stuff. The rivets for the disk facing are smaller but there are twice as many of them. The disk and pressure plate weighed 1/2 lb less than the ones I took out. The clutch grabs very good and has a lighter feel than the stock one did. Only have a couple of days on it so if things change after autox or later I'll ammend the post.

My stock clutch started slipping a while back so I pondered several different units to replace it with. I finally decided to roll the dice on a cheap generic unit since the engine is basically stock and I didn't want to spend the bucks on a aluminum flywheel just yet. Still not sure why my stock clutch was slipping. Only had 80k on it. It didn't slip bad but the disk wear was nowhere near the rivets. Could have been pressure plate weakening or throw out bearing hanging on the coller it rides on. The TOB coller was real gummy.

The clutch was a PITA to change. Main problems are the top starter bolt, wiring bracket on top two tranny bolts, and the tight pilot bearing. A t-45 won't come out past the front converters and removing the front exhaust partially solves the top starter bolt access. It still required removal by the brail method with a 6" extension that has a wobble end. I'm not referring to a universal but an extension with a 3/8" drive shaped like a diamond instead of a square. The pilot bearing is extremely tight fitting and a standard slide hammer type puller just trashed the bearing and eventually slipped out of the hole. I finally screwed a 7/8" tap into what was left being the bearing housing and outer race. When I got the tap bottomed out and it started turning the engine I sprayed it with penetrating fluid and staerted bumping the handle of the adjustable wrench I was using to screw the tap in. I figured the tap would bottom on the crank then begin to pull the bearing as I screwed it in further. It actually started spinning the bearing in it's bore so I pryed on the outer lip while turning the wrench and eventually worked it out of the hole. Installing the new bearing with a socket and 2 1/2 lb sledge hammer took 10 or 12 solid whacks to seat it. Putting the tranny back in using a floor jack I ended up having to turn the jack towards the rear end so I could reach around the bell housing to position the wiring bracket out of the way to get the tranny in. First attempt I had it out of the way I thought and got the tranny in place then discovered it had slipped between the bell housing and engine. I had to slide the tranny back away from the engine about 1 1/2" to get room to reposition the bracket.

I am not affiliated with this company! Just passing along what I feel is a good value for guys like me with stock or lightly modified engines.

Han Solo is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome