Bilstein problem - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-21-2005, 01:25 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Nov 2004
Location: King of Prussia, PA
Posts: 161
Bilstein problem

I have Bilstein HD shocks and struts on an 02 GT vert with subframes and lower control arms. Stock springs/ride height. I'm getting some serious chirping on any non smooth roads. Is this normal?


2002 white/tan vert GT
Densecharger CAI, Lightning 90mm MAM, Accufab 75mm TB, Saleen Series IV SC, Bassani CB Exhaust/Xpipe, 42# injectors, MM lower Control Arms, Kenny Brown Subframe connectors, NGK TR6 plugs gapped at .035, bilstein shocks/struts, Aviator pump.
Car now has a steeda front splitter and stalker side skirts to it's a b***h to get under.
fallstar01 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome